Bug 202242 - Whole Plasma-Desktop freezes if an applet in system tray doesn't respond
Summary: Whole Plasma-Desktop freezes if an applet in system tray doesn't respond
Status: RESOLVED DUPLICATE of bug 184062
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-01 20:38 UTC by Simon Marti
Modified: 2009-08-02 22:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Marti 2009-08-01 20:38:30 UTC
Version:            (using KDE 4.2.98)
OS:                Linux
Installed from:    Ubuntu Packages

Often when I resume after my computer was in standby the nm-applet I use from the Gnome Desktop seems to hang while attempting to reconnect to the network. During this time not only this applet itself, but the whole Plasma Desktop freezes.
Is it somehow possible to avoid this behavior?
Thanks a lot for developing and debugging!
Comment 1 Dario Andres 2009-08-01 21:04:03 UTC
Is there a way to check this behaviour without the systrayapp ? 
There was also a freeze related to the Kickoff menu after resuming. (you could also try to remove that Kickoff and check if it works properly or no)
Thanks
Comment 2 Simon Marti 2009-08-01 23:06:09 UTC
(In reply to comment #1)
> Is there a way to check this behaviour without the systrayapp ? 
> There was also a freeze related to the Kickoff menu after resuming. (you could
> also try to remove that Kickoff and check if it works properly or no)
> Thanks

Thanks for the quick answer. Meanwhile I've tested this a bit better:

First I have to add an important detail, which I've forgot to mention in my original bug report: The freezing of plasma stops immediately when the nm-applet manages to establish a connection to the network.

What I also tested and noticed:
1. I removed the System-Tray-Plasmoid from the panel, but the behavior was the same as before. I think it's because this Plasmoid is only a "viewer" for this applets, which means they are still running in the background and therefore can still lead to the same problem.
2. I killed the nm-applet which I suspected as the trigger of the problem, but the result was even worse: Except for some short moments from time to time where there was a response, Plasma didn't stop to freeze. Finally I started the nm-applet again and after it had connected to the network the freezing was gone.

So I think it must be another part of Plasma or another system tray applet (Kopete?) which causes the freeze because it waits for a network connection.

Hope this helps a bit more.
Comment 3 Dario Andres 2009-08-01 23:21:48 UTC
If you removed the system tray plasmoid for testing and Plasma still suffered the freeze, then, there was no connection between nm-applet and Plasma; so it should be a different thing.

Can you try to remove the Kickoff menu (the "K" icon) just to test ?

Thanks
Comment 4 Simon Marti 2009-08-02 12:56:22 UTC
OK. Now I've tested it without the Kickoff menu and in fact the freezing has mostly disappeared! In one of three tested cases without the Kickoff menu there  was a little freeze but except for that the freezing has gone.
How is this possible? Does Kickoff wait for a network connection or something else to be provided after a suspend-to-RAM?

(In reply to comment #3)
> If you removed the system tray plasmoid for testing and Plasma still suffered
> the freeze, then, there was no connection between nm-applet and Plasma; so it
> should be a different thing.
> 
> Can you try to remove the Kickoff menu (the "K" icon) just to test ?
> 
> Thanks
Comment 5 Dario Andres 2009-08-02 17:31:04 UTC
Do you have any NFS mount? (like bug 184062) ? Thanks
Comment 6 Simon Marti 2009-08-02 22:40:31 UTC
Not NFS but an SMB-Share mounted over cifs. So Kickoff tries to look for the contents of this share and hangs because this is impossible without a network connection?

(In reply to comment #5)
> Do you have any NFS mount? (like bug 184062) ? Thanks
Comment 7 Dario Andres 2009-08-02 22:42:41 UTC
Yes, it seems that way. Merging with bug 184062. Thanks

*** This bug has been marked as a duplicate of bug 184062 ***