Bug 202200 - Konqueror crash on exit cleanup after few heavy javascript page loaded in tab
Summary: Konqueror crash on exit cleanup after few heavy javascript page loaded in tab
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-08-01 13:55 UTC by rapsys
Modified: 2009-08-01 15:53 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rapsys 2009-08-01 13:55:37 UTC
Application that crashed: konqueror
Version of the application: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
KDE Version: 4.2.98 (KDE 4.2.98 (KDE 4.3 RC3))
Qt Version: 4.5.2
Operating System: Linux 2.6.31-server-0.rc4.1mnb i686
Distribution: "Mandriva Linux 2009.1"

What I was doing when the application crashed:
I loaded various facebook pages.

After finished my browsing i closed the window via top right close button, then it crashed in the cleanup.

The pages were open in 3 tabes.

My facebook brosing included friend request/inbox/and friend profiles.

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0xb5ef2a80 (LWP 24821))]

Thread 2 (Thread 0xae6e7b70 (LWP 1714)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb67cade1 in select () from /lib/i686/libc.so.6
#2  0xb7eb97ac in QProcessManager::run (this=0x9a386e8) at io/qprocess_unix.cpp:296
#3  0xb7de3143 in QThreadPrivate::start (arg=0x9a386e8) at thread/qthread_unix.cpp:188
#4  0xb7d848e5 in start_thread () from /lib/i686/libpthread.so.0
#5  0xb67d2bbe in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb5ef2a80 (LWP 24821)):
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb67239e1 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb6725374 in abort () at abort.c:88
#9  0xb671c83e in __assert_fail (assertion=0xb2eb304d "!s_refcnt", file=0xb2eb2fbc "/home/mandrake/rpm/BUILD/kdelibs-4.2.98/khtml/khtml_global.cpp", line=258, 
    function=0xb2eb31c0 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#10 0xb2b08dcc in KHTMLGlobal::finalCheck () at /usr/src/debug/kdelibs-4.2.98/khtml/khtml_global.cpp:258
#11 0xb34a60c5 in ~KHTMLFactory (this=0x9ec6168) at /usr/src/debug/kdelibs-4.2.98/khtml/khtml_factory.cpp:35
#12 0xb7cd4000 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x9eb1320}, end={i = 0x9ec6110}) at /usr/lib/qt4/include/QtCore/qalgorithms.h:350
#13 0xb7cd4079 in qDeleteAll<FactoryHash> (c=@0x9ec6378) at /usr/lib/qt4/include/QtCore/qalgorithms.h:358
#14 0xb7cd42a0 in ~FactoryHash (this=0x9ec6378) at /usr/src/debug/kdelibs-4.2.98/kdecore/util/klibrary.cpp:93
#15 0xb7cd303d in destroy () at /usr/src/debug/kdelibs-4.2.98/kdecore/util/klibrary.cpp:97
#16 0xb7ba4769 in ~KCleanUpGlobalStatic (this=0xb7d7e470) at /usr/src/debug/kdelibs-4.2.98/kdecore/kernel/kglobal.h:62
#17 0xb6726b1f in __run_exit_handlers (status=0, listp=0xb685a304, run_list_atexit=true) at exit.c:78
#18 0xb6726b8f in exit (status=0) at exit.c:100
#19 0x0804dbdc in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=1, envs=0x99fb494 "DISPLAY=:0.0", reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x8051c48 "0") at /usr/src/debug/kdelibs-4.2.98/kinit/kinit.cpp:676
#20 0x0804e345 in handle_launcher_request (sock=7, who=<value optimized out>) at /usr/src/debug/kdelibs-4.2.98/kinit/kinit.cpp:1168
#21 0x0804f0b4 in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.2.98/kinit/kinit.cpp:1361
#22 0x0804f945 in main (argc=2, argv=0xbf81c634, envp=0xbf81c640) at /usr/src/debug/kdelibs-4.2.98/kinit/kinit.cpp:1788

Reported using DrKonqi
Comment 1 Dario Andres 2009-08-01 15:53:29 UTC
Merging with bug 151453. Thanks!

*** This bug has been marked as a duplicate of bug 151453 ***