Bug 202093 - kate should have some way to quickly switch between recently viewed documents
Summary: kate should have some way to quickly switch between recently viewed documents
Status: RESOLVED DUPLICATE of bug 104997
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-31 15:38 UTC by Russ Brown
Modified: 2009-09-02 18:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Russ Brown 2009-07-31 15:38:48 UTC
Version:            (using KDE 4.2.98)
Compiler:          gcc 4.3.3-5ubuntu4 
OS:                Linux
Installed from:    Ubuntu Packages

Kate's quick document switcher is excellent for quickly switching to a document by a part of its name, and I use it often. But even more often I find myself wanting to use what is often accessible in other editors via CTRL+TAB and CTRL+SHIFT+TAB: a way to cycle through the currently open documents in order of most recently viewed.

This is basically analogous to the window manager's ALT+TAB mechanism, and often involves a popup window showing the files in that order with the currently selected one being updated as the user continues to press the keyboard combination.
Comment 1 Russ Brown 2009-09-02 18:13:20 UTC
Just found an earlier bug for this problem.

*** This bug has been marked as a duplicate of bug 104997 ***