Bug 201897 - plasma panel freezes for a few seconds when opening a usb drive
Summary: plasma panel freezes for a few seconds when opening a usb drive
Status: RESOLVED DUPLICATE of bug 184062
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-29 16:15 UTC by Jithin Emmanuel
Modified: 2009-08-04 11:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jithin Emmanuel 2009-07-29 16:15:37 UTC
Version:            (using KDE 4.2.98)
OS:                Linux
Installed from:    Ubuntu Packages

I have a 320 GB USB drive which has about 200 GB data.
When I mount my drive, either clicking on Device Notifier applet or by dolphin Places, plasma panel freezes for a few seconds, ie until the drive is opened in dolphin it freezes the panel and everything goes back to normal once dolphin opens the drive.

Its the same if I mount manually using mount command. Plasma freezes for a few seconds, during which
1. system tray works.
2. no other applets in plasma works - eg, desktop switcher, task manager, notifiactions
3. alt-tab switching of applications work.

I believe its not related to device notifier.
I removed Device Notifier. Mounted from konsole. After 2 seconds it freezes the plasma panel. I dont even have any dolphin or anything running. But the device is properly mounted. I opened a movie in the drive with mplayer when the plasma panel was in a frozen state.

So my guess some process related to plasma is reading something from the device which freezes it.


One side effect of this bug is any notifications which appear during that time,
like a chat message received in kopete during this time stays in notification
area itself.
Comment 1 Aaron J. Seigo 2009-07-29 21:12:11 UTC
if you remove the kickoff (k menu) button from the panel, does the symptom disappear?
Comment 2 Jithin Emmanuel 2009-07-30 02:30:18 UTC
@Aron. Yes that makes the plasma related issue goes away. But still something wrong with dolphin if I try mounting from dolphin Places or Device Notifier. It takes that much time to open. 

Even though dolphin takes that much time I can use konsole to go to that device folder and browse. 

Please try to fix this before 4.3 is released. Is there any way to debug this issue? If you can give me any pointers I can give it a try.
Comment 3 Jithin Emmanuel 2009-07-30 04:45:49 UTC
I tried under a new account. Plasma freeze is still there, but dolphin opened immediately.
Comment 4 Aaron J. Seigo 2009-07-30 21:38:05 UTC
ok, so this is something in the places model when drives are plugged in and/or mounted. CC'ing someone more in the know about the places model than i :)
Comment 5 Aaron J. Seigo 2009-08-03 08:53:08 UTC

*** This bug has been marked as a duplicate of bug 184062 ***
Comment 6 Jithin Emmanuel 2009-08-03 09:03:00 UTC
How does this bug report relate to NFS mount getting disconnected abruptly?
Comment 7 Aaron J. Seigo 2009-08-03 10:50:58 UTC
it's the same kde subsystem (the places model) that's getting hung up by both events and giving the same symptoms in both cases.
Comment 8 Jithin Emmanuel 2009-08-03 11:05:15 UTC
But that bug says it happens when a connected device / network is unavailable plasma hangs. 

This bug says it hangs on connecting a device itself, that too for a few seconds. This also does not occur for all usb devices. Mine is almost full. And my friend's which had less data that mine opened immediately with no hang.

And I do not have any problem with plasma when I disconnect the device even with amarok playing some music in it. Only similarity with the other bug is plasma freeze as far I see.
Comment 9 Aaron J. Seigo 2009-08-04 11:48:17 UTC
trust me. it's the same problem in the same bit of code, it's just triggered by different causal factors.