Bug 201361 - kwin crahses while tapping
Summary: kwin crahses while tapping
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-24 17:26 UTC by Jonas Vejlin
Modified: 2009-07-24 17:29 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonas Vejlin 2009-07-24 17:26:23 UTC
Application that crashed: kwin
Version of the application: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2))
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-686 i686
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
I think my bug is the same. I did have synaptic open and asked for updates (the process did have a window for it self). Then I tapped. While I was tapping one of the synaptic windows did close and kwin crash. It happends everytime

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  0x00000000 in ?? ()
#7  0xb1f3367e in KWin::BoxSwitchEffect::paintWindowThumbnail (this=0x8b94438, w=0x9205e50) at ../../../kwin/effects/boxswitch/boxswitch.cpp:747
#8  0xb1f354d5 in KWin::BoxSwitchEffect::paintScreen (this=0x8b94438, mask=8, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:157
#9  0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#10 0xb1f810d2 in KWin::CubeEffect::paintScreen (this=0x8b4acd8, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:669
#11 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#12 0xb7741556 in KWin::Effect::paintScreen (this=0x8b64190, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:206
#13 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#14 0xb1f88f9a in KWin::CubeSlideEffect::paintScreen (this=0x8c25838, mask=8, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:109
#15 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#16 0xb7741556 in KWin::Effect::paintScreen (this=0x8c265b8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:206
#17 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#18 0xb7741556 in KWin::Effect::paintScreen (this=0x8c20fc8, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:206
#19 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#20 0xb7741556 in KWin::Effect::paintScreen (this=0x8b3d2f0, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:206
#21 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#22 0xb7741556 in KWin::Effect::paintScreen (this=0x8c21880, mask=8, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:206
#23 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#24 0xb1f7084d in KWin::ZoomEffect::paintScreen (this=0x8c1f280, mask=8, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:73
#25 0xb7f14e8f in KWin::EffectsHandlerImpl::paintScreen (this=0x8a45bf8, mask=8, region=..., data=...) at ../../kwin/effects.cpp:122
#26 0xb7efec60 in KWin::Scene::paintScreen (this=0x8a1ed98, mask=0xbfab2f74, region=0xbfab3034) at ../../kwin/scene.cpp:134
#27 0xb7f0e5d7 in KWin::SceneOpenGL::paint (this=0x8a1ed98, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:746
#28 0xb7ef9c66 in KWin::Workspace::performCompositing (this=0x8a46eb8) at ../../kwin/composite.cpp:420
#29 0xb7e8ba4e in KWin::Workspace::qt_metacall (this=0x8a46eb8, _c=QMetaObject::InvokeMetaMethod, _id=149, _a=0xbfab3108) at ./workspace.moc:473
#30 0xb67daad3 in QMetaObject::activate (sender=0x8a4711c, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3112
#31 0xb67db722 in QMetaObject::activate (sender=0x8a4711c, m=0xb68b6d84, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3186
#32 0xb6816117 in QTimer::timeout (this=0x8a4711c) at .moc/release-shared/moc_qtimer.cpp:128
#33 0xb67e0e3e in QTimer::timerEvent (this=0x8a4711c, e=0xbfab35ac) at kernel/qtimer.cpp:261
#34 0xb67d5b6f in QObject::event (this=0x8a4711c, e=0xbfab35ac) at kernel/qobject.cpp:1074
#35 0xb6a717d4 in QApplicationPrivate::notify_helper (this=0x8917448, receiver=0x8a4711c, e=0xbfab35ac) at kernel/qapplication.cpp:4056
#36 0xb6a7993e in QApplication::notify (this=0xbfab3884, receiver=0x8a4711c, e=0xbfab35ac) at kernel/qapplication.cpp:3603
#37 0xb7b53ebd in KApplication::notify (this=0xbfab3884, receiver=0x8a4711c, event=0xbfab35ac) at ../../kdeui/kernel/kapplication.cpp:302
#38 0xb7ea2f3d in KWin::Application::notify (this=0xbfab3884, o=0x8a4711c, e=0xbfab35ac) at ../../kwin/main.cpp:371
#39 0xb67c596b in QCoreApplication::notifyInternal (this=0xbfab3884, receiver=0x8a4711c, event=0xbfab35ac) at kernel/qcoreapplication.cpp:610
#40 0xb67f4301 in QCoreApplication::sendEvent (this=0x891a674) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#41 QTimerInfoList::activateTimers (this=0x891a674) at kernel/qeventdispatcher_unix.cpp:572
#42 0xb67f08a0 in timerSourceDispatch (source=0x891a640) at kernel/qeventdispatcher_glib.cpp:165
#43 0xb3fc2368 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#44 0xb3fc58c3 in ?? () from /usr/lib/libglib-2.0.so.0
#45 0xb3fc5a48 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#46 0xb67f07f8 in QEventDispatcherGlib::processEvents (this=0x88eb5b0, flags=...) at kernel/qeventdispatcher_glib.cpp:327
#47 0xb6b10f85 in QGuiEventDispatcherGlib::processEvents (this=0x88eb5b0, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
#48 0xb67c3fba in QEventLoop::processEvents (this=0xbfab37d0, flags=...) at kernel/qeventloop.cpp:149
#49 0xb67c4402 in QEventLoop::exec (this=0xbfab37d0, flags=...) at kernel/qeventloop.cpp:201
#50 0xb67c6859 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#51 0xb6a71657 in QApplication::exec () at kernel/qapplication.cpp:3525
#52 0xb7ea55cf in kdemain (argc=1, argv=0xbfab3a64) at ../../kwin/main.cpp:527
#53 0x08048582 in main (argc=-1308990424, argv=0xb7e67301) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 194524

Reported using DrKonqi
Comment 1 Martin Flöser 2009-07-24 17:29:32 UTC

*** This bug has been marked as a duplicate of bug 179865 ***