Bug 201148 - Full screen windows are plagued with flashes when a child window is shown (e.g. tooltip)
Summary: Full screen windows are plagued with flashes when a child window is shown (e....
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-22 21:52 UTC by Diederik van der Boor
Modified: 2009-07-22 21:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diederik van der Boor 2009-07-22 21:52:18 UTC
Version:           onbekend (using 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2)) "release 140", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.30-52-pae

Full screen windows are flashing each time a window is opened on top of the fullscreen window.

For example:
- open a gallery in gwenview
- switch to fullscreen
- use the mouse to navigate to the next folders.

Each time a tooltip is displayed for the "next" button, the gwenview window flashes to black and repaints. This is quite annoying to give a fullscreen photo presentation.

Similar behaviour can also be observed with Konqueror.

The flash also happens when accessing other windows, e.g. pressing the delete key in gwenview. Confirmation dialog opens -> gwenview flashes.

I'm using a white MacBook with Intel 945GM onboard graphics card.
Comment 1 Martin Flöser 2009-07-22 21:58:35 UTC

*** This bug has been marked as a duplicate of bug 177495 ***