Bug 200783 - DigiKam crashes while loading JPEG images
Summary: DigiKam crashes while loading JPEG images
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Engine (show other bugs)
Version: 0.10.0
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-19 18:16 UTC by Adrian Berriel
Modified: 2017-08-10 19:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.0.0


Attachments
Image that causes digikam crash (187.27 KB, image/jpeg)
2009-07-21 05:21 UTC, Adrian Berriel
Details
digiKam with test image + last libkexiv2 (633.89 KB, image/png)
2009-07-21 06:40 UTC, caulier.gilles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Berriel 2009-07-19 18:16:35 UTC
Version:           0.10 (using KDE 4.2.4)
OS:                Linux
Installed from:    Unspecified Linux

Digikam crashes when I set the source directory for import the media and starts loading the pictures.

It crashes in the splash screen.

Here is the backtrace:

Aplicación: digiKam (digikam), señal SIGABRT
[Current thread is 0 (LWP 12879)]

Thread 2 (Thread 0xb2db5b70 (LWP 12880)):
[KCrash Handler]
#6  0xb7fab424 in __kernel_vsyscall ()
#7  0xb52cb461 in raise () from /lib/libc.so.6
#8  0xb52ccc62 in abort () from /lib/libc.so.6
#9  0xb52c449e in __assert_fail () from /lib/libc.so.6
#10 0xb5017ac3 in Exiv2::Internal::TiffMnEntry::doCount () from /usr/lib/libexiv2.so.5
#11 0xb5017251 in Exiv2::Internal::TiffComponent::count () from /usr/lib/libexiv2.so.5
#12 0xb5017fe9 in Exiv2::Internal::TiffDirectory::writeDirEntry () from /usr/lib/libexiv2.so.5
#13 0xb501b70b in Exiv2::Internal::TiffDirectory::doWrite () from /usr/lib/libexiv2.so.5
#14 0xb501733b in Exiv2::Internal::TiffComponent::write () from /usr/lib/libexiv2.so.5
#15 0xb50194bc in Exiv2::Internal::TiffSubIfd::doWriteData () from /usr/lib/libexiv2.so.5
#16 0xb5017374 in Exiv2::Internal::TiffComponent::writeData () from /usr/lib/libexiv2.so.5
#17 0xb50173cb in Exiv2::Internal::TiffDirectory::doWriteData () from /usr/lib/libexiv2.so.5
#18 0xb5017374 in Exiv2::Internal::TiffComponent::writeData () from /usr/lib/libexiv2.so.5
#19 0xb501b8db in Exiv2::Internal::TiffDirectory::doWrite () from /usr/lib/libexiv2.so.5
#20 0xb501733b in Exiv2::Internal::TiffComponent::write () from /usr/lib/libexiv2.so.5
#21 0xb501f9b9 in Exiv2::Internal::TiffParserWorker::encode () from /usr/lib/libexiv2.so.5
#22 0xb501fce0 in Exiv2::TiffParser::encode () from /usr/lib/libexiv2.so.5
#23 0xb4fbc054 in Exiv2::ExifParser::encode () from /usr/lib/libexiv2.so.5
#24 0xb76a3667 in KExiv2Iface::KExiv2::getExif () from /usr/lib/libkexiv2.so.7
#25 0xb6e9f869 in Digikam::ImageScanner::loadFromDisk () from /usr/lib/libdigikamdatabase.so.1
#26 0xb6ea6ff2 in Digikam::ImageScanner::newFile () from /usr/lib/libdigikamdatabase.so.1
#27 0xb6e98c84 in Digikam::CollectionScanner::scanNewFile () from /usr/lib/libdigikamdatabase.so.1
#28 0xb6e9a366 in Digikam::CollectionScanner::scanAlbum () from /usr/lib/libdigikamdatabase.so.1
#29 0xb6e9a27a in Digikam::CollectionScanner::scanAlbum () from /usr/lib/libdigikamdatabase.so.1
#30 0xb6e9a27a in Digikam::CollectionScanner::scanAlbum () from /usr/lib/libdigikamdatabase.so.1
#31 0xb6e9aea7 in Digikam::CollectionScanner::scanAlbumRoot () from /usr/lib/libdigikamdatabase.so.1
#32 0xb6e9b149 in Digikam::CollectionScanner::completeScan () from /usr/lib/libdigikamdatabase.so.1
#33 0x08296792 in ?? ()
#34 0xb55a715e in ?? () from /usr/lib/libQtCore.so.4
#35 0xb552368c in start_thread () from /lib/libpthread.so.0
#36 0xb536ee2e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb4675710 (LWP 12879)):
#0  0xb7fab424 in __kernel_vsyscall ()
#1  0xb5527bc5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb55a8177 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#3  0xb55a71f9 in QThread::wait () from /usr/lib/libQtCore.so.4
#4  0x082955de in ?? ()
#5  0x08299331 in ?? ()
#6  0x082994ca in ?? ()
#7  0xb52ce3df in __run_exit_handlers () from /lib/libc.so.6
#8  0xb52ce44f in exit () from /lib/libc.so.6
#9  0xb5bfa9eb in ?? () from /usr/lib/libQtGui.so.4
#10 0xb67b614a in KApplication::xioErrhandler () from /usr/lib/libkdeui.so.5
#11 0xb67b6186 in kde_xio_errhandler () from /usr/lib/libkdeui.so.5
#12 0xb5128756 in _XIOError () from /usr/lib/libX11.so.6
#13 0xb512fed3 in process_responses () from /usr/lib/libX11.so.6
#14 0xb51308c6 in _XEventsQueued () from /usr/lib/libX11.so.6
#15 0xb511934f in XEventsQueued () from /usr/lib/libX11.so.6
#16 0xb5c3630e in ?? () from /usr/lib/libQtGui.so.4
#17 0xb4ec9c60 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#18 0xb4eca001 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#19 0xb4eca513 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#20 0xb56c0527 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#21 0xb5c360b5 in ?? () from /usr/lib/libQtGui.so.4
#22 0xb56940f9 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#23 0xb5694542 in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#24 0x08296c1d in ?? ()
#25 0x0825889a in ?? ()
#26 0x082bbde0 in ?? ()
#27 0xb52b7a36 in __libc_start_main () from /lib/libc.so.6
#28 0x0808d721 in _start ()

---------------------------------------------------

Best regards,
Adrián
Comment 1 caulier.gilles 2009-07-19 19:05:28 UTC
Exiv2 relevant. Which version you use ? See Help/Components Info for details.

Please update to Exiv2 0.18.2. You need to recompile libkexiv2 and digiKam /kipi-plugins.

Also, can you post here the image which crash digiKam ?

Gilles Caulier
Comment 2 caulier.gilles 2009-07-20 13:42:23 UTC
Adrian, 

What's news here. Please give us more info...

Gilles Caulier
Comment 3 Adrian Berriel 2009-07-21 05:21:42 UTC
Created attachment 35505 [details]
Image that causes digikam crash
Comment 4 Adrian Berriel 2009-07-21 05:23:47 UTC
Hi Gilles,

I attached the image.

I am using exiv2 0.18-1 with Arch Linux.

Adrian
Comment 5 caulier.gilles 2009-07-21 06:40:28 UTC
Created attachment 35506 [details]
digiKam with test image + last libkexiv2

It's a bug already fixed in libkexiv2 recently.

Here i use Exiv2 0.18.1 + last libkexiv2. It don't crash like you can see...

Gilles Caulier
Comment 6 caulier.gilles 2009-09-21 10:58:39 UTC
*** Bug 203967 has been marked as a duplicate of this bug. ***
Comment 7 caulier.gilles 2009-09-21 10:59:27 UTC
*** Bug 207955 has been marked as a duplicate of this bug. ***