Bug 200601 - random crash using kde
Summary: random crash using kde
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-17 23:33 UTC by Alin M Elena
Modified: 2009-07-17 23:38 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alin M Elena 2009-07-17 23:33:38 UTC
Application that crashed: kwin
Version of the application: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2)) "release 142"
KDE Version: 4.2.96 (KDE 4.2.96 (KDE 4.3 RC2)) "release 142"
Qt Version: 4.5.2
Operating System: Linux 2.6.27.23-0.1-default x86_64

 -- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#5  WindowPaintData (this=0x7fff5ecf91d0, w=0x1a0001701a00004) at /usr/src/debug/kdebase-workspace-4.2.96/kwin/lib/kwineffects.cpp:76
#6  0x00007f26439aad99 in KWin::CoverSwitchEffect::paintWindows (this=0x9c91e0, windows=0x9c9260, left=true, reflectedWindows=<value optimized out>, additionalWindow=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.2.96/kwin/effects/coverswitch/coverswitch.cpp:886
#7  0x00007f26439ab68c in KWin::CoverSwitchEffect::paintScene (this=0x9c91e0, frontWindow=0x5994ff0, leftWindows=0x9c9260, rightWindows=0x9c9268, reflectedWindows=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.2.96/kwin/effects/coverswitch/coverswitch.cpp:438
#8  0x00007f26439b18ab in KWin::CoverSwitchEffect::paintScreen (this=0x9c91e0, mask=0, region=
        {d = 0x7fff5ecf9610, static shared_empty = {ref = {_q_value = 114247}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=<value optimized out>)
    at /usr/src/debug/kdebase-workspace-4.2.96/kwin/effects/coverswitch/coverswitch.cpp:308
#9  0x00007f26568b2f67 in KWin::EffectsHandlerImpl::paintScreen (this=0x85d140, mask=32, region=
        {d = 0x7fff5ecf9660, static shared_empty = {ref = {_q_value = 114247}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=@0x7fff5ecf9730)
    at /usr/src/debug/kdebase-workspace-4.2.96/kwin/effects.cpp:122
#10 0x00007f26563d55f0 in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=@0x7fff5ecf9730)
    at /usr/src/debug/kdebase-workspace-4.2.96/kwin/lib/kwineffects.cpp:206
#11 0x00007f26568b2f67 in KWin::EffectsHandlerImpl::paintScreen (this=0x85d140, mask=32, region=
        {d = 0x7fff5ecf97b0, static shared_empty = {ref = {_q_value = 114247}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, data=@0x7fff5ecf9730)
    at /usr/src/debug/kdebase-workspace-4.2.96/kwin/effects.cpp:122
#12 0x00007f265689ec3c in KWin::Scene::paintScreen (this=0x8bb390, mask=0x7fff5ecf98bc, region=0x7fff5ecf99c0) at /usr/src/debug/kdebase-workspace-4.2.96/kwin/scene.cpp:134
#13 0x00007f26568ad61f in KWin::SceneOpenGL::paint (this=0x8bb390, damage={d = 0x7fff5ecf99c0, static shared_empty = {ref = {_q_value = 114247}, rgn = 0x0, xrectangles = 0x0, qt_rgn = 0x0}}, 
    toplevels=<value optimized out>) at /usr/src/debug/kdebase-workspace-4.2.96/kwin/scene_opengl.cpp:746
#14 0x00007f2656899fe4 in KWin::Workspace::performCompositing (this=0x8e8190) at /usr/src/debug/kdebase-workspace-4.2.96/kwin/composite.cpp:420
#15 0x00007f2656835d5a in KWin::Workspace::qt_metacall (this=0x8e8190, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5ecf9b50)
    at /usr/src/debug/kdebase-workspace-4.2.96/build/kwin/workspace.moc:473
#16 0x00007f2653f856e2 in QMetaObject::activate (sender=0x8e85b8, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3113
#17 0x00007f2653f80533 in QObject::event (this=0x8e85b8, e=0x1a0001701a00004) at kernel/qobject.cpp:1075
#18 0x00007f2654674b0d in QApplicationPrivate::notify_helper (this=0x622930, receiver=0x8e85b8, e=0x7fff5ecfa240) at kernel/qapplication.cpp:4056
#19 0x00007f265467cd9a in QApplication::notify (this=0x7fff5ecfa660, receiver=0x8e85b8, e=0x7fff5ecfa240) at kernel/qapplication.cpp:4021
#20 0x00007f2655b8f63b in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#21 0x00007f2653f7094c in QCoreApplication::notifyInternal (this=0x7fff5ecfa660, receiver=0x8e85b8, event=0x7fff5ecfa240) at kernel/qcoreapplication.cpp:610
#22 0x00007f2653f9db60 in QTimerInfoList::activateTimers (this=0x626170) at kernel/qcoreapplication.h:213
#23 0x00007f2653f99ddd in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
#24 0x00007f264ce9a0fb in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#25 0x00007f264ce9d8cd in ?? () from /usr/lib64/libglib-2.0.so.0
#26 0x00007f264ce9da8b in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f2653f99d3f in QEventDispatcherGlib::processEvents (this=0x609990, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#28 0x00007f265470bfef in QGuiEventDispatcherGlib::processEvents (this=0x1a0001701a00004, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#29 0x00007f2653f6f1d2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1590666592}) at kernel/qeventloop.cpp:149
#30 0x00007f2653f6f5a4 in QEventLoop::exec (this=0x7fff5ecfa5a0, flags={i = 1590666672}) at kernel/qeventloop.cpp:201
#31 0x00007f2653f71894 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#32 0x00007f265684ddd8 in kdemain (argc=3, argv=0x7fff5ecfab48) at /usr/src/debug/kdebase-workspace-4.2.96/kwin/main.cpp:527
#33 0x00007f2650fb6586 in __libc_start_main () from /lib64/libc.so.6
#34 0x0000000000400849 in _start () at ../sysdeps/x86_64/elf/start.S:113

Reported using DrKonqi
Comment 1 Martin Flöser 2009-07-17 23:38:32 UTC

*** This bug has been marked as a duplicate of bug 179865 ***