Bug 200460 - log the channel list in the query window when i receive a private message
Summary: log the channel list in the query window when i receive a private message
Status: RESOLVED LATER
Alias: None
Product: konversation
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konversation Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-16 17:42 UTC by Mathieu Jobin
Modified: 2013-04-15 01:13 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mathieu Jobin 2009-07-16 17:42:57 UTC
Version:           1.1.75+ #3400 (Debian 1.1.75+svn965785-0ubuntu1~jaunty1~ppa1) (using 4.2.4 (KDE 4.2.4), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.28-11-generic

hi there ! 

here is a small feature request that might be nice for many people.

sometimes, someone you don't know sends you a private message. it would be nice to know if he is/was in a same channel as yourself.

you can run a /whois command on him if he is still online. but he might be gone. so if the channel list of this person, could be inserted in the query window. that would be nice.

it could be the output of a /whois for this person that is executed automatically. but the channel info might be hidden. 

so konversation could loop through the channels i have open and check if this dude is present and returns the list when the query window is open.

that'd be nice.

thanks
Comment 1 Eike Hein 2012-04-11 12:09:13 UTC
Git commit 598c8e2de50bbad0e7204f3c76c0ac243cd51107 by Eike Hein.
Committed on 11/04/2012 at 14:09.
Pushed by hein into branch 'master'.

Post a list of shared channels at query start.

M  +2    -0    ChangeLog
M  +6    -0    src/irc/query.cpp
M  +12   -0    src/irc/server.cpp
M  +5    -0    src/irc/server.h

http://commits.kde.org/konversation/598c8e2de50bbad0e7204f3c76c0ac243cd51107
Comment 2 Nicolás Alvarez 2012-06-16 21:09:17 UTC
Git commit 99168eb01a0632f49f63217faa7ebd980fad4169 by Nicolás Alvarez, on behalf of Eike Hein.
Committed on 16/06/2012 at 21:33.
Pushed by nalvarez into branch 'master'.

Remove the shared channel announcement in queries again.

I never found a string I liked, I haven't found a satisfactory
way to deal with the race condition during auto-join, and there
were some complaints about the additional highlight vector (also
potentially interacting badly with the actual query messages).

Looks like a better idea might be to show the current shared
channels in the "topic" area of query tabs. This is subtly diff-
erent from having a timestamped record of the shared channels at
query open time, but at least gives the area more to do and avoids
these problems.

Additionally, removing this again fixes a regression that caused
query tabs not to light up with the message highlight when newly
opened (probably because the command message event overwrote the
highlight event before the event loop cycled enough for priority
sorting to be possible, haven't really worked through it).

M  +1    -1    src/commit.h
M  +0    -9    src/irc/query.cpp

http://commits.kde.org/konversation/99168eb01a0632f49f63217faa7ebd980fad4169