Bug 200137 - non-IMAP-related crash in FolderStorage::ignoreJobsForMessage
Summary: non-IMAP-related crash in FolderStorage::ignoreJobsForMessage
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 176688 186422 194990 199892 200626 202367 203703 204678 205296 205451 205986 207046 207262 208123 208585 210017 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-14 08:46 UTC by Constantin Berzan
Modified: 2009-11-03 13:32 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Constantin Berzan 2009-07-14 08:46:31 UTC
Version:            (using KDE 4.2.96)
OS:                Linux
Installed from:    Ubuntu Packages

I have seen a lot of similar backtraces from IMAP crashes, but I am only using POP3.  I've also found this backtrace here [1], unrelated to the bug report it is attached to.

[1] https://bugs.kde.org/show_bug.cgi?id=176688#c17

Other potentially useful info:
* I have filters set up, so that some mail coming into the inbox is automatically moved elsewhere.  It doesn't look like I received any message when the crash occurred, though.
* It is possible that I had a search folder open when I last closed Kontact/KMail.  But they don't seem to remain open when KMail is restarted.

Will update bug report if I manage to reproduce.



Application: Kontact (kontact), signal: Segmentation fault
[KCrash Handler]
#5  0xb11a09a6 in FolderStorage::ignoreJobsForMessage (this=0x89339c8, msg=0x9372a68) at /build/buildd/kdepim-4.2.96/kmail/folderstorage.cpp:1113
#6  0xb119f703 in FolderStorage::unGetMsg (this=0x89339c8, idx=0) at /build/buildd/kdepim-4.2.96/kmail/folderstorage.cpp:569
#7  0xb116cfab in KMFolder::unGetMsg (this=0x8951298, idx=0) at /build/buildd/kdepim-4.2.96/kmail/kmfolder.cpp:373
#8  0xb11edbdb in KMSearchPattern::matches (this=0x890c238, serNum=130161, ignoreBody=false) at /build/buildd/kdepim-4.2.96/kmail/kmsearchpattern.cpp:794
#9  0xb119f0a0 in FolderStorage::slotProcessNextSearchBatch (this=0x89339c8) at /build/buildd/kdepim-4.2.96/kmail/folderstorage.cpp:1180
#10 0xb13a80b4 in KMSearch::slotProcessNextBatch (this=0x8971da0) at /build/buildd/kdepim-4.2.96/kmail/kmfoldersearch.cpp:272
#11 0xb13a822b in KMSearch::qt_metacall (this=0x8971da0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xbfc71cb8) at /build/buildd/kdepim-4.2.96/obj-i486-linux-gnu/kmail/kmfoldersearch.moc:79
#12 0xb5c93ca8 in QMetaObject::activate (sender=0x894d3c0, from_signal_index=4, to_signal_index=4, argv=0x0) at kernel/qobject.cpp:3069
#13 0xb5c94932 in QMetaObject::activate (sender=0x894d3c0, m=0xb5d70904, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3143
#14 0xb5ccf717 in QTimer::timeout (this=0x894d3c0) at .moc/release-shared/moc_qtimer.cpp:128
#15 0xb5c996fe in QTimer::timerEvent (this=0x894d3c0, e=0xbfc7213c) at kernel/qtimer.cpp:261
#16 0xb5c8e15f in QObject::event (this=0x894d3c0, e=0xbfc7213c) at kernel/qobject.cpp:1082
#17 0xb615ee9c in QApplicationPrivate::notify_helper (this=0x84a5470, receiver=0x894d3c0, e=0xbfc7213c) at kernel/qapplication.cpp:4084
#18 0xb616719e in QApplication::notify (this=0xbfc723e8, receiver=0x894d3c0, e=0xbfc7213c) at kernel/qapplication.cpp:3631
#19 0xb6d854dd in KApplication::notify (this=0xbfc723e8, receiver=0x894d3c0, event=0xbfc7213c) at /build/buildd/kde4libs-4.2.96/kdeui/kernel/kapplication.cpp:302
#20 0xb5c7da3b in QCoreApplication::notifyInternal (this=0xbfc723e8, receiver=0x894d3c0, event=0xbfc7213c) at kernel/qcoreapplication.cpp:602
#21 0xb5cacd71 in QTimerInfoList::activateTimers (this=0x8493334) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#22 0xb5ca94e0 in timerSourceDispatch (source=0x8493300) at kernel/qeventdispatcher_glib.cpp:164
#23 0xb4d42b88 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#24 0xb4d460eb in ?? () from /usr/lib/libglib-2.0.so.0
#25 0xb4d46268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#26 0xb5ca9438 in QEventDispatcherGlib::processEvents (this=0x8473028, flags={i = -1077468488}) at kernel/qeventdispatcher_glib.cpp:323
#27 0xb6200365 in QGuiEventDispatcherGlib::processEvents (this=0x8473028, flags={i = -1077468440}) at kernel/qguieventdispatcher_glib.cpp:202
#28 0xb5c7c06a in QEventLoop::processEvents (this=0xbfc72360, flags={i = -1077468376}) at kernel/qeventloop.cpp:149
#29 0xb5c7c4aa in QEventLoop::exec (this=0xbfc72360, flags={i = -1077468312}) at kernel/qeventloop.cpp:200
#30 0xb5c7e959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#31 0xb615ed17 in QApplication::exec () at kernel/qapplication.cpp:3553
#32 0x0804bfef in main (argc=3, argv=0xbfc726e4) at /build/buildd/kdepim-4.2.96/kontact/src/main.cpp:218
Comment 1 Christophe Marin 2009-08-03 08:31:55 UTC
*** Bug 176688 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Marin 2009-08-03 08:32:08 UTC
*** Bug 199892 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Marin 2009-08-03 08:32:35 UTC
*** Bug 194990 has been marked as a duplicate of this bug. ***
Comment 4 Christophe Marin 2009-08-03 08:32:42 UTC
*** Bug 202367 has been marked as a duplicate of this bug. ***
Comment 5 Christophe Marin 2009-08-03 08:33:01 UTC
*** Bug 186422 has been marked as a duplicate of this bug. ***
Comment 6 Christophe Marin 2009-08-21 19:39:00 UTC
*** Bug 204678 has been marked as a duplicate of this bug. ***
Comment 7 Christophe Marin 2009-08-27 09:36:01 UTC
*** Bug 205296 has been marked as a duplicate of this bug. ***
Comment 8 Christophe Marin 2009-08-28 09:23:59 UTC
*** Bug 205451 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2009-09-02 14:32:10 UTC
*** Bug 205986 has been marked as a duplicate of this bug. ***
Comment 10 Christophe Marin 2009-09-11 10:43:38 UTC
*** Bug 207046 has been marked as a duplicate of this bug. ***
Comment 11 Thomas McGuire 2009-09-22 03:04:57 UTC
*** Bug 207262 has been marked as a duplicate of this bug. ***
Comment 12 Thomas McGuire 2009-09-22 03:05:02 UTC
*** Bug 203703 has been marked as a duplicate of this bug. ***
Comment 13 Thomas McGuire 2009-09-22 03:05:15 UTC
*** Bug 200626 has been marked as a duplicate of this bug. ***
Comment 14 Thomas McGuire 2009-09-22 03:05:27 UTC
*** Bug 208123 has been marked as a duplicate of this bug. ***
Comment 15 Thomas McGuire 2009-09-22 03:10:15 UTC
With a bit of luck, this problem could be fixed in KDE 4.3.2, a potential fix has been committed in r1024448, see http://websvn.kde.org/?revision=1024448&view=revision .
Comment 16 Christophe Marin 2009-09-26 12:08:19 UTC
*** Bug 208585 has been marked as a duplicate of this bug. ***
Comment 17 Christophe Marin 2009-10-10 10:01:00 UTC
*** Bug 210017 has been marked as a duplicate of this bug. ***
Comment 18 Jonathan Thomas 2009-11-03 13:32:34 UTC
According to the reporter of our downstream bug for this (https://launchpad.net/bugs/420337) this has not been an issue for him in KDE 4.3.2, and Kontact has been quite stable for him. (I think he's CC'd here in fact)