Bug 199889 - After closing the amarok GUI, the playlist scrolls to the top, even if the played track is in the middle
Summary: After closing the amarok GUI, the playlist scrolls to the top, even if the pl...
Status: RESOLVED DUPLICATE of bug 193459
Alias: None
Product: amarok
Classification: Applications
Component: Playlist (show other bugs)
Version: 2.1.1
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-12 17:07 UTC by jeanpaul145
Modified: 2009-07-16 08:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeanpaul145 2009-07-12 17:07:28 UTC
Version:           2.1.1 (using KDE 4.2.96)
Compiler:          gcc (Ubuntu 4.3.3-5ubuntu4) 4.3.3 
OS:                Linux
Installed from:    Ubuntu Packages

Here is how I can reproduce the bug:
Suppose you have a long playlist, of around 100 entries (that's the length I'm reporting with, but I don't think this is related to the list size).
You're playing a song in the middle of the playlist, and decide to close the playlist.
Then you switch the focus to another application.
Reopen Amarok's playlist, now the list has "scrolled" all the way to the top.

I find this very annoying, so I think of it as a usability bug. What I expect is that the song currently playing is at least visible in the playlist, not by placing the song at the top (that would be idiotic), but by _not_ scrolling the playlist to the top.
Comment 1 Myriam Schweingruber 2009-07-15 19:39:05 UTC
I find the title a bit misleading in regard to the bug description, any thoughts?
Comment 2 jeanpaul145 2009-07-15 19:58:16 UTC
Ok, how about "After closing the Amarok playlist, it scrolls to the top"?
Comment 3 Myriam Schweingruber 2009-07-15 21:09:29 UTC
Well, I don't understand what you mean by "closing" and "reopening" the playlist, that makes no sense to me, sorry.
Comment 4 jeanpaul145 2009-07-15 21:12:04 UTC
Ah. By closing the playlist I simply mean clicking the x-button in the upper-right corner corner of Amarok, or pressing meta+P.
Opening is nothing else than ctrl+P when closed, or clicking Amarok's systray button.
Comment 5 Myriam Schweingruber 2009-07-15 21:29:51 UTC
Ok, you meant closing the GUI. FYI: the playlist is the left pane, the context view is the one in the middle, the collection view on the left. You can't really close the playlist. Changed the bug title accordingly.
Comment 6 Myriam Schweingruber 2009-07-15 21:32:10 UTC

*** This bug has been marked as a duplicate of bug 193459 ***