Bug 199840 - kio_thumbnail produces segfault messages in dmesg
Summary: kio_thumbnail produces segfault messages in dmesg
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Unclassified
Component: thumbnail (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Malte Starostik
URL:
Keywords:
: 199474 199749 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-07-12 10:29 UTC by Guillermo Belli
Modified: 2009-07-25 23:46 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Guillermo Belli 2009-07-12 10:29:54 UTC
Version:            (using KDE 4.2.95)
OS:                Linux
Installed from:    Ubuntu Packages

I have hundreds of kio_thumbnail segfault messages in the kernel log. Here's an example:

[ 3715.424146] kio_thumbnail[15382]: segfault at 1 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]         
[ 3715.814607] kio_thumbnail[15386]: segfault at f68 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]       
[ 3715.818328] kio_thumbnail[15385]: segfault at f68 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]       
[ 3716.139478] kio_thumbnail[15389]: segfault at f68 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]       
[ 3716.178964] kio_thumbnail[15390]: segfault at 7fb700000002 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3716.786999] kio_thumbnail[15396]: segfault at 7fb700000002 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3716.999644] kio_thumbnail[15398]: segfault at 1 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3717.151564] kio_thumbnail[15399]: segfault at 7fb700000002 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3779.165635] __ratelimit: 1 callbacks suppressed
[ 3779.165638] kio_thumbnail[15436]: segfault at f68 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3779.212394] kio_thumbnail[15437]: segfault at f68 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3779.298339] kio_thumbnail[15439]: segfault at 2 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]
[ 3779.422675] kio_thumbnail[15441]: segfault at 7fb700000000 ip 00007fb723f7c4ef sp 00007fff0b2b64f0 error 4 in libgcc_s.so.1[7fb723f6c000+16000]

I have previews enabled in Dolphin, and was browsing folders with images and documents.
Comment 1 Norberto Bensa 2009-07-12 20:30:22 UTC
/Me too. 

KDE 4.2.96. Ubuntu packages (from Karmic)
Comment 2 Dario Andres 2009-07-15 01:41:34 UTC
*** Bug 199749 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2009-07-15 01:41:42 UTC
*** Bug 199474 has been marked as a duplicate of this bug. ***
Comment 4 Maciej Mrozowski 2009-07-15 17:45:08 UTC
Not perfect one, but better than nothing:
Using Qt 4.5.1, Gentoo, KDE from 4.3 branch, rebuilt 15 July 2009

Program terminated with signal 11, Segmentation fault.                                                                             
---Type <return> to continue, or q <return> to quit---                                                                             
#0  0x00007fc0f95d035c in ?? () from /lib/libgcc_s.so.1                                                                            
(gdb) bt                                                                                                                           
#0  0x00007fc0f95d035c in ?? () from /lib/libgcc_s.so.1                                                                            
#1  0x00007fc0f95d0bb0 in _Unwind_Backtrace () from /lib/libgcc_s.so.1                                                             
#2  0x00007fc0fd4c2452 in backtrace () from /lib/libc.so.6                                                                         
#3  0x00007fc0ff59cfbc in kRealBacktrace(int) () from /usr/lib64/libkdecore.so.5                                                   
#4  0x00007fc0fe6c32eb in KIconLoader::~KIconLoader() () from /usr/lib64/libkdeui.so.5                                             
#5  0x00007fc0fd3fc6fd in exit () from /lib/libc.so.6                                                                              
#6  0x00007fc0fec6db40 in ?? () from /usr/lib64/libkio.so.5                                                                        
#7  <signal handler called>                                                                                                        
#8  0x0000000000000001 in ?? ()                                                                                                    
#9  0x00007fc0fdcca79c in QPainter::end() () from /usr/lib64/qt4/libQtGui.so.4                                                     
#10 0x00007fc0fdccb06a in QPainter::~QPainter() () from /usr/lib64/qt4/libQtGui.so.4
---Type <return> to continue, or q <return> to quit---
#11 0x00007fc0f504dc43 in ThumbnailProtocol::thumbForDirectory (this=0x7fff081581e0, directory=@0x7fff08158000)
    at /usr/src/debug/kde-base/kdebase-kioslaves-4.3.9999/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:648
#12 0x00007fc0f504e7bc in ThumbnailProtocol::get (this=0x7fff081581e0, url=@0x7fff08158000)
    at /usr/src/debug/kde-base/kdebase-kioslaves-4.3.9999/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:247
#13 0x00007fc0fec72df0 in KIO::SlaveBase::dispatch(int, QByteArray const&) () from /usr/lib64/libkio.so.5
#14 0x00007fc0fec73420 in KIO::SlaveBase::dispatchLoop() () from /usr/lib64/libkio.so.5
#15 0x00007fc0f504fc47 in kdemain (argc=4, argv=0x2551e10)
    at /usr/src/debug/kde-base/kdebase-kioslaves-4.3.9999/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:136
#16 0x000000000040718f in _start ()
Comment 5 Dario Andres 2009-07-15 20:03:11 UTC
We got a core dump: http://www.researchut.com/~rrs/tmp/core.6513
@Ritesh Raj Sarraf: could you use it to try to get a backtrace from it too ? (there are some hints at http://www.kdedevelopers.org/node/3921)
Thanks
Comment 6 Maciej Mrozowski 2009-07-15 21:43:44 UTC
A bit better than previous one (with debug symbols in kdelibs)

(gdb) bt
#0  0x00007f16fdffa35c in ?? () from /lib/libgcc_s.so.1
#1  0x00007f16fdffabb0 in _Unwind_Backtrace () from /lib/libgcc_s.so.1
#2  0x00007f1701ef9452 in backtrace () from /lib/libc.so.6
#3  0x00007f17040754b9 in kRealBacktrace (levels=-1)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kdecore/io/kdebug.cpp:594
#4  0x00007f170310b5b8 in kBacktrace (levels=-1)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kdecore/io/kdebug.h:98
#5  0x00007f170310355e in KIconLoader::~KIconLoader (this=0xf5a1e0, __in_chrg=<value optimized out>,
    __in_chrg=<value optimized out>)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kdeui/icons/kiconloader.cpp:557
#6  0x00007f1703102a1c in <anonymous struct>::destroy(void) ()
---Type <return> to continue, or q <return> to quit---
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kdeui/icons/kiconloader.cpp:1696
#7  0x00007f170308f9c1 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0x7f1703575aa8, __in_chrg=<value optimized out>,
    __in_chrg=<value optimized out>)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kdecore/kernel/kglobal.h:62
#8  0x00007f1701e336fd in exit () from /lib/libc.so.6
#9  0x00007f1703708390 in sigsegv_handler (sig=11)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kio/kio/slavebase.cpp:745
#10 <signal handler called>
#11 0x0000000000000001 in ?? ()
#12 0x00007f170270179c in QPainter::end() () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007f170270206a in QPainter::~QPainter() () from /usr/lib64/qt4/libQtGui.so.4
---Type <return> to continue, or q <return> to quit---
#14 0x00007f16f9a2bc43 in ThumbnailProtocol::thumbForDirectory (this=0x7fff0cc46e60, directory=@0x7fff0cc46ca0)
    at /var/tmp/portage/kde-base/kdebase-kioslaves-4.3.9999/work/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:648
#15 0x00007f16f9a2c7bc in ThumbnailProtocol::get (this=0x7fff0cc46e60, url=@0x7fff0cc46ca0)
    at /var/tmp/portage/kde-base/kdebase-kioslaves-4.3.9999/work/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:247
#16 0x00007f170370abfe in KIO::SlaveBase::dispatch (this=0x7fff0cc46e60, command=67, data=@0x7fff0cc46d90)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kio/kio/slavebase.cpp:1012
#17 0x00007f170370b9de in KIO::SlaveBase::dispatchLoop (this=0x7fff0cc46e60)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kio/kio/slavebase.cpp:282
#18 0x00007f16f9a2dc47 in kdemain (argc=4, argv=0xf514d0)
    at /var/tmp/portage/kde-base/kdebase-kioslaves-4.3.9999/work/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:136
#19 0x00000000004074b7 in launch (argc=4, _name=0xf50bf8 "kio_thumbnail", args=0xf50c7c "", cwd=0x0, envc=0, envs=0xf50c84 "",
---Type <return> to continue, or q <return> to quit---
    reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b192 "0")
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:676
#20 0x0000000000407c8f in handle_launcher_request (sock=7, who=0x40b23c "launcher")
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:1168
#21 0x000000000040849e in handle_requests (waitForPid=0)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:1361
#22 0x0000000000408d2f in main (argc=2, argv=0x7fff0cc47af8, envp=0x7fff0cc47b10)
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:1788
(gdb)
Comment 7 Ritesh Raj Sarraf 2009-07-16 07:02:35 UTC
(In reply to comment #5)
> We got a core dump: http://www.researchut.com/~rrs/tmp/core.6513
> @Ritesh Raj Sarraf: could you use it to try to get a backtrace from it too ?
> (there are somwhich is calling mplayerthumbs.
Anyway, i'll do some more tests to see where the problem may be.
Also, can you try compiling mplayerthumbs AND kdelibs with debug support,
enable everything on kdebugdialog and collect logging again?e hints at http://www.kdedevelopers.org/node/3921)
> Thanks

Sorry, Unfortunately I can't.
I don't have the debug symbols installed (and am also very low on space).
Comment 8 Maciej Mrozowski 2009-07-16 15:58:28 UTC
It has nothing to do with mplayerthumbs (I don't have it installed) - kdeinit4 simply crashes within kio_thumbnail - just enable previews in dolphin.
Comment 9 Dario Andres 2009-07-16 16:04:35 UTC
I know it is unrelated but as he got a coredump (which I manually tried to produce to get some info about the crash, and I failed) I thought it could be useful to have here. Regards
Comment 10 Guillermo Belli 2009-07-16 16:32:03 UTC
What can I do to provide some useful information? I'm just getting those messages in dmesg, but no actual application crash, so I have no backtrace or core dump. I have debugging packages installed.
Comment 11 Simon St James 2009-07-22 19:09:35 UTC
Maciej Mrozowski's actually looks like an intentional bit of diagnostic code, to me, and so may be a red-herring - the code is simply storing the backtrace representing the point at which this KIconLoader was delete'd in the master list:

http://api.kde.org/4.x-api/kdelibs-apidocs/kdeui/html/kiconloader_8cpp-source.html#l00557

Unless something is going wrong in the backtrace() call and this is a legitimate crash, that is ;)
Comment 12 Simon St James 2009-07-22 19:55:50 UTC
@Guillermo:

I have no experience with this, but you can try the approach here:

http://techbase.kde.org/Development/Tutorials/Debugging/Debugging_IOSlaves

in particular, running:

KDE_SLAVE_DEBUG_WAIT=thumbnail kdeinit4

Now open Dolphin to a directory where previewing causes a crash.  As I understand it, each spawned kio_thumbnail instance will start off in a stopped state so that you can connect to it with gdb.

In the output from the above command, you should see lines like:

kdeinit4: Suspending process
kdeinit4: 'gdb kdeinit4 xxxxxxx' to debug

Executing the 

gdb kdeinit4 xxxxxxx

command will attach to the kio_thumbnail process so that you can debug it.  Press "c" to run the kio_thumbnail process until it crashes (or exits naturally).  Note that not all of the kio_thumbnail processes will crash, necessarily.

You can also get the PIDs of the kio_thumbnail instances via

ps -A  | grep thumbnail

and run 

gdb kdeinit4 <PID>

on one of the resulting PIDs.
Comment 13 Maciej Mrozowski 2009-07-23 01:01:33 UTC
My backtrace could be mesleading a bit, let me paste relevant part of backtarce (and not word-wrapped this time):

#9  0x00007f6af1663390 in sigsegv_handler (sig=11) at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kio/kio/slavebase.cpp:745
#10 <signal handler called>
#11 0x00007f6a00000001 in ?? ()
#12 0x00007f6af065b79c in QPainter::end() () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007f6af065c06a in QPainter::~QPainter() () from /usr/lib64/qt4/libQtGui.so.4
#14 0x00007f6ae7984c43 in ThumbnailProtocol::thumbForDirectory (this=0x7ffffaba1db0, directory=@0x7ffffaba1bf0)
    at /var/tmp/portage/kde-base/kdebase-kioslaves-4.3.9999/work/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:648
#15 0x00007f6ae79857bc in ThumbnailProtocol::get (this=0x7ffffaba1db0, url=@0x7ffffaba1bf0)
    at /var/tmp/portage/kde-base/kdebase-kioslaves-4.3.9999/work/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:247
#16 0x00007f6af1665bfe in KIO::SlaveBase::dispatch (this=0x7ffffaba1db0, command=67, data=@0x7ffffaba1ce0) at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kio/kio/slavebase.cpp:1012
#17 0x00007f6af16669de in KIO::SlaveBase::dispatchLoop (this=0x7ffffaba1db0) at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kio/kio/slavebase.cpp:282
#18 0x00007f6ae7986c47 in kdemain (argc=4, argv=0x1b36c40) at /var/tmp/portage/kde-base/kdebase-kioslaves-4.3.9999/work/kdebase-kioslaves-4.3.9999/kioslave/thumbnail/thumbnail.cpp:136
#19 0x00000000004074b7 in launch (argc=4, _name=0x1b62818 "kio_thumbnail", args=0x1b6289c "", cwd=0x0, envc=0, envs=0x1b628a4 "", reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b192 "0")
    at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:676
#20 0x0000000000407c8f in handle_launcher_request (sock=7, who=0x40b23c "launcher") at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:1168
#21 0x000000000040849e in handle_requests (waitForPid=0) at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:1361
#22 0x0000000000408d2f in main (argc=2, argv=0x7ffffaba2a48, envp=0x7ffffaba2a60) at /var/tmp/portage/kde-base/kdelibs-4.3.9999/work/kdelibs-4.3.9999/kinit/kinit.cpp:1788

looks like it crashes somewhere in QPainter code, and last non-Qt  invocation is in kioslave/thumbnail/thumbnail.cpp:648
Comment 14 Maciej Mrozowski 2009-07-23 01:10:27 UTC
dammit, bugzilla (or konsole/klipper?) cuts long lines intead of wrapping them, anyway it looks like kioslave/thumbnail/thumbnail.cpp:648


img = thumbForDirectory(url); (thumbnail.cpp:247)
(call QImage ThumbnailProtocol::thumbForDirectory(const KUrl& directory))
and crashes while invoking return img; (thumbnail.cpp:648)

so.. invoking copy constructor of QImage??
Maybe something wrong with Qt 4.5.1?
Comment 15 Anne-Marie Mahfouf 2009-07-23 15:20:31 UTC
I get these crashes as well on a newly built kde 4.3 branch installation but they are very difficult to debug. Qt 4.5.2 here.

Some konsole output

kioslave: ####### CRASH ###### protocol = thumbnail pid = 545 signal = 11       
/usr/local/branch/lib/libkio.so.5[0xb7883465]                                   
[0xffffe400]                                                                    
/usr/local/branch-src/qt/lib/libQtGui.so.4(_ZN8QPainterD1Ev+0x3b)[0xb6b7123d]   
/usr/local/branch/lib/kde4/kio_thumbnail.so[0xb606307c]                         
/usr/local/branch/lib/kde4/kio_thumbnail.so[0xb6063e0f]                         
/usr/local/branch/lib/libkio.so.5(_ZN3KIO9SlaveBase8dispatchEiRK10QByteArray+0x433)[0xb7886311]                                                                 
/usr/local/branch/lib/libkio.so.5(_ZN3KIO9SlaveBase12dispatchLoopEv+0x233)[0xb7887025]                                                                          
/usr/local/branch/lib/kde4/kio_thumbnail.so(kdemain+0x256)[0xb60655b5]          
kdeinit4: kio_thumbnail [kdeinit] thumbnail local:/tmp/branch-branch/ksocket-branch/klauncherT32764.slave-socket local:/tmp/branch-branch/ksocket-branch/dolphinPtc414.slave-[0x804e455]                                                        
kdeinit4: kio_thumbnail [kdeinit] thumbnail local:/tmp/branch-branch/ksocket-branch/klauncherT32764.slave-socket local:/tmp/branch-branch/ksocket-branch/dolphinPtc414.slave-[0x804ebc4]                                                        
kdeinit4: kio_thumbnail [kdeinit] thumbnail local:/tmp/branch-branch/ksocket-branch/klauncherT32764.slave-socket local:/tmp/branch-branch/ksocket-branch/dolphinPtc414.slave-[0x804f4ed]                                                        
kdeinit4: kio_thumbnail [kdeinit] thumbnail local:/tmp/branch-branch/ksocket-branch/klauncherT32764.slave-socket local:/tmp/branch-branch/ksocket-branch/dolphinPtc414.slave-[0x804febc]                                                        
/lib/i686/libc.so.6(__libc_start_main+0xe5)[0xb667d6a5]                         
kdeinit4: kio_thumbnail [kdeinit] thumbnail local:/tmp/branch-branch/ksocket-branch/klauncherT32764.slave-socket local:/tmp/branch-branch/ksocket-branch/dolphinPtc414.slave-[0x804b151]                                                        
kdeinit4: PID 545 terminated.                                                   
dolphin(414)/kio (KDirListerCache) KDirListerCache::forgetDirs: DolphinDirLister(0x8bd3b18)  item moved into cache:  KUrl("file:///home/branch/build/kdegraphics/gwenview")                                                                     
dolphin(414)/kio (KDirListerCache) KDirListerCache::listDir: Listing directory: KUrl("file:///home/branch/build/kdegraphics/gwenview/app")                      
dolphin(414)/kio (Slave) KIO::Slave::gotInput: slave died pid =  545            
dolphin(414)/kdeui (KIconLoader) KIconLoader::loadIcon: No such icon "application-x-konsole"                                                                    
dolphin(414)/kio (KDirListerCache) KDirListerCache::slotResult: finished listing KUrl("file:///home/branch/build/kdegraphics/gwenview/app")                     
dolphin(414)/kio KIO::DelegateAnimationHandler::setSequenceIndex: 1             
dolphin(414)/kio KIO::DelegateAnimationHandler::gotNewIcon: 1                   
dolphin(414)/kio (Slave) KIO::Slave::createSlave: createSlave "thumbnail" for KUrl("thumbnail:/home/branch/build/kdegraphics/gwenview/app/CMakeFiles")          
dolphin(414)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/branch-branch/ksocket-branch/dolphinVJJ414.slave-socket"     
klauncher(32764)/kio (KLauncher) KLauncher::requestSlave: KLauncher: launching new slave  "kio_thumbnail"  with protocol= "thumbnail"  args= ("thumbnail", "local:/tmp/branch-branch/ksocket-branch/klauncherT32764.slave-socket", "local:/tmp/branch-branch/ksocket-branch/dolphinVJJ414.slave-socket")                        
kdeinit4: Got EXEC_NEW 'kio_thumbnail' from launcher.                           
kdeinit4: preparing to launch /usr/local/branch/lib/kde4/kio_thumbnail.so       
klauncher(32764)/kio (KLauncher) KLauncher::processRequestReturn: "kio_thumbnail" (pid 547) up and running.                                                     
kio_thumbnail(547) ThumbnailProtocol::get: Wanting MIME Type: "inode/directory" 
kio_thumbnail(547)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from  "/var/tmp/kdecache-branch/ksycoca4"                             
kio_thumbnail(547)/kdecore (KMimeType) KMimeTypeFactory::parseMagic: Now parsing  "/usr/share/mime/magic"                                                       
kio_thumbnail(547)/kdecore (KMimeType) KMimeTypeFactory::parseMagic: Now parsing  "/usr/local/branch/share/mime/magic"                                          
kio_thumbnail(547)/kdecore (KMimeType) KMimeTypeFactory::parseMagic: Now parsing  "/home/branch/.local/share/mime/magic"                                        
kio_thumbnail(547)/kdecore (trader) KMimeTypeTrader::query: query for mimeType  "text/plain" ,  "ThumbCreator"  : returning  1  offers                          
kio_thumbnail(547)/kdecore (trader) KMimeTypeTrader::query: query for mimeType  "text/x-cmake" ,  "ThumbCreator"  : returning  1  offers
Comment 16 Alessandro Ghersi 2009-07-23 19:47:05 UTC
Same here, I opened the bug on launchpad:
https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/401490
Comment 17 Dario Andres 2009-07-25 23:46:56 UTC
This was fixed recently by:

SVN commit 1001953 by ppenz
SVN commit 1002368 by ppenz
SVN commit 1002369 by ppenz

See details at bug 196880.
Thanks