Bug 199343 - Konqueror crash closing windows
Summary: Konqueror crash closing windows
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-07 22:04 UTC by Sebastien
Modified: 2009-07-07 22:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien 2009-07-07 22:04:21 UTC
Application that crashed: konqueror
Version of the application: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
KDE Version: 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1))
Qt Version: 4.5.2
Operating System: Linux 2.6.30.1-desktop-1mnb i686
Distribution: "Mandriva Linux 2009.1"

What I was doing when the application crashed:
Closing Konqueror after navigate on Ebay

 -- Backtrace:
Application: Konqueror (kdeinit4), signal: Aborted
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb66a59e1 in raise () from /lib/i686/libc.so.6
#8  0xb66a7374 in abort () from /lib/i686/libc.so.6
#9  0xb669e83e in __assert_fail () from /lib/i686/libc.so.6
#10 0xb16b661c in KHTMLGlobal::finalCheck () at /usr/src/debug/kdelibs-4.2.95/khtml/khtml_global.cpp:258
#11 0xb14270c5 in ~KHTMLFactory (this=0x8d63918) at /usr/src/debug/kdelibs-4.2.95/khtml/khtml_factory.cpp:35
#12 0xb7c53bb0 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x8d4da40}, end={i = 0x8d63dc0}) at /usr/lib/qt4/include/QtCore/qalgorithms.h:350
#13 0xb7c53c29 in qDeleteAll<FactoryHash> (c=@0x8d52488) at /usr/lib/qt4/include/QtCore/qalgorithms.h:358
#14 0xb7c53e50 in ~FactoryHash (this=0x8d52488) at /usr/src/debug/kdelibs-4.2.95/kdecore/util/klibrary.cpp:93
#15 0xb7c52bed in destroy () at /usr/src/debug/kdelibs-4.2.95/kdecore/util/klibrary.cpp:97
#16 0xb7b246c9 in ~KCleanUpGlobalStatic (this=0xb7cfd450) at /usr/src/debug/kdelibs-4.2.95/kdecore/kernel/kglobal.h:62
#17 0xb66a8b1f in ?? () from /lib/i686/libc.so.6
#18 0xb66a8b8f in exit () from /lib/i686/libc.so.6
#19 0x0804db52 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x8a6ae54 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8a6ae58 "localhost;1246995887;840215;4873_TIME37702288") at /usr/src/debug/kdelibs-4.2.95/kinit/kinit.cpp:672
#20 0x0804e2a5 in handle_launcher_request (sock=7, who=<value optimized out>) at /usr/src/debug/kdelibs-4.2.95/kinit/kinit.cpp:1164
#21 0x0804f014 in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.2.95/kinit/kinit.cpp:1357
#22 0x0804f8a5 in main (argc=2, argv=0xbf88f914, envp=0xbf88f920) at /usr/src/debug/kdelibs-4.2.95/kinit/kinit.cpp:1784

Reported using DrKonqi
Comment 1 Dario Andres 2009-07-07 22:59:05 UTC
This is reported as bug 151453. Thanks

*** This bug has been marked as a duplicate of bug 151453 ***