Bug 199282 - Valgrind chrashes with "Trace/BPT trap"
Summary: Valgrind chrashes with "Trace/BPT trap"
Status: RESOLVED DUPLICATE of bug 193917
Alias: None
Product: valgrind
Classification: Developer tools
Component: general (show other bugs)
Version: 3.5 SVN
Platform: Unlisted Binaries macOS
: NOR crash
Target Milestone: ---
Assignee: Julian Seward
Depends on:
Reported: 2009-07-07 13:52 UTC by caulfield.holden
Modified: 2009-07-07 14:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:

Contents of the file config.log (136.01 KB, text/plain)
2009-07-07 13:52 UTC, caulfield.holden

Note You need to log in before you can comment on or make changes to this bug.
Description caulfield.holden 2009-07-07 13:52:36 UTC
Created attachment 35120 [details]
Contents of the file config.log

uname -a: Darwin <hostname has been removed> 9.7.1 Darwin Kernel Version 9.7.1: Thu Apr 23 13:52:18 PDT 2009; root:xnu-1228.14.1~1/RELEASE_I386 i386

valgrind -v: Trace/BPT trap


I'm using revision 1906 from the SVN repository. I compiled and installed valgrind, with and without the configure flags "-enable-only64bit" or "-enable-only32bit", respectively, using the Apple supplied gcc-4.2 from XCode 3.1.3. Upon invocation of valgrind (e.g. just "valgrind") I get the message "Trace/BPT trap" in my terminal window. The system logs at the same time record the following messages:

07.07.09 11:51:31 kernel shared_region: enter(0xc73ef04,0x7c48058,0,7,0): vm_map_enter(0x90000000,0x20000000,0x6ebac94) error 0x3 
07.07.09 11:51:31 ReportCrash[89417] Failed to create VMUSymbolicator for memcheck-x86-darwin[89416] 
07.07.09 11:51:31 ReportCrash[89417] Formulating crash report for process memcheck-x86-darwin[89416] 

The crash reporter, as seen above, saves a report that contains the following information:

Process:         memcheck-x86-darwin [89416]
Path:            /usr/local/lib/valgrind/memcheck-x86-darwin
Identifier:      memcheck-x86-darwin
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  bash [28327]

Date/Time:       2009-07-07 11:51:31.318 +0200
OS Version:      Mac OS X 10.5.7 (9J3050)
Report Version:  6
Anonymous UUID:  0B0F598F-4D68-4975-9CA5-DA6F34007C4C

Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  Unknown

Backtrace not available

Unknown thread crashed with X86 Thread State (32-bit):
  eax: 0x00000000  ebx: 0xf0adc286  ecx: 0x00000000  edx: 0xf0a985a8
  edi: 0xf0ae59b0  esi: 0xf0adc278  ebp: 0xf007f4f8  esp: 0xf007f4e0
   ss: 0x0000001f  efl: 0x00000246  eip: 0xf0adc2a0   cs: 0x00000017
   ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037
  cr2: 0xf0a985a8

Binary images description not available

The described behavior is also encountered when invoking valgrind to use other tools like cachegrind. The system logs then show:

07.07.09 11:54:52 kernel shared_region: enter(0x123b0e88,0x7c48058,0,7,0): vm_map_enter(0x90000000,0x20000000,0x6ebac94) error 0x3 
07.07.09 11:54:52 ReportCrash[89429] Failed to create VMUSymbolicator for cachegrind-x86-darwin[89428] 
07.07.09 11:54:52 ReportCrash[89429] Formulating crash report for process cachegrind-x86-darwin[89428] 

So the problem seems to be unrelated to a specific valgrind tool.

I'm using a MacBook Pro (mid 2009) with Core 2 Duo 2.66GHz processor and 4GB of RAM running Mac OS X 10.5.7. 

I have attached the contents of the file config.log after running "./configure".

I have skimmed through the open bugs section but did not find anything similar, so I hope this is not a duplicate. 


Comment 1 Julian Seward 2009-07-07 14:02:38 UTC
It may be that this is a dup of another recently discussed V-MacOSX
bug, in which the problem is due to a conflict with some other
package which also plays games with LD_PRELOAD (or is it dyld).
But I don't remember much more than that (apart from, if you disable
the other package, it's easily worked-around).
Comment 2 Nicholas Nethercote 2009-07-07 14:04:42 UTC
It sounds like bug 193917 -- are you running a program called Instant Hijack?
Comment 3 caulfield.holden 2009-07-07 14:26:15 UTC
Problem solved.

Just checked, and indeed I was running Instant Hijack. I did install it some time ago but it had since fallen off my radar. So, I disabled that one following the instructions posted in the comments attached to bug 193917. After that, valgrind seems to be working just fine. Thanks for the quick response. I took the liberty to mark this one as solved.

*** This bug has been marked as a duplicate of bug 193917 ***