Bug 198987 - Amarok forgets myriad settings when shutdown abnormally
Summary: Amarok forgets myriad settings when shutdown abnormally
Status: RESOLVED DUPLICATE of bug 211509
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.1.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-05 09:51 UTC by Michael Liddle
Modified: 2009-10-23 09:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Liddle 2009-07-05 09:51:12 UTC
Version:           2.1.1 (using 4.2.95 (KDE 4.2.95 (KDE 4.3 RC1)) "release 139", KDE:KDE4:Factory:Desktop / openSUSE_11.0)
Compiler:          gcc
OS:                Linux (i686) release 2.6.25.20-0.4-default

Not sure if this is a bug or a wish. Feel free to reclassify it.

Whenever (I think it's every time, but it might be only sometimes) Amarok is shut down "abnormally" it forgets many things on next start up. For example the current playlist and changes to widgets and/or their layout. This has happened to me pretty much from the 2.0 betas.

"Abnormally" here seems to be anything other than selecting "Quit" from the systray icon. Obviously this includes Amarok crashes, but also, say, an X crash (or forced exit---ctrl+alt+bkspc); even a completely normal KDE logout without  explicitly closing Amarok first (which happens quite often, as Amarok behaves for all intents and purposes as a background process, what with it living happily in the systray and all) causes this to happen.

Anyway, while I'd expect maybe that if some "task" was in progress when the shutdown occurred, then its changes might be forgotten, it seems odd that things which completed perfectly normally (in some cases hours ago) would also be forgotten.
Comment 1 Myriam Schweingruber 2009-07-08 14:58:44 UTC
FWIW, you should not do a forced shutdown of the X server with Ctrl+Alt+Backspace, as it doesn't allow the applications to save any settings, so this is not related to Amarok at all.
I suspect Amarok having not enough time to write its settings when you logout of KDE, could you check if this is happening everytime with a normal KDE logout?
Comment 2 Michael Liddle 2009-07-08 16:19:13 UTC
In a small number of tests I can confirm that it happened every time. Also lost are any album covers that were set since the last correct shutdown. 

If it is indeed the case that Amarok needs to write all this information to disk, all on quit, then it might be better to flush such state more often. As I say this occurs for things that have been changed for hours (or even days if I leave my computer on, or just suspend in between). For example if I play an album (replace playlist) in the afternoon, then logout in the evening, when I restart Amarok the _old_ playlist (i.e. whatever was there last time Amarok was manually "Quit") is reinstated. Could it be a DB commit issue? I don't know how to examine the DB now that it's using the embedded server...

As another data-point, last night I "supsended" my laptop, and something didn't go right. When I opened it this morning, it was still running, but I only got a blank screen, and no response otherwise. I had to do a hard (power-button) reset. In this case Amarok _did_ restore correctly. To speculate here, it seems that the suspend sufficiently forced things to flush, including Amarok, and the problem occurred later. But this is just speculation, I really have no idea!
Comment 3 Myriam Schweingruber 2009-07-09 17:54:46 UTC
Could well be a KDE problem then. Any ideas from the devs?
Comment 4 Michael Liddle 2009-10-23 09:25:25 UTC

*** This bug has been marked as a duplicate of bug 211509 ***