Bug 198869 - no navigator toolbar icons in kmail
Summary: no navigator toolbar icons in kmail
Status: RESOLVED WORKSFORME
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 1.4.2
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-07-04 08:47 UTC by Daniel Mang
Modified: 2016-11-03 14:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Mang 2009-07-04 08:47:10 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Debian testing/unstable Packages

After a computer restart, in kmail, the icons of those Kontact applications chosen for the navigator toolbar (in my case those are: mail, contacts, calendar and feeds) do not show up in the field they should show up in (in my case, on top), even though the navigator toolbar is activated and the applications are selected in the navigator toolbar settings. All I see are the icons of the Main Toolbar. The Navigator Toolbar icons only show up once I have opened up the toolbar configuration menu, effected some random change of configuration in the navigator toolbar and clicked on Apply or OK. If I then shut down Kontact and restart it, the icons are there. But the next time I launch Kontact after a computer shutdown and restart, it has "forgotten" and the icons are once more not there. As far as I can tell, this is only a problem in the kmail module, but since I do not use the other modules as much I am not 100% sure.
Comment 1 luisfe 2009-11-23 22:50:59 UTC
I can confirm this behaviour in the summary view, in the kmail module and in the akregator module.

Same package Debian testing/unstable.
Comment 2 Denis Kurz 2016-09-24 19:29:25 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kontact (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 3 luisfe 2016-10-31 18:34:47 UTC
I cannot reproduce this bug with kde applications 16.04. Rebooting shows the icons of navigator in kmail component.

It still looks strange that if I enable navigator toolbar in the summary view, it only appears in the summary view. I have to enable on each component I want to see it. This is probably by design.
Comment 4 Denis Kurz 2016-11-03 14:38:52 UTC
The original bug seems to be resolved, so I close. Thanks for the reply