Konversation has a "Use raw modes for mode changes" option. When this option is disabled (which it defaults to), the server response to "/mode <channel>" will be displayed in such a way that channel mode chars are replaced by human-readable strings, e.g. "moderated" for the "m" mode char. The same is true for the server response to a "/mode channel +/-<mode>" command (or someone else setting/removing a mode), however the list of human-readable strings used in those two cases is inconsistent. For example, while the "r" channel mode is shown as "server reop" in the response to "/mode <channel>", in the response to "/mode <channel> +/-<mode>" it is left as "r". Also, the Channel Settings Dialog ignores the setting and always uses mode chars in its Advanced Modes table. And finally, as the setting affects more than only mode changes, it should have a more generic name covering all of its effects.
SVN commit 989313 by hein: Use a better name for the raw modes option. CCBUG:198371 M +1 -1 chatwindowbehaviour_config.ui WebSVN link: http://websvn.kde.org/?view=rev&revision=989313
SVN commit 1000978 by tjmchenry: Move raw mode -> mode strings to a qhash in common.cpp Use this in channeloptionsdialog's 'show advanced modes' list CCBUG:198371 Add CHANMODES from RPL_ISUPPORT to the allowedChannelModes() BUG:198365 M +26 -0 common.cpp M +8 -0 common.h M +9 -3 irc/channeloptionsdialog.cpp M +36 -20 irc/inputfilter.cpp WebSVN link: http://websvn.kde.org/?view=rev&revision=1000978
SVN commit 1001026 by tjmchenry: Move the get for the channelmodeshash to a smarter location Remove a no longer needed spell check setting on-close Make it so modes are translated if known with /mode #channel +/-<mode> BUG:198371 M +23 -8 channel.cpp M +1 -1 inputfilter.cpp WebSVN link: http://websvn.kde.org/?view=rev&revision=1001026