Bug 197867 - Option to cd into dropped directories
Summary: Option to cd into dropped directories
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Unspecified
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-25 19:35 UTC by Dotan Cohen
Modified: 2012-04-20 05:39 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-06-25 19:35:55 UTC
Version:            (using KDE 4.2.90)
Installed from:    Ubuntu Packages

When dragging folders from Konquerer into Konsole, it would be nice if Konsole offered to cd into that directory.
Comment 1 Donn Ingle 2009-06-25 20:12:24 UTC
cd or mv or cp. KDE 3.x used to do this (well the cd at least, can't recall the exact details).
Comment 2 Kurt Hindenburg 2009-06-29 01:25:18 UTC
Yea, the old Konsole 3 had a menu where you could choose.  With KDE 4 you have to type 'cd' and then drag-n-drop.  I'm not sure if it was removed due to lack of time coding or usability/feature issues.
Comment 3 Kurt Hindenburg 2011-03-06 01:01:18 UTC
*** Bug 252725 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2012-01-26 16:10:54 UTC
Git commit c08484f40a424825490cb297e33046cb5ffdad5a by Jekyll Wu.
Committed on 26/01/2012 at 17:05.
Pushed by jekyllwu into branch 'master'.

Add action "Change Directory to" for cding into dropped directory.

That action is shown only when:
1). only one item is selected and dropped
2). that item is local instead of remote
3). that item is a directory instead of file
FIXED-IN: 4.9

M  +28   -0    src/TerminalDisplay.cpp
M  +2    -0    src/TerminalDisplay.h

http://commits.kde.org/konsole/c08484f40a424825490cb297e33046cb5ffdad5a