Bug 197754 - plasma crash on Download New Google Gadgets
Summary: plasma crash on Download New Google Gadgets
Status: RESOLVED UPSTREAM
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 206957 207065 207714 208662 210273 214080 220155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-24 19:34 UTC by Pedro
Modified: 2009-12-26 18:07 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2009-06-24 19:34:50 UTC
Application that crashed: plasma-desktop
Version of the application: 0.3
KDE Version: 4.2.92 (KDE 4.2.92 (KDE 4.3 >= 20090617)) "release 1"
Qt Version: 4.5.1
Operating System: Linux 2.6.27.23-0.1-pae i686

What I was doing when the application crashed:
Plasma crashed when choosing Install New Widgets>Download New Google Gadgets.
I can reproduce this every time I choose this option.
It started when I updated google-gadgets from version 0.10.5 to version 0.11 (google-gadgets-0.11.0-24.1 from openSUSE repos).

 -- Backtrace:
Application: Plasma Workspace (kdeinit), signal: Segmentation fault
[Current thread is 1 (Thread 0xb5e32710 (LWP 7231))]

Thread 2 (Thread 0xa7cc3b90 (LWP 7238)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb7ce0c35 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7d40722 in QWaitCondition::wait (this=0x85e96d8, mutex=0x85e96d4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  0xb75b9ae2 in QHostInfoAgent::run (this=0x85e96c8) at kernel/qhostinfo.cpp:260
#4  0xb7d3f70e in QThreadPrivate::start (arg=0x85e96c8) at thread/qthread_unix.cpp:189
#5  0xb7cdd1b5 in start_thread () from /lib/libpthread.so.0
#6  0xb64fe3be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5e32710 (LWP 7231)):
[KCrash Handler]
#6  0xa57b42fb in ggadget::smjs::JSScriptContext::MaybeGC(JSContext*) () from /usr/lib/google-gadgets/modules/smjs-script-runtime.so
#7  0xa57b15fe in ggadget::smjs::JSFunctionSlot::Call(ggadget::ScriptableInterface*, int, ggadget::Variant const*) const () from /usr/lib/google-gadgets/modules/smjs-script-runtime.so
#8  0xa5d3bc24 in ggadget::Signal::Emit(int, ggadget::Variant const*) const () from /usr/lib/libggadget-1.0.so.0
#9  0xa5d23cba in ggadget::SignalSlot::Call(ggadget::ScriptableInterface*, int, ggadget::Variant const*) const () from /usr/lib/libggadget-1.0.so.0
#10 0xa5d66448 in ggadget::View::Impl::SetSize(double, double) () from /usr/lib/libggadget-1.0.so.0
#11 0xa5d633d3 in ggadget::MethodSlot2<void, double, double, ggadget::View::Impl, void (ggadget::View::Impl::*)(double, double)>::Call(ggadget::ScriptableInterface*, int, ggadget::Variant const*) const () from /usr/lib/libggadget-1.0.so.0
#12 0xa57b92fd in ggadget::smjs::NativeJSWrapper::CallNativeSlot(char const*, ggadget::Slot*, unsigned int, long*, long*) () from /usr/lib/google-gadgets/modules/smjs-script-runtime.so
#13 0xa57b94ac in ggadget::smjs::NativeJSWrapper::CallMethod(unsigned int, long*, long*) () from /usr/lib/google-gadgets/modules/smjs-script-runtime.so
#14 0xa57b99cd in ggadget::smjs::NativeJSWrapper::CallWrapperMethod(JSContext*, JSObject*, unsigned int, long*, long*) () from /usr/lib/google-gadgets/modules/smjs-script-runtime.so
#15 0xa569098e in js_Invoke () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#16 0xa5680afc in ?? () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#17 0xa56909a1 in js_Invoke () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#18 0xa5690cde in ?? () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#19 0xa5654fdd in JS_CallFunctionValue () from /usr/lib/xulrunner-1.9.1/libmozjs.so
#20 0xa57b158c in ggadget::smjs::JSFunctionSlot::Call(ggadget::ScriptableInterface*, int, ggadget::Variant const*) const () from /usr/lib/google-gadgets/modules/smjs-script-runtime.so
#21 0xa5d3bc24 in ggadget::Signal::Emit(int, ggadget::Variant const*) const () from /usr/lib/libggadget-1.0.so.0
#22 0xa5d23cba in ggadget::SignalSlot::Call(ggadget::ScriptableInterface*, int, ggadget::Variant const*) const () from /usr/lib/libggadget-1.0.so.0
#23 0xa5d658ba in ggadget::View::Impl::FireEvent(ggadget::ScriptableEvent*, ggadget::Signal0<void> const&) () from /usr/lib/libggadget-1.0.so.0
#24 0xa5d613b3 in ggadget::View::OnOtherEvent(ggadget::Event const&) () from /usr/lib/libggadget-1.0.so.0
#25 0xa5d2e558 in ggadget::ScriptableView::Impl::InitFromXML(std::string const&, char const*) () from /usr/lib/libggadget-1.0.so.0
#26 0xa5d2a8be in ggadget::ScriptableView::InitFromXML(std::string const&, char const*) () from /usr/lib/libggadget-1.0.so.0
#27 0xa5cc72c6 in ggadget::Gadget::Impl::Initialize() () from /usr/lib/libggadget-1.0.so.0
#28 0xa5cbbbdf in ggadget::Gadget::Gadget(ggadget::HostInterface*, char const*, char const*, int, ggadget::Permissions const&, ggadget::Gadget::DebugConsoleConfig) ()
   from /usr/lib/libggadget-1.0.so.0
#29 0xa57e754a in ggadget::google::GoogleGadgetManager::ShowGadgetBrowserDialog(ggadget::HostInterface*) () from /usr/lib/google-gadgets/modules/google-gadget-manager.so
#30 0xa74619f9 in ?? () from /usr/lib/kde4/plasma_package_ggl.so
#31 0xb4893b3a in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#32 0xb4897dad in ?? () from /usr/lib/libkdeinit4_plasma-desktop.so
#33 0xb7e49dc8 in QMetaObject::activate (sender=0x8ffda70, from_signal_index=5, to_signal_index=5, argv=0xbff6a68c) at kernel/qobject.cpp:3120
#34 0xb7e4b552 in QMetaObject::activate (sender=0x8ffda70, m=0xb7f29878, local_signal_index=1, argv=0xbff6a68c) at kernel/qobject.cpp:3194
#35 0xb7e4ccb3 in QSignalMapper::mapped (this=0x8ffda70, _t1=@0xbff6a6c8) at .moc/release-shared/moc_qsignalmapper.cpp:102
#36 0xb7e4d5dd in QSignalMapper::map (this=0x8ffda70, sender=0x95e42f0) at kernel/qsignalmapper.cpp:268
#37 0xb7e4d77e in QSignalMapper::map (this=0x8ffda70) at kernel/qsignalmapper.cpp:257
#38 0xb7e4e0bb in QSignalMapper::qt_metacall (this=0x8ffda70, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbff6a80c) at .moc/release-shared/moc_qsignalmapper.cpp:81
#39 0xb7e49dc8 in QMetaObject::activate (sender=0x95e42f0, from_signal_index=5, to_signal_index=6, argv=0xbff6a80c) at kernel/qobject.cpp:3120
#40 0xb7e4a200 in QMetaObject::activate (sender=0x95e42f0, m=0xb704f1a8, from_local_signal_index=1, to_local_signal_index=2, argv=0xbff6a80c) at kernel/qobject.cpp:3214
#41 0xb67cc021 in QAction::triggered (this=0x95e42f0, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#42 0xb67cd59f in QAction::activate (this=0x95e42f0, event=QAction::Trigger) at kernel/qaction.cpp:1160
#43 0xb6c2c1d4 in QMenuPrivate::activateCausedStack (this=0x95738c8, causedStack=@0xbff6a8e8, action=0x95e42f0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:967
#44 0xb6c3298b in QMenuPrivate::activateAction (this=0x95738c8, action=0x95e42f0, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1060
#45 0xb6c334d2 in QMenu::mouseReleaseEvent (this=0x8463f18, e=0xbff6af28) at widgets/qmenu.cpp:2254
#46 0xb73d89b5 in KMenu::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#47 0xb6829323 in QWidget::event (this=0x8463f18, event=0xbff6af28) at kernel/qwidget.cpp:7521
#48 0xb6c35789 in QMenu::event (this=0x8463f18, e=0xbff6af28) at widgets/qmenu.cpp:2353
#49 0xb67d269c in QApplicationPrivate::notify_helper (this=0x80b09c0, receiver=0x8463f18, e=0xbff6af28) at kernel/qapplication.cpp:4057
#50 0xb67db311 in QApplication::notify (this=0x80aa830, receiver=0x8463f18, e=0xbff6af28) at kernel/qapplication.cpp:3759
#51 0xb72f0edd in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#52 0xb7e33adb in QCoreApplication::notifyInternal (this=0x80aa830, receiver=0x8463f18, event=0xbff6af28) at kernel/qcoreapplication.cpp:610
#53 0xb67da37e in QApplicationPrivate::sendMouseEvent (receiver=0x8463f18, event=0xbff6af28, alienWidget=0x0, nativeWidget=0x8463f18, buttonDown=0xb7067a40, lastMouseReceiver=@0xb7067a44)
    at ../../src/corelib/kernel/qcoreapplication.h:216
#54 0xb684a78e in QETWidget::translateMouseEvent (this=0x8463f18, event=0xbff6c5bc) at kernel/qapplication_x11.cpp:4380
#55 0xb68498dd in QApplication::x11ProcessEvent (this=0x80aa830, event=0xbff6c5bc) at kernel/qapplication_x11.cpp:3442
#56 0xb687327a in x11EventSourceDispatch (s=0x80b3330, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#57 0xb637b9c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#58 0xb637f083 in ?? () from /usr/lib/libglib-2.0.so.0
#59 0xb637f241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#60 0xb7e5f558 in QEventDispatcherGlib::processEvents (this=0x80affa0, flags={i = -1074346120}) at kernel/qeventdispatcher_glib.cpp:324
#61 0xb6872975 in QGuiEventDispatcherGlib::processEvents (this=0x80affa0, flags={i = -1074346072}) at kernel/qguieventdispatcher_glib.cpp:202
#62 0xb7e320fa in QEventLoop::processEvents (this=0xbff6c81c, flags={i = -1074346008}) at kernel/qeventloop.cpp:149
#63 0xb7e3253a in QEventLoop::exec (this=0xbff6c81c, flags={i = -1074345948}) at kernel/qeventloop.cpp:200
#64 0xb6c355f1 in QMenu::exec (this=0x8463f18, p=@0xbff6c8c4, action=0x0) at widgets/qmenu.cpp:1993
#65 0xb6c41caa in QPushButtonPrivate::_q_popupPressed (this=0x85d0220) at widgets/qpushbutton.cpp:611
#66 0xb6c4333f in QPushButton::qt_metacall (this=0x8aa27c8, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbff6c9b8) at .moc/release-shared/moc_qpushbutton.cpp:74
#67 0xb73e694a in KPushButton::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdeui.so.5
#68 0xb7e49dc8 in QMetaObject::activate (sender=0x8aa27c8, from_signal_index=27, to_signal_index=27, argv=0x0) at kernel/qobject.cpp:3120
#69 0xb7e4b552 in QMetaObject::activate (sender=0x8aa27c8, m=0xb7060244, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3194
#70 0xb6e6f437 in QAbstractButton::pressed (this=0x8aa27c8) at .moc/release-shared/moc_qabstractbutton.cpp:187
#71 0xb6b97f19 in QAbstractButtonPrivate::emitPressed (this=0x85d0220) at widgets/qabstractbutton.cpp:557
#72 0xb6b980fe in QAbstractButton::mousePressEvent (this=0x8aa27c8, e=0xbff6cfb8) at widgets/qabstractbutton.cpp:1092
#73 0xb73e6591 in KPushButton::mousePressEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#74 0xb6829426 in QWidget::event (this=0x8aa27c8, event=0xbff6cfb8) at kernel/qwidget.cpp:7517
#75 0xb6b9820e in QAbstractButton::event (this=0x8aa27c8, e=0xbff6cfb8) at widgets/qabstractbutton.cpp:1077
#76 0xb6c43170 in QPushButton::event (this=0x8aa27c8, e=0xbff6cfb8) at widgets/qpushbutton.cpp:662
#77 0xb67d269c in QApplicationPrivate::notify_helper (this=0x80b09c0, receiver=0x8aa27c8, e=0xbff6cfb8) at kernel/qapplication.cpp:4057
#78 0xb67db311 in QApplication::notify (this=0x80aa830, receiver=0x8aa27c8, e=0xbff6cfb8) at kernel/qapplication.cpp:3759
#79 0xb72f0edd in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#80 0xb7e33adb in QCoreApplication::notifyInternal (this=0x80aa830, receiver=0x8aa27c8, event=0xbff6cfb8) at kernel/qcoreapplication.cpp:610
#81 0xb67da37e in QApplicationPrivate::sendMouseEvent (receiver=0x8aa27c8, event=0xbff6cfb8, alienWidget=0x8aa27c8, nativeWidget=0x875af00, buttonDown=0xb7067a40, lastMouseReceiver=@0xb7067a44)
    at ../../src/corelib/kernel/qcoreapplication.h:216
#82 0xb684a506 in QETWidget::translateMouseEvent (this=0x875af00, event=0xbff6e64c) at kernel/qapplication_x11.cpp:4446
#83 0xb68498dd in QApplication::x11ProcessEvent (this=0x80aa830, event=0xbff6e64c) at kernel/qapplication_x11.cpp:3442
#84 0xb687327a in x11EventSourceDispatch (s=0x80b3330, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#85 0xb637b9c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#86 0xb637f083 in ?? () from /usr/lib/libglib-2.0.so.0
#87 0xb637f241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#88 0xb7e5f558 in QEventDispatcherGlib::processEvents (this=0x80affa0, flags={i = -1074337784}) at kernel/qeventdispatcher_glib.cpp:324
#89 0xb6872975 in QGuiEventDispatcherGlib::processEvents (this=0x80affa0, flags={i = -1074337736}) at kernel/qguieventdispatcher_glib.cpp:202
#90 0xb7e320fa in QEventLoop::processEvents (this=0xbff6e8b0, flags={i = -1074337672}) at kernel/qeventloop.cpp:149
#91 0xb7e3253a in QEventLoop::exec (this=0xbff6e8b0, flags={i = -1074337608}) at kernel/qeventloop.cpp:200
#92 0xb7e349e9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#93 0xb67d2517 in QApplication::exec () at kernel/qapplication.cpp:3526
#94 0xb4871930 in kdemain () from /usr/lib/libkdeinit4_plasma-desktop.so
#95 0x0804e2b0 in _start ()

Reported using DrKonqi
Comment 1 Marco Martin 2009-06-24 19:38:35 UTC
this seems an issue deeeply in google gadgets
the best thing to do would be trying to reproduce also by running google gadgets standalone and report it here
http://code.google.com/p/google-gadgets-for-linux/
Comment 2 Dario Andres 2009-09-11 16:41:17 UTC
*** Bug 207065 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2009-09-17 00:31:05 UTC
*** Bug 206957 has been marked as a duplicate of this bug. ***
Comment 4 Dario Andres 2009-09-18 00:26:38 UTC
*** Bug 207714 has been marked as a duplicate of this bug. ***
Comment 5 Dario Andres 2009-09-27 13:38:02 UTC
*** Bug 208662 has been marked as a duplicate of this bug. ***
Comment 6 Dario Andres 2009-10-12 14:47:14 UTC
*** Bug 210273 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-11-11 13:20:51 UTC
*** Bug 214080 has been marked as a duplicate of this bug. ***
Comment 8 Dario Andres 2009-12-26 18:07:57 UTC
*** Bug 220155 has been marked as a duplicate of this bug. ***