Bug 197553 - Konqueror crash when closing application
Summary: Konqueror crash when closing application
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-22 22:44 UTC by Pieter Vande Wyngaerde
Modified: 2009-06-23 03:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pieter Vande Wyngaerde 2009-06-22 22:44:46 UTC
Application that crashed: konqueror
Version of the application: 4.2.92 (KDE 4.2.92 (KDE 4.3 >= 20090617))
KDE Version: 4.2.92 (KDE 4.2.92 (KDE 4.3 >= 20090617))
Qt Version: 4.5.1
Operating System: Linux 2.6.28-13-generic x86_64
Distribution: Ubuntu 9.04

 -- Backtrace:
Application: Konqueror (kdeinit), signal: Aborted
[KCrash Handler]
#5  0x00007fc41be7ffb5 in *__GI_raise (sig=<value optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#6  0x00007fc41be81bc3 in *__GI_abort () at abort.c:88
#7  0x00007fc41be78f09 in *__GI___assert_fail (assertion=0x7fc40c93d351 "!s_refcnt", file=0x7fc40c93d2b0 "/build/buildd/kde-nightly-kdelibs-20090619+svn984009/khtml/khtml_global.cpp", line=258, 
    function=0x7fc40c93d4c0 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#8  0x00007fc40c60f7eb in KHTMLGlobal::finalCheck () at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/khtml/khtml_global.cpp:258
#9  0x00007fc40ce0075a in ~KHTMLFactory (this=0x264a6c0) at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/khtml/khtml_factory.cpp:35
#10 0x00007fc41f06ea31 in qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator> (begin={i = 0x2649700}, end={i = 0x2642bd0}) at /opt/project-neon/include/QtCore/qalgorithms.h:350
#11 0x00007fc41f06ec59 in ~FactoryHash (this=0x2347) at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/kdecore/util/klibrary.cpp:93
#12 0x00007fc41f06dd92 in destroy () at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/kdecore/util/klibrary.cpp:97
#13 0x00007fc41be836ed in *__GI_exit (status=0) at exit.c:75
#14 0x0000000000406fb2 in launch (argc=2, _name=0x22351b8 "konqueror", args=0x22351ec "", cwd=0x22351ed "/home/pvandewyngaerde/Documenten", envc=40, envs=<value optimized out>, reset_env=true, 
    tty=0x0, avoid_loops=false, startup_id_str=0x2235899 "0") at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/kinit/kinit.cpp:672
#15 0x0000000000407b02 in handle_launcher_request (sock=12, who=<value optimized out>) at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/kinit/kinit.cpp:1164
#16 0x000000000040830c in handle_requests (waitForPid=0) at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/kinit/kinit.cpp:1348
#17 0x00000000004087de in main (argc=2, argv=0x7fff27b7b388, envp=0x7fff27b7b3a0) at /build/buildd/kde-nightly-kdelibs-20090619+svn984009/kinit/kinit.cpp:1784

Reported using DrKonqi
Comment 1 Dario Andres 2009-06-23 03:27:33 UTC
Thanks. This is reported under bug 151453.

*** This bug has been marked as a duplicate of bug 151453 ***