Bug 197029 - Lokalize crash when I edit an entry
Summary: Lokalize crash when I edit an entry
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: lokalize
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-18 17:04 UTC by Zayed Al-Saidi
Modified: 2009-06-18 17:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zayed Al-Saidi 2009-06-18 17:04:29 UTC
Version:            (using KDE 4.2.3)
Installed from:    SuSE RPMs

when I start to edit an entry, lokalize crashed. I use Arabic language and RTL layout direction. I'm working to translate kde po file to Arabic.  

تطبيق: Lokalize (lokalize), signal SIGSEGV
[Current thread is 1 (Thread 0xb5bc9700 (LWP 18106))]

Thread 2 (Thread 0xb4519b90 (LWP 18107)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb6584e93 in ?? () from /lib/libc.so.6
#2  0xb65184e1 in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb5bc9700 (LWP 18106)):
[KCrash Handler]
#6  0xb6515755 in ?? () from /lib/libc.so.6
#7  0xb651788c in malloc () from /lib/libc.so.6
#8  0xb6791ced in qMalloc(unsigned int) () from /usr/lib/libQtCore.so.4
#9  0xb67dd3ed in QString::fromLatin1_helper(char const*, int) () from /usr/lib/libQtCore.so.4
#10 0xb67e864c in QString::fromAscii_helper(char const*, int) () from /usr/lib/libQtCore.so.4
#11 0xb74d8a3f in KCatalog::language (this=0x8300520) at /usr/include/QtCore/qstring.h:388
#12 0xb74ed07a in KLocalePrivate::translate_priv (this=0x818afb8, msgctxt=0x853b838 "@info:tooltip Tooltip of toolbar button", msgid=0x82cd5b0 "%1", msgid_plural=0x0, n=0, language=0xbfc4d680, 
    translation=0xbfc4d67c) at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocale.cpp:756
#13 0xb74ed6c0 in KLocale::translateRaw (this=0x81695c0, ctxt=0x853b838 "@info:tooltip Tooltip of toolbar button", msg=0x82cd5b0 "%1", lang=0xbfc4d680, trans=0xbfc4d67c)
    at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocale.cpp:789
#14 0xb74f7665 in KLocalizedStringPrivate::toString (this=0x85322d8, locale=0x81695c0) at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocalizedstring.cpp:243
#15 0xb74f8004 in KLocalizedString::toString (this=0xbfc4d6e0) at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocalizedstring.cpp:205
#16 0xb7bbd233 in i18nc<QString> (ctxt=0xb7c2d8e4 "@info:tooltip Tooltip of toolbar button", text=0xb7c09b5a "%1", a1=@0xbfc4d824)
    at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocalizedstring.h:748
#17 0xb7bb5219 in KToolBar::eventFilter (this=0x81c13c8, watched=0x83181a0, event=0xbfc4dbe0) at /usr/src/debug/kdelibs-4.2.3/kdeui/widgets/ktoolbar.cpp:1282
#18 0xb688b37a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#19 0xb6aa78ca in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#20 0xb6aafcc2 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#21 0xb7aa70cd in KApplication::notify (this=0xbfc50b74, receiver=0x83181a0, event=0xbfc4dbe0) at /usr/src/debug/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#22 0xb688c16b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#23 0xb6ab2a7e in QCoreApplication::sendEvent(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0xb6affb50 in QWidgetPrivate::setEnabled_helper(bool) () from /usr/lib/libQtGui.so.4
#25 0xb6affc61 in QWidget::setEnabled(bool) () from /usr/lib/libQtGui.so.4
#26 0xb6f2b16b in QToolButton::setDefaultAction(QAction*) () from /usr/lib/libQtGui.so.4
#27 0xb6f2b319 in QToolButton::actionEvent(QActionEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb6afe9f5 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#29 0xb6e4033e in QAbstractButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
#30 0xb6f2c5ea in QToolButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
#31 0xb6aa78ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#32 0xb6aafcc2 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#33 0xb7aa70cd in KApplication::notify (this=0xbfc50b74, receiver=0x83181a0, event=0xbfc4e108) at /usr/src/debug/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#34 0xb688c16b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#35 0xb6aa2488 in ?? () from /usr/lib/libQtGui.so.4
#36 0xb6aa5573 in QAction::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
#37 0xb6b0843a in QWidgetAction::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libQtGui.so.4
#38 0xb79cc54a in KAction::qt_metacall (this=0x82809f8, _c=QMetaObject::InvokeMetaMethod, _id=17, _a=0xbfc4e2dc) at /usr/src/debug/kdelibs-4.2.3/build/kdeui/kaction.moc:84
#39 0xb68a1788 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#40 0xb68a2412 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#41 0xb71233d9 in QUndoStack::cleanChanged(bool) () from /usr/lib/libQtGui.so.4
#42 0xb710fb1d in ?? () from /usr/lib/libQtGui.so.4
#43 0xb711047d in QUndoStack::push(QUndoCommand*) () from /usr/lib/libQtGui.so.4
#44 0x08083293 in _start ()
Comment 1 Pino Toscano 2009-06-18 17:10:16 UTC

*** This bug has been marked as a duplicate of bug 191122 ***