Bug 196261 - Nepomuk Strigi File Indexing suspended at startup
Summary: Nepomuk Strigi File Indexing suspended at startup
Status: RESOLVED FIXED
Alias: None
Product: nepomuk
Classification: Unclassified
Component: fileindexer (show other bugs)
Version: 4.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
: 222665 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-12 23:10 UTC by Peter Dewitt
Modified: 2012-06-16 13:02 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Dewitt 2009-06-12 23:10:42 UTC
Version:            (using KDE 4.2.4)
Compiler:          gcc-4.3.2 
OS:                Linux
Installed from:    Gentoo Packages

When logging in a notification pops up explaining that Nepomuk is suspended to preserve resources. This happens every time, my machine is a quad core Phemon with 4GB of ram so this message makes appears to be wrong. If I disable the indexer then enable again it works fine, however since an update from KDE 4.2.3 to 4.2.4 I now get the message "Could not get owner ... nepomuk.services.nepomukstrigiservice: no such name" when trying to enable Strigi.
Comment 1 Sebastian Trueg 2009-12-14 11:01:45 UTC
I think this has been fixed already. Does it still happen with KDE 4.4 beta1?
Comment 2 Thomas Richard 2009-12-17 19:21:04 UTC
It does on my laptop. Not every time. Powerdevil says that the power adapter is connected but i still get a warning that file indexing is suspended.

It starts indexing again as soon as i pull out my power cord and reattach it again.
Comment 3 Sebastian Trueg 2010-01-26 11:26:34 UTC
*** Bug 222665 has been marked as a duplicate of this bug. ***
Comment 4 Romain Henriet 2010-03-14 10:04:56 UTC
Same problem for me on my desktop computer (Opensuse, KDE 4.4.1)
Comment 5 Anthony 2010-08-10 18:30:36 UTC
I am experiencing the same problem.  Running openSUSE 11.3 on a Thinkpad X40.  It has 1GB of memory and a 1.2Ghz Pentium M processor.  Not a powerhouse but everything else runs really well.  I enable indexing from the System Tray, it goes along and indexes for a minute or two and then suspends the indexing.  I can see the virtuoso-t process running at 100% while this is happening.  This is even when it is plugged in and the power settings are set to "performance".

What additional information can I provide that would be useful?
Comment 6 fatgerman 2010-12-04 20:39:17 UTC
Confirmed for me on KDE 4.5.4 on a Core i5 with 4GB of RAM. At startup my virtuoso-t process takes 100% CPU for quite a while and it is that I think that makes strigi suspend itself. What fixed it for me was to give nepomuk a shedload more RAM - it was set to 50MB - increasing it to 400MB finally sorted this for me, but 400MB for a metadata database is seriously overkill. It seems like some kind of performance problem.
Comment 7 l33tmmx 2011-07-31 19:14:25 UTC
I haven't seen this before, on earlier versions, but after upgrading to KDE-4.7.0 on Gentoo I started getting exactly the same "Indexing suspeded to preserve resources" notification popups on login. And this happens on a desktop machine...
Comment 8 Vishesh Handa 2012-06-16 13:02:09 UTC
Git commit be468ffc088dd48c86612340d1db89a718a0aa97 by Vishesh Handa.
Committed on 16/06/2012 at 13:12.
Pushed by vhanda into branch 'master'.

No event notifications when Resuming/Suspending indexing of resources

Indexing is a background process that the user shouldn't be aware about.
We should just work, and not annoy the user about stuff like this.

Added a config option in nepomukstrigirc just in case anyone wants it.
Add ShowSuspendResumeEvents = true in [General]
REVIEW: 105271

M  +7    -2    services/fileindexer/eventmonitor.cpp

http://commits.kde.org/nepomuk-core/be468ffc088dd48c86612340d1db89a718a0aa97