Bug 196053 - Kontact crashes at random. Multiple times a day. (KMAccount::runPrecommand)
Summary: Kontact crashes at random. Multiple times a day. (KMAccount::runPrecommand)
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: pop3 (show other bugs)
Version: 1.11.2
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 206902 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-11 17:39 UTC by Jeppe Fock
Modified: 2009-09-09 21:28 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of kmail (4.15 KB, text/plain)
2009-07-08 10:06 UTC, Jeppe Fock
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeppe Fock 2009-06-11 17:39:45 UTC
Version:           Kontact: 1.4.2 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

Kontact crashes at random.  It happens to me multiple times a day, but I can find a systematic event which courses the crash. 

When restarting kontact the last state of kmail is restored, except for the marking of some of the read mails as unread.


Backtraces:
Application: Kontact (kontact), signal SIGSEGV
0x00007f2902d79d21 in nanosleep () from /lib/libc.so.6
Current language:  auto; currently c
[Current thread is 0 (LWP 31217)]

Thread 2 (Thread 0x7f28e8d78950 (LWP 31260)):
#0  0x00007f2902db0742 in select () from /lib/libc.so.6
#1  0x00007f2903921f06 in QProcessManager::run (this=0x1d32150) at io/qprocess_unix.cpp:305
#2  0x00007f290385a952 in QThreadPrivate::start (arg=0x1d32150) at thread/qthread_unix.cpp:189
#3  0x00007f29001263ba in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00007f2902db7fcd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f290920f750 (LWP 31217)):
[KCrash Handler]
#5  QEventLoop::exec (this=0x2ee4810, flags={i = 287691168}) at ../../include/QtCore/../../src/corelib/tools/qvector.h:127
#6  0x00007f28f05501cb in KMAccount::runPrecommand (this=0x24e4d20, precommand=<value optimized out>) at /build/buildd/kdepim-4.2.2/kmail/kmaccount.cpp:407
#7  0x00007f28f06b606d in KMail::PopAccount::startJob (this=0x7f2903c34980) at /build/buildd/kdepim-4.2.2/kmail/popaccount.cpp:364
#8  0x00007f28f06b7867 in KMail::PopAccount::processNewMail (this=0x24e4d20, _interactive=false) at /build/buildd/kdepim-4.2.2/kmail/popaccount.cpp:194
#9  0x00007f28f05da0d2 in KMail::AccountManager::processNextCheck (this=0x24e17c0, _newMail=<value optimized out>) at /build/buildd/kdepim-4.2.2/kmail/accountmanager.cpp:228
#10 0x00007f28f05dab82 in KMail::AccountManager::singleCheckMail (this=0x24e17c0, account=0x24e4d20, interactive=<value optimized out>) at /build/buildd/kdepim-4.2.2/kmail/accountmanager.cpp:155
#11 0x00007f28f054d0d5 in KMAccount::qt_metacall (this=0x24e4d20, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff1125da40)
    at /build/buildd/kdepim-4.2.2/obj-x86_64-linux-gnu/kmail/kmaccount.moc:147
#12 0x00007f28f06b5f25 in KMail::PopAccount::qt_metacall (this=0x7f2903c34980, _c=QMetaObject::QueryPropertyScriptable, _id=30654624, _a=0x5)
    at /build/buildd/kdepim-4.2.2/obj-x86_64-linux-gnu/kmail/popaccount.moc:77
#13 0x00007f29039591f2 in QMetaObject::activate (sender=0x257e630, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x5) at kernel/qobject.cpp:3069
#14 0x00007f29039534d3 in QObject::event (this=0x257e630, e=0x5) at kernel/qobject.cpp:1082
#15 0x00007f29044ec78d in QApplicationPrivate::notify_helper (this=0x1d32560, receiver=0x257e630, e=0x7fff1125e0f0) at kernel/qapplication.cpp:4084
#16 0x00007f29044f497a in QApplication::notify (this=0x7fff1125e440, receiver=0x257e630, e=0x7fff1125e0f0) at kernel/qapplication.cpp:4049
#17 0x00007f290592126b in KApplication::notify (this=0x7fff1125e440, receiver=0x257e630, event=0x7fff1125e0f0) at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:307
#18 0x00007f290394375c in QCoreApplication::notifyInternal (this=0x7fff1125e440, receiver=0x257e630, event=0x7fff1125e0f0) at kernel/qcoreapplication.cpp:602
#19 0x00007f29039707f6 in QTimerInfoList::activateTimers (this=0x1d3c040) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 0x00007f290396cf0d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:164
#21 0x00007f28fd08c20a in IA__g_main_context_dispatch (context=0x1d3b120) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#22 0x00007f28fd08f8e0 in g_main_context_iterate (context=0x1d3b120, block=1, dispatch=1, self=<value optimized out>) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#23 0x00007f28fd08fa7c in IA__g_main_context_iteration (context=0x1d3b120, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#24 0x00007f290396ce6f in QEventDispatcherGlib::processEvents (this=0x1d09f20, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:323
#25 0x00007f2904584bef in QGuiEventDispatcherGlib::processEvents (this=0x7f2903c34980, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#26 0x00007f2903942002 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 287695712}) at kernel/qeventloop.cpp:149
#27 0x00007f29039423cd in QEventLoop::exec (this=0x7fff1125e3a0, flags={i = 287695792}) at kernel/qeventloop.cpp:200
#28 0x00007f2903944694 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#29 0x0000000000404a15 in main (argc=1, argv=0x7fff1125eb28) at /build/buildd/kdepim-4.2.2/kontact/src/main.cpp:218
Comment 1 Christophe Marin 2009-06-12 11:55:56 UTC
Maybe related to bug 124372
Comment 2 Jeppe Fock 2009-07-06 18:41:46 UTC
After a clean reinstall of Kubuntu juanty, kontact/kmail still crashes with the same traceback.  I don't see any relation to bug 124372, but I'm no developer.

I will be happy to provide further details for the bug to be solved.
Comment 3 Jeppe Fock 2009-07-08 10:06:17 UTC
Created attachment 35146 [details]
Backtrace of kmail

Backtrace of bug
Comment 4 Jeppe Fock 2009-07-08 10:09:54 UTC
When stating kmail directly (instead of stating kontact), a slightly different backtrace is produced. I have attached the backtrace here. Please ask  for more details if needed.
Comment 5 Jeppe Fock 2009-07-08 10:11:57 UTC
Comment on attachment 35146 [details]
Backtrace of kmail

When stating kmail directly (instead of stating kontact), a slightly different
backtrace is produced. I have attached the backtrace here. Please ask  for more
details if needed.
Comment 6 Christophe Marin 2009-07-18 17:58:01 UTC
Do you have a pre-command set for this account ? (kmail/settings/Configure KMail/Accounts and the "Advanced tab"
Comment 7 Jeppe Fock 2009-07-18 18:53:29 UTC
Yes I have two accounts each calling a script which connect to a the specific server. The script contains:

ssh -C -f username@server -L 2025:localhost:25  -L 2110:mail.server:110 'sleep 5'; sleep 1
Comment 8 Martin Koller 2009-08-31 23:48:11 UTC
SVN commit 1017922 by mkoller:

BUG: 196053

Fix crash in precommand execution (hopefully).
The crash was probably due to the eventloop object got destroyed in its own loop.


 M  +5 -11     kmaccount.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1017922
Comment 9 Christophe Marin 2009-09-09 21:28:55 UTC
*** Bug 206902 has been marked as a duplicate of this bug. ***