Bug 195837 - Digital Clock date does not conform to SS locale setting
Summary: Digital Clock date does not conform to SS locale setting
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-clock (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 174334 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-10 01:01 UTC by James Richard Tyrer
Modified: 2011-01-04 23:03 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screen Shot from experimental code (11.75 KB, image/png)
2009-07-03 08:03 UTC, James Richard Tyrer
Details
Clock with date formated by KDEGlobal Locale information (5.67 KB, image/png)
2009-07-24 05:11 UTC, James Richard Tyrer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Richard Tyrer 2009-06-10 01:01:28 UTC
Version:            (using Devel)
Compiler:          4.3.3 
OS:                Linux
Installed from:    Compiled sources

SystemSettings Locale Date Format set to:

WEEKDAY MONTH dD YYYY

and the Digital Clock says:

Tue, 9 Jun 2009

While it is OK for the Digital Clock Settings to modify the string set in SystemSettings.  That is, to remove WEEKDAY or YYYY, it does need to start with the string set there.

With the above string, the Digital Clock should say:

TUESDAY 9 JUNE 2009

Note that it might be a good idea to add additional date strings to SystemSettings, but that is another issue.
Comment 1 Aaron J. Seigo 2009-06-10 01:10:24 UTC
this has been discussed previously; the clock date and the system date format are only weekly relatable.
Comment 2 James Richard Tyrer 2009-06-10 01:29:40 UTC
Re: Comment #1

Your statement makes no sense (and that is being nice about it).  If your team designed it wrong, then redesign it!

IAC, the fact that it says:

9 Jun

rather than 

Jun 9

with a US locale is a bug.

IAC, might I suggest that instead of making lame excuses or reclassifying bugs as wish list items that you simply fix them, or say that you are unable to fix it.  Why should users go to the trouble of reporting bugs if you are simply going to (incorrectly) claim that they are not bugs?

It theory you could reclassify all bugs that don't result in crashes as wish list items. E.G. "I wish that X worked correctly", but that is absurd.
Comment 3 Pino Toscano 2009-06-10 02:37:56 UTC

*** This bug has been marked as a duplicate of bug 162368 ***
Comment 4 James Richard Tyrer 2009-06-16 07:45:43 UTC
Re: original report:

Obviously, I meant to say:

With the above string, the Digital Clock should say:

TUESDAY JUNE 9 2009

The fact that the US locale is not correct is clearly a bug.
Comment 5 James Richard Tyrer 2009-07-02 12:51:14 UTC
(In reply to comment #1)
> this has been discussed previously; the clock date and the system date format
> are only weekly relatable.

Please refer to:

https://bugs.kde.org/show_bug.cgi?id=158786#c11
Comment 6 James Richard Tyrer 2009-07-03 08:03:14 UTC
Created attachment 35009 [details]
Screen Shot from experimental code

This is a real screen shot, not a mock up.

For vertical panels (which this is) it appears to me that the day of the week, if shown, should be on the first line and the rest of the date should be on the second.  Horizontal panels will need to be different and/or dependent on the panel size.
Comment 7 James Richard Tyrer 2009-07-24 05:11:58 UTC
Created attachment 35585 [details]
Clock with date formated by KDEGlobal Locale information

This seems to work OK.
Comment 8 Beat Wolf 2009-09-03 14:36:44 UTC
closing as per last comment
Comment 9 James Richard Tyrer 2009-09-03 21:37:04 UTC
(In reply to comment #8)
> closing as per last comment

That screen shot is using my experimental code which has not been committed because it is not completed.
Comment 10 John Layt 2009-10-18 00:36:34 UTC
Lets keep all the date format issues under one bug.  This is being fixed for 4.4, code is currently on reviewboard and will hit trunk in next day or two.

*** This bug has been marked as a duplicate of bug 162368 ***
Comment 11 James Richard Tyrer 2009-10-18 01:17:18 UTC
This bug is not related to bug 162368 since this is actually a bug (NOT a wishlist -- please change this back to a bug) because this is about something which does not work correctly and 162368 is a request for a new feature.
Comment 12 John Layt 2010-02-01 13:08:45 UTC
*** Bug 174334 has been marked as a duplicate of this bug. ***
Comment 13 Marc Payne 2010-12-03 20:50:52 UTC
This issue is still present in 4.6-beta1. I agree that it should be classified as a bug.

Why should the clock applet not conform to the system date format? First off, there is no way at present to change the date format in the clock applet. One can only add or remove seconds, date, year, etc. Second, I would bet that 99.9% of users would expect the system locale settings to apply to the clock.

I'm not ranting, just bumping this. I think it deserves attention. :-)
Comment 14 Teo Mrnjavac 2011-01-04 23:03:29 UTC
SVN commit 1211756 by mrnjavac:

Obey locale KCM settings for date format in the Digital Clock Plasma applet.
BUG:195837
BUG:247277
BUG:162368

 M  +5 -1      CMakeLists.txt  
 M  +61 -37    clock.cpp  
 M  +2 -3      clock.h  
 M  +44 -173   clockConfig.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1211756