Bug 195535 - Kwalletmanager shouldn't pop-up again and again after a connection has been authorized
Summary: Kwalletmanager shouldn't pop-up again and again after a connection has been a...
Status: RESOLVED DUPLICATE of bug 179663
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kpasswdserver (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Michael Leupold
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-07 10:50 UTC by Tamas Baka
Modified: 2012-05-12 15:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
This pops up 30 times if i'm opening 30 files :-P (22.93 KB, image/png)
2009-06-13 15:56 UTC, Tamas Baka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tamas Baka 2009-06-07 10:50:36 UTC
Version:            (using KDE 4.2.4)
Installed from:    Ubuntu Packages

When working (with kate) through ftp and sftp connections it is quite frustrating that kwalletmanager pops up again and again after some time to reauthorize the password for the connection.

Example case: Try opening 30+ files through an sftp connection in kate. It will pop up a password authorization for ALL FILES and after 4 or five the rest will timeout and will not open. I have to open files in groups of 4 or five.

Example 2: I opened a file, worked on it some and press save. It asks for authorizing the passord again... Why? I already authorized when I opened it. As I usually immediately switch to firefox to test the file - the popup pops under FF and I don't even see it...

This is not good it should work in a way that a connection should need authorization only once... at least please make this an option in kwalletmanager.

Sorry for my bad english...

Please comment & please fix this...
Comment 1 Michael Leupold 2009-06-13 11:43:47 UTC
Are you sure it's the wallet reopening and not the default password entry dialog (for entering username and password) ?
Comment 2 Tamas Baka 2009-06-13 15:52:41 UTC
It asks for my data for the specific server and the values are already filled in. My problem is that it asks to confirm each time I'm opening or saving files and this is a really unnecessary and annoying step (after giving my passord to open kwallet)
Comment 3 Tamas Baka 2009-06-13 15:56:49 UTC
Created attachment 34499 [details]
This pops up 30 times if i'm opening 30 files :-P

So, this is bothersome. The first time I click ok, this shouldn't pop up until the next time I turn on my computer. When working on a lot of files through ftp/sftp I have to click on these a lot...
Comment 4 Michael Leupold 2009-06-13 16:15:32 UTC
Ah, I see. The dialog is shown by kpasswdserver so I'm reassigning this bug to it.
Comment 5 Dawit Alemayehu 2012-05-12 15:41:52 UTC
Fixed in KDE 4.7.4

*** This bug has been marked as a duplicate of bug 179663 ***