Bug 195511 - Marble widget crashes when quickly selecting several geotagged items
Summary: Marble widget crashes when quickly selecting several geotagged items
Status: RESOLVED DUPLICATE of bug 182470
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-06 23:56 UTC by Felix Möller
Modified: 2018-08-27 17:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Möller 2009-06-06 23:56:09 UTC
Version:            (using KDE 4.2.3)
Installed from:    Fedora RPMs

I am just trying to start geotagging photos. I tagged a folder of photos with digikam which went really great.

But when the marble widget on the right is displayed and I select several pictures, digikam crashes eventually.
I got the following when running in gdb.

Program received signal SIGSEGV, Segmentation fault.
0x04d154f9 in __dynamic_cast () from /usr/lib/libstdc++.so.6
(gdb) bt                                                    
#0  0x04d154f9 in __dynamic_cast () from /usr/lib/libstdc++.so.6
#1  0x010c3e33 in Marble::MarbleGeometryModel::data (this=0x8e98358, index=@0xbfffccd8, role=183828557) at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleGeometryModel.cpp:161
#2  0x07fb6b0c in Marble::MarbleGeoDataView::renderIndex (this=0x8d5fcb0, index=@0xbfffcd40) at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:91
#3  0x07fb6d1b in Marble::MarbleGeoDataView::paintEvent (this=0x8d5fcb0, event=0x0) at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:77         
#4  0x07fb5fac in Marble::MarbleGeoDataView::setGeoPainter (this=0x8d5fcb0, painter=0xbfffd070)                                                                                       
    at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:42                                                                                         
#5  0x07fb5786 in Marble::MarbleGeoDataPlugin::render (this=0x8d71030, painter=0xbfffd070, viewport=0x8d5e844, renderPos=@0xbfffce54, layer=0x0)                                      
    at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataPlugin.cpp:102
#6  0x010d8c7e in Marble::LayerManager::renderLayers (this=0x8d5f178, painter=0xbfffd070, viewParams=0x8d5e804) at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/LayerManager.cpp:92
#7  0x01097819 in Marble::MarbleModel::paintGlobe (this=0x8d5edf8, painter=0xbfffd070, width=300, height=796, viewParams=0x8d5e804, redrawBackground=true, dirtyRect=@0xbfffd060)
    at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleModel.cpp:700
#8  0x010a0b8e in Marble::MarbleMapPrivate::paintGround (this=0x8d5e7f0, painter=@0xbfffd070, dirtyRect=@0xbfffd060) at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleMap.cpp:290
#9  0x0108ff71 in Marble::MarbleWidget::paintEvent (this=0x8d5e570, evt=0xbfffd4d4) at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleWidget.cpp:844
#10 0x02278252 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#11 0x02222cfc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#12 0x0222a124 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x0134005a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#14 0x064416db in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x02280b65 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from /usr/lib/libQtGui.so.4
#16 0x0243cbe3 in ?? () from /usr/lib/libQtGui.so.4
#17 0x02271746 in QWidgetPrivate::syncBackingStore() () from /usr/lib/libQtGui.so.4
#18 0x02278a33 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#19 0x02675b47 in QMainWindow::event(QEvent*) () from /usr/lib/libQtGui.so.4
#20 0x0141f604 in KMainWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#21 0x0146554f in KXmlGuiWindow::event(QEvent*) () from /usr/lib/libkdeui.so.5
#22 0x02222cfc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#23 0x0222a124 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#24 0x0134005a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#25 0x064416db in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#26 0x02439ec7 in ?? () from /usr/lib/libQtGui.so.4
#27 0x0243d8ec in ?? () from /usr/lib/libQtGui.so.4
#28 0x02273779 in QWidget::repaint(QRegion const&) () from /usr/lib/libQtGui.so.4
#29 0x08260ccb in Digikam::IconView::contentsMouseMoveEvent (this=0x84760c8, e=0xbfffdfc0) at /usr/src/debug/digikam-0.10.0/digikam/iconview.cpp:1296
#30 0x02c1eb08 in Q3ScrollView::viewportMouseMoveEvent(QMouseEvent*) () from /usr/lib/libQt3Support.so.4
#31 0x02c20803 in Q3ScrollView::eventFilter(QObject*, QEvent*) () from /usr/lib/libQt3Support.so.4
#32 0x0644082a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#33 0x02222cda in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#34 0x0222a9fb in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#35 0x0134005a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#36 0x064416db in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#37 0x02229a7e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
#38 0x02298c40 in ?? () from /usr/lib/libQtGui.so.4
#39 0x022980f2 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#40 0x022c3142 in ?? () from /usr/lib/libQtGui.so.4
#41 0x019991e8 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#42 0x0199c7f8 in ?? () from /lib/libglib-2.0.so.0
#43 0x0199c96a in g_main_context_iteration () from /lib/libglib-2.0.so.0
#44 0x0646cbcc in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---
#45 0x022c2825 in ?? () from /usr/lib/libQtGui.so.4
#46 0x0643fc69 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0x064400b2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x0644243f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#49 0x02222b77 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#50 0x082a6023 in main (argc=1, argv=0xbffff1d4) at /usr/src/debug/digikam-0.10.0/digikam/main.cpp:190

please tell me if you need anything more.
Comment 1 Dario Andres 2009-06-07 00:09:31 UTC
Thanks

*** This bug has been marked as a duplicate of bug 182470 ***