Bug 195450 - Network link from dolphin's places panel always asks for password twice
Summary: Network link from dolphin's places panel always asks for password twice
Status: RESOLVED FIXED
Alias: None
Product: kio
Classification: Unclassified
Component: sftp (show other bugs)
Version: 4.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
: 197347 202276 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-06-06 13:40 UTC by Tanja Schulte
Modified: 2011-05-27 23:37 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.0


Attachments
screenshot: 3 dialogs (75.13 KB, image/jpeg)
2009-08-02 20:17 UTC, Tanja Schulte
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tanja Schulte 2009-06-06 13:40:36 UTC
Version:            (using KDE 4.2.4)
OS:                Linux
Installed from:    Ubuntu Packages

I am using dolphin veresion 1.2.80 with KDE 4.3 Beta 1 (sorry, couldn't choose it from bug reports drop down list and choosing Beta2 gives only non-valid version). When I open a connection to another linux computer in the network via the network icon in dolphin's places panel I always get the dialog twice to enter username and password. They open right on top of each other, not after I have confirmed the first dialog.
Comment 1 Peter Penz 2009-06-06 15:35:57 UTC
Thanks for the report, but I cannot reproduce this issue. Does the URL contain a network:/ prefix?
Comment 2 Tanja Schulte 2009-06-07 17:39:53 UTC
the prefix is remote:/ when I use the network button in dolphin's places panel. There I added a new network folder and chose secure shell (ssh) and ticked the "create icon for this network folder" option. When I then click on the new icon the addressbar changes from remote:/ to sftp://username@IP and the two dialogs pop up to enter the password.
Comment 3 FiNeX 2009-08-02 18:37:41 UTC
@Peter: it looks like accessing to ftp/sftp sometimes displays two password dialogs, is knetattach which manage the ftp login or kio/ftp?
Comment 4 FiNeX 2009-08-02 18:37:49 UTC
*** Bug 197347 has been marked as a duplicate of this bug. ***
Comment 5 FiNeX 2009-08-02 18:37:56 UTC
*** Bug 202276 has been marked as a duplicate of this bug. ***
Comment 6 Tanja Schulte 2009-08-02 19:39:18 UTC
Now with RC3 I even get more password dialogs... Does "it" (whatever it in this case is) need a password confirmation for every subdirectory or file in the remote folder?
Comment 7 Tanja Schulte 2009-08-02 20:07:40 UTC
And after I have answered all dialogs with the password I get a "Unknown error. unexpected SFTP-error:8. Please enter a password"
Comment 8 Tanja Schulte 2009-08-02 20:17:09 UTC
Created attachment 35797 [details]
screenshot: 3 dialogs

Just to prove - three dialogs in this case. But I also had up to 6 or seven.
Comment 9 Peter Penz 2009-08-02 21:34:36 UTC
@FiNeX: Judging from other bug-reports this seems to be a kio issue and not a knetattach thing... I'd propose to set the subsystem to kio, although I'm not 100 % sure.
Comment 10 FiNeX 2009-08-03 00:18:32 UTC
Knetattach is unassigned, at least someone could see this report if it is on KIO :-) :-) :-)
Comment 11 Dawit Alemayehu 2011-04-28 21:29:52 UTC
I think you meant to assign to the sftp kioslave. Not the ftp one...
Comment 12 Dawit Alemayehu 2011-05-27 23:37:53 UTC
Git commit e1d42cb7ff079f05a6358f474a1f0634c1d06b97 by Dawit Alemayehu.
Committed on 11/05/2011 at 06:03.
Pushed by adawit into branch 'master'.

- Properly update the client application when the user changes the 'username'
  that was entered as part of the url in the password dialog.
- Do not prompt for password when there is cached password in the wallet.
- Show the "Remember password" checkbox on login failure retries.
- Avoid crash if slave_status is called after the mSftp was set to NULL.

BUG: 165875
BUG: 195450
BUG: 255991
FIXED-IN: 4.7.0
REVIEW: 101332

M  +102  -94   kioslave/sftp/kio_sftp.cpp     
M  +6    -1    kioslave/sftp/kio_sftp.h     

http://commits.kde.org/kde-runtime/e1d42cb7ff079f05a6358f474a1f0634c1d06b97