Bug 195387 - konqueror crashes when closing when google suggest is still active
Summary: konqueror crashes when closing when google suggest is still active
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-06 00:09 UTC by Oliver Putz
Modified: 2011-06-26 17:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Valgrind log for bug195387 (13.11 KB, text/plain)
2009-06-07 13:46 UTC, Oliver Putz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Putz 2009-06-06 00:09:03 UTC
Version:           4.2.3 (KDE 4.2.3) (using 4.2.3 (KDE 4.2.3), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.28-gentoo-r6

Steps to reproduce:

1) Open konqueror
2) Go to google.de
3) Start typing in some expression
4) Wait until the suggested search terms appear
5) Close konqueror via CTRL+Q
6) See konqueror crash with the backtrace below.

I think I've seen the KHTMLGlobal::finalCheck thing already somewhere, but a quick search for this backtrace only resulted in reports that were closed back in 2008, so I open a new report...

Backtrace:
#0  0x00007f33bbe9f235 in raise () from /lib/libc.so.6
No symbol table info available.
#1  0x00007f33bbea0753 in abort () from /lib/libc.so.6
No symbol table info available.
#2  0x00007f33bbe980e9 in __assert_fail () from /lib/libc.so.6
No symbol table info available.
#3  0x00007f33b39dce31 in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/khtml/khtml_global.cpp:258
        __PRETTY_FUNCTION__ = "static void KHTMLGlobal::finalCheck()"
#4  0x00007f33b036c878 in ~KHTMLFactory (this=0x131b770) at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/khtml/khtml_factory.cpp:35
No locals.
warning: (Internal error: pc 0x7f33bef45be8 in read in psymtab, but not in symtab.)

warning: (Internal error: pc 0x7f33bef45be8 in read in psymtab, but not in symtab.)

#5  0x00007f33bef45be9 in ~FactoryHash (this=0xcb85b0) at /usr/include/qt4/QtCore/qalgorithms.h:352
warning: (Internal error: pc 0x7f33bef45be8 in read in psymtab, but not in symtab.)

No locals.
#6  0x00007f33bef4515a in destroy () at /var/tmp/portage/kde-base/kdelibs-4.2.3/work/kdelibs-4.2.3/kdecore/util/klibrary.cpp:97
        x = (FactoryHash *) 0xcb85b0
#7  0x00007f33bbea1ddd in exit () from /lib/libc.so.6
No symbol table info available.
#8  0x00007f33bbe8b48d in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#9  0x00000000004008f9 in _start ()
No symbol table info available.
Comment 1 Oliver Putz 2009-06-07 13:46:25 UTC
Created attachment 34340 [details]
Valgrind log for bug195387

In case its helpful: A Valgrind log for this crash using KDE-4.2.4
Comment 2 Dario Andres 2009-06-21 21:59:50 UTC
This looks related to bug 151453 or bug 162474
Thanks
Comment 3 Dawit Alemayehu 2011-06-26 17:37:15 UTC

*** This bug has been marked as a duplicate of bug 151453 ***