Bug 195351 - utf8 support broken on filenames in zips?
Summary: utf8 support broken on filenames in zips?
Status: RESOLVED DUPLICATE of bug 187201
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-05 18:08 UTC by Andrey Zakharov
Modified: 2009-06-06 02:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
broken cyryllic in utf8 filenames (39.45 KB, image/png)
2009-06-05 18:13 UTC, Andrey Zakharov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Zakharov 2009-06-05 18:08:55 UTC
Version:           Версия 2.12 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

Does UTF8 in filename works fine for you?

Reproduce:
 Just open any zip, with some stuff

Expected:
 Содержание ПЗ_инженеры_5.doc
See:
 evidence, attach
Comment 1 Andrey Zakharov 2009-06-05 18:13:57 UTC
Created attachment 34300 [details]
broken cyryllic in utf8 filenames

but console's unzip:
$ unzip /home/vaulter/Desktop/Download/2___5.zip
Archive:  /home/vaulter/Desktop/Download/2___5.zip
  inflating: Содержание ПЗ_инженеры_5.doc
Comment 2 Raphael Kubo da Costa 2009-06-05 19:47:03 UTC
This is very likely to be bug 187201. Please take a look at comment 17 specially. Is this the same issue?
Comment 3 Harald Hvaal 2009-06-06 02:25:20 UTC
Yes, duplicate. Also, libzip plugin is deprecated in 4.3, and the new plugin does support unicode filenames.

*** This bug has been marked as a duplicate of bug 187201 ***