Bug 195176 - Akregator crash when I start my computer
Summary: Akregator crash when I start my computer
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: klocale (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Chusslove Illich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-04 08:51 UTC by Zayed Al-Saidi
Modified: 2009-06-04 10:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zayed Al-Saidi 2009-06-04 08:51:17 UTC
Version:            (using KDE 4.2.3)
Installed from:    SuSE RPMs

When I started kde, Akregator was working background (just icon in the system tray).  Then it crashed I do not know why because it is never happen before. I use KDE in RTL mode (Arabic version).

Backtrace: 

تطبيق: اكريغاتور قارىء RSS (akregator), signal SIGSEGV
[?1034h[Thread debugging using libthread_db enabled]
[Current thread is 1 (Thread 0xb45c1700 (LWP 3815))]

Thread 2 (Thread 0xb09ffb90 (LWP 3906)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb5c5fe93 in ?? () from /lib/libc.so.6
#2  0xb5bf34e1 in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb45c1700 (LWP 3815)):
[KCrash Handler]
#6  0xb5bf0755 in ?? () from /lib/libc.so.6
#7  0xb5bf288c in malloc () from /lib/libc.so.6
#8  0xb6953ced in qMalloc(unsigned int) () from /usr/lib/libQtCore.so.4
#9  0xb699f3ed in QString::fromLatin1_helper(char const*, int) () from /usr/lib/libQtCore.so.4
#10 0xb69aa64c in QString::fromAscii_helper(char const*, int) () from /usr/lib/libQtCore.so.4
#11 0xb6d0da3f in KCatalog::language (this=0x80a9ec8) at /usr/include/QtCore/qstring.h:388
#12 0xb6d22170 in KLocalePrivate::translate_priv (this=0x80d07b8, msgctxt=0x83fd068 "@title job", msgid=0x82347b8 "Transferring", msgid_plural=0x0, n=0, language=0xbff373a0, translation=0xbff3739c)
    at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocale.cpp:772
#13 0xb6d226c0 in KLocale::translateRaw (this=0x80aa928, ctxt=0x83fd068 "@title job", msg=0x82347b8 "Transferring", lang=0xbff373a0, trans=0xbff3739c)
    at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocale.cpp:789
#14 0xb6d2c665 in KLocalizedStringPrivate::toString (this=0x824e1a0, locale=0x80aa928) at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocalizedstring.cpp:243
#15 0xb6d2d004 in KLocalizedString::toString (this=0xbff37428) at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocalizedstring.cpp:205
#16 0xb72ad036 in KIO::JobPrivate::emitTransferring (job=0x80f2998, url=@0x840aee0) at /usr/src/debug/kdelibs-4.2.3/kdecore/localization/klocalizedstring.h:735
#17 0xb72b67cc in KIO::TransferJobPrivate::start (this=0x840ae90, slave=0x82b5420) at /usr/src/debug/kdelibs-4.2.3/kio/kio/job.cpp:1148
#18 0xb73502de in KIO::SchedulerPrivate::startJobDirect (this=0x8076028) at /usr/src/debug/kdelibs-4.2.3/kio/kio/scheduler.cpp:60
#19 0xb7350410 in KIO::SchedulerPrivate::startStep (this=0x8076028) at /usr/src/debug/kdelibs-4.2.3/kio/kio/scheduler.cpp:433
#20 0xb7350676 in KIO::Scheduler::qt_metacall (this=0x8225460, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xbff375d8) at /usr/src/debug/kdelibs-4.2.3/build/kio/scheduler.moc:101
#21 0xb6a63788 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
#22 0xb6a64412 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#23 0xb6a9ffe7 in QTimer::timeout() () from /usr/lib/libQtCore.so.4
#24 0xb6a69c0e in QTimer::timerEvent(QTimerEvent*) () from /usr/lib/libQtCore.so.4
#25 0xb6a5e72f in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#26 0xb5f2a8ec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#27 0xb5f32bde in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#28 0xb700c0cd in KApplication::notify (this=0xbff37d20, receiver=0x807602c, event=0xbff37a80) at /usr/src/debug/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#29 0xb6a4e16b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#30 0xb6a7d5f6 in ?? () from /usr/lib/libQtCore.so.4
#31 0xb6a79980 in ?? () from /usr/lib/libQtCore.so.4
#32 0xb4bbf9c8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0xb4bc3083 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0xb4bc3241 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0xb6a798d8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#36 0xb5fcaa55 in ?? () from /usr/lib/libQtGui.so.4
#37 0xb6a4c78a in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#38 0xb6a4cbd2 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0xb6a4f079 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#40 0xb5f2a767 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#41 0x0804ed51 in main (argc=2, argv=0x0) at /usr/src/debug/kdepim-4.2.3/akregator/src/main.cpp:115
Comment 1 Chusslove Illich 2009-06-04 10:02:04 UTC
Should be fixed in 4.2.4 and following releases.

*** This bug has been marked as a duplicate of bug 191122 ***