Bug 195107 - KDE printing ignores default duplex option
Summary: KDE printing ignores default duplex option
Status: RESOLVED DUPLICATE of bug 180051
Alias: None
Product: kdelibs
Classification: Unclassified
Component: print-dialog (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-03 15:52 UTC by jarauh
Modified: 2009-10-28 16:05 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jarauh 2009-06-03 15:52:24 UTC
Version:            (using KDE 4.2.3)
Compiler:          gcc-Version 4.3.3 (Gentoo 4.3.3 p1.0, pie-10.1.5) 
OS:                Linux
Installed from:    Gentoo Packages

When printing from KDE applications (e.g. Okular) the default duplexing option from CUPS is ignored.

Usually the default duplexing option for a specific printer is recorded in the file
       /etc/cups/ppd/<printer>.ppd
in a line such as
       *DefaultDuplex: DuplexNoTumble

Apparently, KDE ignores this line (while GNOME, for example, respects it).
Comment 1 Pino Toscano 2009-06-03 16:03:35 UTC
Is the problem only Okular?
Comment 2 jarauh 2009-06-03 16:34:38 UTC
Thanks for the fast reply.

I have the same problem with Konqueror.

Another similar problem: The printing system also ignores my default printer: When I change the default printer using CUPS, okular and konqueror ignore this.
Comment 3 Pino Toscano 2009-06-03 16:46:08 UTC
There is a separate report for Okular (which is a slightly "different" case), but if the same problem is for any KDE application, then there's something non-Okular-specific.
Comment 4 Stefan Götz 2009-06-17 13:08:36 UTC
I'm seeing the same behavior on KDE 4.2.2 installed from Ubuntu 9.04 desktop i386 packages. The problem is independent of the application (tested with okular, kate, konqueror, and kmail).
Comment 5 guefz 2009-09-21 15:01:14 UTC
I'm using KDE 4.3.1 on Debian Sid. My experience is that the print dialog of KDE-Applications ignores the setting of the duplex option. Even with "no duplex" marked the job is done in duplex mode. Print dialogs of none-KDE software such as Openoffice and evince doesn't show this behavior, so the printer installation seems ok.
Comment 6 guefz 2009-10-22 23:46:23 UTC
The problem from comment #5 is still present in KDE 4.3.2. Just tested with Okular, printing is always in duplex mode, even when explicitly set on simplex. Non-KDE software still works as expected.
Comment 7 Brice Hunt 2009-10-27 23:40:56 UTC
Experiencing the same behavior as #5 and #6.
Comment 8 jarauh 2009-10-28 16:05:08 UTC
I think this bug is a duplicate of
Bug 180051.  So please vote for that bug!

*** This bug has been marked as a duplicate of bug 180051 ***