Bug 195063 - konqueror crashed on startup
Summary: konqueror crashed on startup
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.2.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-03 06:43 UTC by Klaus Layer
Modified: 2009-06-03 10:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Klaus Layer 2009-06-03 06:43:35 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

Konqueror crashed on startup unexpected. I can't recreate this.

Anwendung: Konqueror (konqueror), Signal SIGSEGV
[Current thread is 0 (LWP 5960)]

Thread 3 (Thread 0xb21a3b90 (LWP 5991)):
[KCrash Handler]
#6  0xb655ea98 in ?? () from /lib/tls/i686/cmov/libc.so.6
#7  0xb65609c5 in malloc () from /lib/tls/i686/cmov/libc.so.6
#8  0xb72f30bd in qMalloc (size=24) at global/qmalloc.cpp:55
#9  0xb733e4bd in QString::fromLatin1_helper (str=0xa183ca0 "de", size=-1) at tools/qstring.cpp:3452
#10 0xb734976c in QString::fromAscii_helper (str=0xa183ca0 "de", size=-1317011440) at tools/qstring.cpp:3486
#11 0xb76b441f in KCatalog::language (this=0xa1850c8) at /usr/include/qt4/QtCore/qstring.h:416
#12 0xb76c9240 in KLocalePrivate::translate_priv (this=0x9b1ba80, msgctxt=0x0, msgid=0xb7c53bce "Host not found", msgid_plural=0x0, n=0, language=0xb21a2bd0, translation=0xb21a2bd4)
    at /build/buildd/kde4libs-4.2.2/kdecore/localization/klocale.cpp:756
#13 0xb76c9c15 in KLocale::translateQt (this=0x9b1b250, context=0xb7c5be8b "QHostInfoAgent", sourceText=0xb7c53bce "Host not found", comment=0x0)
    at /build/buildd/kde4libs-4.2.2/kdecore/localization/klocale.cpp:856
#14 0xb7995e60 in KDETranslator::translate (this=0x9b08018, context=0xb7c5be8b "QHostInfoAgent", sourceText=0xb7c53bce "Host not found", message=0x0)
    at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:462
#15 0xb740a3d1 in QTranslator::translate (this=0xb1800010, context=0xb7c5be8b "QHostInfoAgent", sourceText=0xb7c53bce "Host not found", disambiguation=0x0, n=-1) at kernel/qtranslator.cpp:804
#16 0xb73f02ea in QCoreApplication::translate (context=0xb7c5be8b "QHostInfoAgent", sourceText=0xb7c53bce "Host not found", disambiguation=0x0, encoding=QCoreApplication::CodecForTr, n=-1)
    at kernel/qcoreapplication.cpp:1633
#17 0xb73f0736 in QCoreApplication::translate (context=0xb7c5be8b "QHostInfoAgent", sourceText=0xb7c53bce "Host not found", disambiguation=0x0, encoding=QCoreApplication::CodecForTr)
    at kernel/qcoreapplication.cpp:1548
#18 0xb73f3752 in QMetaObject::tr (this=0xb7ca0878, s=0xb7c53bce "Host not found", c=0x0) at kernel/qmetaobject.cpp:314
#19 0xb7c103b6 in QHostInfoAgent::fromName (hostName=@0xb21a3244) at kernel/qhostinfo_p.h:107
#20 0xb7c06263 in QHostInfo::fromName (name=@0xa17c908) at kernel/qhostinfo.cpp:230
#21 0xb7e2ac4d in QtConcurrent::StoredFunctorCall1<QHostInfo, QHostInfo (*)(QString const&), QString>::runFunctor (this=0xa17c8f0) at /usr/include/qt4/QtCore/qtconcurrentstoredfunctioncall.h:274
#22 0xb7e2bb61 in QtConcurrent::RunFunctionTask<QHostInfo>::run (this=0xa17c8f0) at /usr/include/qt4/QtCore/qtconcurrentrunbase.h:103
#23 0xb72eedd4 in QThreadPoolThread::run (this=0xa198dd8) at concurrent/qthreadpool.cpp:106
#24 0xb72f896e in QThreadPrivate::start (arg=0xa198dd8) at thread/qthread_unix.cpp:189
#25 0xb63954ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#26 0xb65d149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb17ffb90 (LWP 5992)):
#0  0xb80c9430 in __kernel_vsyscall ()
#1  0xb65e0643 in ?? () from /lib/tls/i686/cmov/libc.so.6
#2  0xb6561f5d in ?? () from /lib/tls/i686/cmov/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 1 (Thread 0xb5f5bb50 (LWP 5960)):
#0  0xb80c9430 in __kernel_vsyscall ()
#1  0xb63990e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb65e02ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb72f99b2 in QWaitCondition::wait (this=0x9b1b7c8, mutex=0x9b1b7b4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb72eda4a in QThreadPoolPrivate::waitForDone (this=0x9b1b770) at concurrent/qthreadpool.cpp:293
#5  0xb72edf83 in ~QThreadPool (this=0xa117f90) at concurrent/qthreadpool.cpp:424
#6  0xb72ef20a in ~QGlobalStaticDeleter (this=0xb74e1b78) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1625
#7  0xb651bbb9 in exit () from /lib/tls/i686/cmov/libc.so.6
#8  0xb6a5921b in qt_xio_errhandler () at kernel/qapplication_x11.cpp:707
#9  0xb79902fa in KApplication::xioErrhandler (this=0xbfae4a08, dpy=0x9a71ea8) at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:413
#10 0xb7990336 in kde_xio_errhandler (dpy=0x9a71ea8) at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:130
#11 0xb67dbf22 in _XIOError () from /usr/lib/libX11.so.6
#12 0xb67e3743 in ?? () from /usr/lib/libX11.so.6
#13 0xb67e40e5 in _XEventsQueued () from /usr/lib/libX11.so.6
#14 0xb67cc7af in XEventsQueued () from /usr/lib/libX11.so.6
#15 0xb6a9652d in x11EventSourceCheck (s=0x9a6d368) at kernel/qguieventdispatcher_glib.cpp:87
#16 0xb62c76f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#17 0xb62c7fdd in ?? () from /usr/lib/libglib-2.0.so.0
#18 0xb62c8268 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#19 0xb7418438 in QEventDispatcherGlib::processEvents (this=0x9a577c0, flags={i = -1079097544}) at kernel/qeventdispatcher_glib.cpp:323
#20 0xb6a96365 in QGuiEventDispatcherGlib::processEvents (this=0x9a577c0, flags={i = -1079097496}) at kernel/qguieventdispatcher_glib.cpp:202
#21 0xb73eb06a in QEventLoop::processEvents (this=0xbfae47e0, flags={i = -1079097432}) at kernel/qeventloop.cpp:149
#22 0xb73eb4aa in QEventLoop::exec (this=0xbfae47e0, flags={i = -1079097368}) at kernel/qeventloop.cpp:200
#23 0xb73ed959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#24 0xb69f4d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#25 0xb809800f in kdemain (argc=3, argv=0xbfae4d84) at /build/buildd/kdebase-4.2.2/apps/konqueror/src/konqmain.cpp:257
#26 0x080486f2 in main (argc=) at /build/buildd/kdebase-4.2.2/obj-i486-linux-gnu/apps/konqueror/src/konqueror_dummy.cpp:3
Comment 1 Pino Toscano 2009-06-03 10:16:01 UTC

*** This bug has been marked as a duplicate of bug 191122 ***