Bug 195028 - KHelpCenter crashed when starting
Summary: KHelpCenter crashed when starting
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: khelpcenter
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Cornelius Schumacher
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-02 22:07 UTC by Zdeněk Zikán
Modified: 2009-06-02 23:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zdeněk Zikán 2009-06-02 22:07:12 UTC
Application that crashed: khelpcenter
Version of the application: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
KDE Version: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
Qt Version: 4.5.1
Operating System: Linux 2.6.28-12-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
I started khelpcenter (from network monitoring widget settings) and it crashed before showing the window itself. It doesn't happen every time, so I don't know how to reproduce.

 -- Backtrace:
Application: KDE hjelpesenter (khelpcenter), signal: Segmentation fault
[KCrash Handler]
#6  0xb5ae407a in strcmp () from /lib/tls/i686/cmov/libc.so.6
#7  0xb5a9284f in ?? () from /lib/tls/i686/cmov/libc.so.6
#8  0xb5a93893 in ?? () from /lib/tls/i686/cmov/libc.so.6
#9  0xb5a92433 in dcgettext () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6ad2f4b in dcpgettext_expr (domain=0x8581ef8 "kio4", msgctxt=0x880e6e0 "@action:intoolbar Text label of toolbar button", msgid=0x8563bb0 "%1", category=5)
    at /build/buildd/kde4libs-4.2.85/kdecore/localization/gettext.h:208
#11 0xb6ad3c17 in KCatalog::translateStrict (this=0x856bc90, msgctxt=0x880e6e0 "@action:intoolbar Text label of toolbar button", msgid=0x8563bb0 "%1")
    at /build/buildd/kde4libs-4.2.85/kdecore/localization/kcatalog.cpp:243
#12 0xb6ae9efd in KLocalePrivate::translate_priv (this=0x855a8d8, msgctxt=0x880e6e0 "@action:intoolbar Text label of toolbar button", msgid=0x8563bb0 "%1", msgid_plural=0x0, n=0, 
    language=0xbfd2cd80, translation=0xbfd2cd7c) at /build/buildd/kde4libs-4.2.85/kdecore/localization/klocale.cpp:828
#13 0xb6aeac80 in KLocale::translateRaw (this=0x8567708, ctxt=0x880e6e0 "@action:intoolbar Text label of toolbar button", msg=0x8563bb0 "%1", lang=0xbfd2cd80, trans=0xbfd2cd7c)
    at /build/buildd/kde4libs-4.2.85/kdecore/localization/klocale.cpp:852
#14 0xb6af65df in KLocalizedStringPrivate::toString (this=0x8805658, locale=0x8567708) at /build/buildd/kde4libs-4.2.85/kdecore/localization/klocalizedstring.cpp:243
#15 0xb6af71c4 in KLocalizedString::toString (this=0xbfd2ce00) at /build/buildd/kde4libs-4.2.85/kdecore/localization/klocalizedstring.cpp:205
#16 0xb6ed3813 in i18nc<QString> (ctxt=0xb6f4e428 "@action:intoolbar Text label of toolbar button", text=0xb6f25a8d "%1", a1=@0xbfd2cf50)
    at /build/buildd/kde4libs-4.2.85/kdecore/localization/klocalizedstring.h:780
#17 0xb6ecb739 in KToolBar::eventFilter (this=0x87ee5d0, watched=0x8504d28, event=0xbfd2d300) at /build/buildd/kde4libs-4.2.85/kdeui/widgets/ktoolbar.cpp:1281
#18 0xb68069ca in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x84fa220, receiver=0x8504d28, event=0xbfd2d300) at kernel/qcoreapplication.cpp:726
#19 0xb5e15baa in QApplicationPrivate::notify_helper (this=0x84fa220, receiver=0x8504d28, e=0xbfd2d300) at kernel/qapplication.cpp:4053
#20 0xb5e1dfc2 in QApplication::notify (this=0xbfd2e548, receiver=0x8504d28, e=0xbfd2d300) at kernel/qapplication.cpp:4022
#21 0xb6db2c9d in KApplication::notify (this=0xbfd2e548, receiver=0x8504d28, event=0xbfd2d300) at /build/buildd/kde4libs-4.2.85/kdeui/kernel/kapplication.cpp:307
#22 0xb68077ab in QCoreApplication::notifyInternal (this=0xbfd2e548, receiver=0x8504d28, event=0xbfd2d300) at kernel/qcoreapplication.cpp:610
#23 0xb5e20d7e in QCoreApplication::sendEvent (receiver=0x8504d28, event=0xba4a7a) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#24 0xb5e6df50 in QWidgetPrivate::setEnabled_helper (this=0x8830d38, enable=false) at kernel/qwidget.cpp:2958
#25 0xb5e6e061 in QWidget::setEnabled (this=0x8504d28, enable=64) at kernel/qwidget.cpp:2914
#26 0xb62e57bb in QToolButton::setDefaultAction (this=0x8504d28, action=0x87fa9b8) at widgets/qtoolbutton.cpp:1107
#27 0xb62e5969 in QToolButton::actionEvent (this=0x8504d28, event=0xbfd2d828) at widgets/qtoolbutton.cpp:557
#28 0xb5e6cdf5 in QWidget::event (this=0x8504d28, event=0xbfd2d828) at kernel/qwidget.cpp:7878
#29 0xb61fa81e in QAbstractButton::event (this=0x8504d28, e=0xbfd2d828) at widgets/qabstractbutton.cpp:1077
#30 0xb62e6c3a in QToolButton::event (this=0x8504d28, event=0xbfd2d828) at widgets/qtoolbutton.cpp:1151
#31 0xb5e15bcc in QApplicationPrivate::notify_helper (this=0x84fa220, receiver=0x8504d28, e=0xbfd2d828) at kernel/qapplication.cpp:4057
#32 0xb5e1dfc2 in QApplication::notify (this=0xbfd2e548, receiver=0x8504d28, e=0xbfd2d828) at kernel/qapplication.cpp:4022
#33 0xb6db2c9d in KApplication::notify (this=0xbfd2e548, receiver=0x8504d28, event=0xbfd2d828) at /build/buildd/kde4libs-4.2.85/kdeui/kernel/kapplication.cpp:307
#34 0xb68077ab in QCoreApplication::notifyInternal (this=0xbfd2e548, receiver=0x8504d28, event=0xbfd2d828) at kernel/qcoreapplication.cpp:610
#35 0xb5e10768 in QActionPrivate::sendDataChanged (this=0x87fab10) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#36 0xb7ec5bd7 in ?? () from /usr/lib/libkdeinit4_khelpcenter.so
#37 0xb7ec811a in ?? () from /usr/lib/libkdeinit4_khelpcenter.so
#38 0xb7ed0de6 in ?? () from /usr/lib/libkdeinit4_khelpcenter.so
#39 0xb6dba546 in KUniqueApplicationAdaptor::newInstance (this=0x856de78, asn_id=@0x8503168, args=@0x85302a0) at /build/buildd/kde4libs-4.2.85/kdeui/kernel/kuniqueapplication.cpp:454
#40 0xb6dba5ee in KUniqueApplicationAdaptor::qt_metacall (this=0x856de78, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd2dc18)
    at /build/buildd/kde4libs-4.2.85/obj-i486-linux-gnu/kdeui/kuniqueapplication_p.moc:75
#41 0xb691fe2a in QDBusConnectionPrivate::deliverCall (this=0x8500eb8, object=0x856de78, msg=@0x8503370, metaTypes=@0xbfd2dcc8, slotIdx=4) at qdbusintegrator.cpp:891
#42 0xb6921042 in QDBusConnectionPrivate::activateCall (this=0x8500eb8, object=0x856de78, flags=337, msg=@0x8503370) at qdbusintegrator.cpp:796
#43 0xb69215b1 in QDBusConnectionPrivate::activateObject (this=0x8500eb8, node=@0x850335c, msg=@0x8503370, pathStartPos=16) at qdbusintegrator.cpp:1375
#44 0xb6921aaa in QDBusActivateObjectEvent::placeMetaCall (this=0x8503330) at qdbusintegrator.cpp:1469
#45 0xb6818150 in QObject::event (this=0xbfd2e548, e=0x8503330) at kernel/qobject.cpp:1118
#46 0xb680714b in QCoreApplication::event (this=0xbfd2e548, e=0x8503330) at kernel/qcoreapplication.cpp:1434
#47 0xb5e1b509 in QApplication::event (this=0xbfd2e548, e=0x8503330) at kernel/qapplication.cpp:2318
#48 0xb5e15bcc in QApplicationPrivate::notify_helper (this=0x84fa220, receiver=0xbfd2e548, e=0x8503330) at kernel/qapplication.cpp:4057
#49 0xb5e1dede in QApplication::notify (this=0xbfd2e548, receiver=0xbfd2e548, e=0x8503330) at kernel/qapplication.cpp:3604
#50 0xb6db2c9d in KApplication::notify (this=0xbfd2e548, receiver=0xbfd2e548, event=0x8503330) at /build/buildd/kde4libs-4.2.85/kdeui/kernel/kapplication.cpp:307
#51 0xb68077ab in QCoreApplication::notifyInternal (this=0xbfd2e548, receiver=0xbfd2e548, event=0x8503330) at kernel/qcoreapplication.cpp:610
#52 0xb6808405 in QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x84dc560) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#53 0xb68085fd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1140
#54 0xb683358f in postEventSourceDispatch (s=0x84ff698) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#55 0xb5531b88 in IA__g_main_context_dispatch (context=0x84ff610) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#56 0xb55350eb in g_main_context_iterate (context=0x84ff610, block=1, dispatch=1, self=0x84fa1c8) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#57 0xb5535268 in IA__g_main_context_iteration (context=0x84ff610, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#58 0xb68331d8 in QEventDispatcherGlib::processEvents (this=0x84fd600, flags={i = -1076698120}) at kernel/qeventdispatcher_glib.cpp:324
#59 0xb5eb7765 in QGuiEventDispatcherGlib::processEvents (this=0x84fd600, flags={i = -1076698072}) at kernel/qguieventdispatcher_glib.cpp:202
#60 0xb6805dda in QEventLoop::processEvents (this=0xbfd2e4a0, flags={i = -1076698008}) at kernel/qeventloop.cpp:149
#61 0xb680621a in QEventLoop::exec (this=0xbfd2e4a0, flags={i = -1076697944}) at kernel/qeventloop.cpp:200
#62 0xb68086c9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#63 0xb5e15a47 in QApplication::exec () at kernel/qapplication.cpp:3526
#64 0xb7ed15e7 in kdemain () from /usr/lib/libkdeinit4_khelpcenter.so
#65 0x080486b2 in _start ()
Comment 1 Jonathan Thomas 2009-06-02 23:28:35 UTC
This has been fixed for beta2. :)

*** This bug has been marked as a duplicate of bug 191122 ***