Bug 194981 - case-sensitive filesystems - folders switching order
Summary: case-sensitive filesystems - folders switching order
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-02 12:56 UTC by Martin Zbořil
Modified: 2010-10-09 21:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Zbořil 2009-06-02 12:56:48 UTC
Version:           1.2.80 (using 4.2.88 (KDE 4.2.88 (KDE 4.3 >= 20090527)) "release 127", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.21-0.1-default

I have an nfs share on my server connected with my workstation, this share contains 'images' & 'Images' directories and for historic reason I cannot change them, those two are switching order every time cursor is over one of them.
Comment 1 Rufus 2009-12-17 22:07:09 UTC
You don't need nfs nor folders. Steps to reproduce:

1. Use krita to create some_file.png
2. "convert -monochrome some_file.png some_file.PNG"
3. activate thumbnails in dolphin
4. hover mouse over some_file.png

What happens is:
-some_file.png's thumbnail gets the bluish shadow, its metadata gets shown in the F11 bar
-roughly a second afterwards some_file.png's thumbnail (including the shadow and the string "some_file.png") moves to where some_file.PNG used to be and vice-cersa. So I end up with some_file.PNG being underneath my cursor, but without the shadow. The F11 bar still shows some_file.png's metadata
-when I move the mouse cursor off some_file.PNG the thumbnails and strings swap back. No file carries the bluish shadow any more. The F11 bar shows some_file.png's metadata as always.
I don't know what it is about krita. I guess any file invoking a thumbnail would work - "bla.tst" and "bla.TST" don't (each file carrying some random ascii characters)
Comment 2 Rufus 2009-12-18 11:44:38 UTC
By the "work" in "any file invoking a thumbnail would work" I mean "would exhibit the bug".
Comment 3 Peter Penz 2010-10-09 21:25:38 UTC
Thanks for the report, this has been fixed since KDE SC 4.5