Bug 194959 - use keyboard to assign tags
Summary: use keyboard to assign tags
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Tags-Engine (show other bugs)
Version: 1.0.0
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-02 10:36 UTC by Mikolaj Machowski
Modified: 2022-01-22 17:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2009-06-02 10:36:00 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

To speed up review of pictures it would be good to assign tags completely by keyboard. At the moment you cannot do this - there is no KAction to call "New Tags..." dialog. Also when using this dialog to add existing tag user is welcomed with Error about existing tag.

It should be possible to disable this dialog if user knows what (s)he wants to do.
Comment 1 caulier.gilles 2009-06-02 11:42:10 UTC
>To speed up review of pictures it would be good to assign tags completely by
>keyboard. 

This point is already seen in https://bugs.kde.org/show_bug.cgi?id=114465

>there is no KAction to call "New Tags..." dialog.

This can be a simple problem to add shortcut to Tags/New... menu entry. Andi ?

>Also when using this dialog to add existing tag user is
>welcomed with Error about existing tag.

We need more info here.

>It should be possible to disable this dialog if user knows what (s)he wants to
>do.

You want mean accordingly with the user context, for example when focus is in icon view and not in tree folder view ?

Gilles Caulier
Comment 2 Andi Clemens 2009-06-02 11:53:15 UTC
>>there is no KAction to call "New Tags..." dialog.

>This can be a simple problem to add shortcut to Tags/New... menu entry. Andi ?


I could swear we had a shortcut before? But now it is gone. I would simply use CTRL+T for that, if it is not taking already?

Andi
Comment 3 Andi Clemens 2009-06-02 12:33:10 UTC
Ok CTRL+T is a bad idea :-) It is used in more places.
In general the Tag->New... Dialog is not very useful to add existing tags, as Mik already said.
In another bugreport (#bug 114465) there were some good suggestions, like having a dialog that behaves like KMails filtering (I like this idea). You will have a popup dialog with all tags in it (like we have on the right sidebar now). By simply typing (no need for an input widget like lineedit or something like that) the list gets filtered. you can then select the tag, hit Enter and it is assigned (or removed if it was assigned before). ESC will close this dialog again, and some other shortcut (maybe CTRL+BACKSPACE) will reset the filtering, so that you can start from the beginning.

I also like the way you tag in F-Spot. Just type will you're in iconview, and tags become auto-completed. Multiple tags are assigned with a comma separated list. This is very fast.

Andi
Comment 4 Mikolaj Machowski 2009-06-02 12:44:17 UTC
#3 - but it is not usable to assign many tags at once - unless digiKam will recognize ";" or "," to assign previous tag and start from the beginning.

#1 - after entering existing tag name in "new tag" dialog I see another dialog with info: "This tag already exists, Continue, Cancel". If digiKam goes with one dialog approach it should be possible to disable dialog with error log.
Comment 5 Andi Clemens 2009-06-02 12:50:21 UTC
Have you tried the F-Spot approach?
For me it is quite the best system.

You enter a tag, then press TAB to autocomplete, an ',' is automatically entered and you can continue to type.
This is very fast. And the nice thing: If you want to assign this tag combination to many images afterwards, just use copy & paste.
Comment 6 Dominic Lyons 2009-06-02 15:14:18 UTC
Yes, the F-Spot approach seems to be very handy.
Comment 7 Andi Clemens 2009-06-02 15:23:49 UTC
The good thing about this approach is that you constantly see which tags are already assigned. In digiKam we must first set the toggleButton to see already assigned tags.
Comment 8 caulier.gilles 2009-06-19 13:13:27 UTC

*** This bug has been marked as a duplicate of bug 114465 ***
Comment 9 caulier.gilles 2022-01-22 17:37:06 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=114465