Bug 194918 - removable media missing files are not restored
Summary: removable media missing files are not restored
Status: RESOLVED DUPLICATE of bug 171213
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.0.2
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-01 22:02 UTC by Spraff
Modified: 2009-08-22 14:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Spraff 2009-06-01 22:02:33 UTC
Version:           2.0.2 (using 4.2.2 (KDE 4.2.2), Kubuntu packages)
Compiler:          cc
OS:                Linux (i686) release 2.6.28-11-generic

To duplicate:

1) Have music files on removable media with drive label LABEL. On my Ubuntu this is mounted automatically at /media/LABEL

2) Add /media/LABEL/foo to Amarok collection

3) Close Amarok

4) Remove external drive

5) Restart Amarok, the collection is now missing the files in /media/LABEL, as you would expect.

6) Close Amarok.

7) Insert external drive. This is mounted at /media/LABEL again (manually checked)

8) Restart Amarok

Observed: same state as step 5, the missing files are not restored.

Desired: missing files should be a temporary phenomenon, not removed from the collection but merely unavailable until the drive is re-mounted. Ideally this would not require an Amarok restart, thus the inner logic would be something like "do (select candidate file) while (file does not exist); play;" and the collection would not be altered until /media/LABEL/foo are explicitly (manually) removed.

This is a major headache when 100GB collections on external media are temporarily unavailable. There is no technical reason to force a rebuild of the collection!
Comment 1 Marios Andreopoulos 2009-06-28 13:56:26 UTC
I want to confirm this bug which still exists in amarok 2.1.1 and describe more problems coming from it.

If you mount the "missing" drive and ask amarok to re-scan your collection it destroys the collection shuffling artist and album names.

If you had some of the "missing files" in your playlist then these files will not be scanned in the collection.

Searching through amarok forums the solution usually suggested is to delete the collection. I do not consider this as a solution since it does not prevent the problem from happening next time you start amarok with an unmounted hard disk.
Comment 2 Mikko C. 2009-08-22 14:59:26 UTC

*** This bug has been marked as a duplicate of bug 171213 ***