Bug 194872 - flicker/stall with mplayer and compositing enabled and xv video out (fullscreen) on kmix osd
Summary: flicker/stall with mplayer and compositing enabled and xv video out (fullscre...
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources NetBSD
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-06-01 15:29 UTC by Jason
Modified: 2009-06-01 15:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jason 2009-06-01 15:29:34 UTC
Version:           4.2.87 (using Devel)
OS:                NetBSD
Installed from:    Compiled sources

I admit I don't know if it's mplayer or kwin at fault but this doesn't happen in compiz/anything else or with kde when compositing is disabled.

Basically, I have vo=xv for mplayer, I fullscreen it, and when I use my media keys to adjust volume, which means kmix's osd is put ontop of the fullscreen window, the screen flickers a few times and frames can stall (sometimes pretty badly).  It won't happen every time, particularly within a brief period after it shows up if you adjust volume again.  So to reproduce fullscreen when vo=xv and use your volume keys every few minutes... it should happen to you at least once in a reasonable period of time.  Note that this doesn't happen with totem or vlc (which implies mplayer is doing something wrong).

As a side note: I am using the nvidia driver's but this bug has gone on for a year...  Should have the problem with any nvidia driver afaict.  Unfortunately I can't test on any other video cards (ati/intel).  I'd have to say it has something to do with xv, fullscreen windows and undirected/redirected rendering/compositing though.
Comment 1 Martin Flöser 2009-06-01 15:32:03 UTC
Your guess is correct: that's caused be unredirecting fullscreen windows.

*** This bug has been marked as a duplicate of bug 177495 ***