Bug 194756 - Konqueror crashes at shutdown SIGABRT
Summary: Konqueror crashes at shutdown SIGABRT
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-31 15:12 UTC by Marc Paine
Modified: 2009-06-01 08:30 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Paine 2009-05-31 15:12:26 UTC
Version:           4.2.3 (KDEMod - Arch Linux) (using KDE 4.2.3)
OS:                Linux
Installed from:    Unlisted Binary Package

Konqueror crashes when closed regardless of number of tabs open, etc. Compositing is ON. 
Amarok is RUNNING.
Troubleshooting combinations of the above? NO.


Application: Konqueror (konqueror), signal SIGABRT

Thread 1 (Thread 0xb5b53710 (LWP 5660)):
[KCrash Handler]
#6  0xb7f97424 in __kernel_vsyscall ()
#7  0xb62347a1 in raise () from /lib/libc.so.6
#8  0xb6235fd4 in abort () from /lib/libc.so.6
#9  0xb622d5fe in __assert_fail () from /lib/libc.so.6
#10 0xb3a2b5a7 in KHTMLGlobal::finalCheck () from /usr/lib/libkhtml.so.5
#11 0xb1a792bf in KHTMLFactory::~KHTMLFactory () from /usr/lib/kde4/libkhtmlpart.so
#12 0xb7496922 in ._132::destroy () from /usr/lib/libkdecore.so.5
#13 0xb732ecbb in KCleanUpGlobalStatic::~KCleanUpGlobalStatic () from /usr/lib/libkdecore.so.5
#14 0xb623777f in __run_exit_handlers () from /lib/libc.so.6
#15 0xb62377ef in exit () from /lib/libc.so.6
#16 0xb6220a3e in __libc_start_main () from /lib/libc.so.6
#17 0x08048681 in _start ()
Comment 1 Dario Andres 2009-05-31 15:19:03 UTC
Do you always get this crash on exit? Thanks
Comment 2 Christoph Feck 2009-06-01 08:21:29 UTC
I just got the same crash, on todays trunk. Closing konqueror after using reviewboard.kde.org with a clean .kde.

This is the konsole output, including the output of drKonqui2 (sorry, I closed the dialog too fast... )

konqueror(21824)/khtml (html) DOM::HTMLDocumentImpl::changeModes:  using compatibility parseMode
konqueror(21824)/khtml (html) DOM::HTMLDocumentImpl::changeModes:  using transitional parseMode
konqueror(21824) KonqMainWindow::addClosedWindowToUndoList:
konqueror(21824) KonqClosedWindowItem::KonqClosedWindowItem: "Closed_Window170250728"
konqueror(21824) KonqMainWindow::addClosedWindowToUndoList: done
konqueror(21824)/khtml (part) KHTMLPart::~KHTMLPart: KHTMLPart(0x87c25f0)
konqueror(21824)/kparts KParts::Part::~Part: deleting widget QWidget(0x87d5e00, name = "khtml_part_widget") "khtml_part_widget"
kded(6730) KCookieJar::eatSessionCookies: deleting session cookie
QThreadStorage: Thread 0x8050728 exited after QThreadStorage 2147483636 destroyed
konqueror(21824) Sonnet::Loader::~Loader: Removing loader :  Sonnet::Loader(0x923a228)
kio_http(22564)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22564)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22565)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22565)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22568)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22568)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22570)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22570)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22562)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22562)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22572)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22572)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
konqueror(21824)/khtml KHTMLFactory::~KHTMLFactory: KHTMLFactory(0x87c3c00)
konqueror(21824)/khtml KHTMLGlobal::finalCheck: 1 docs not deleted
konqueror(21824)/khtml KHTMLGlobal::finalCheck: Document DOM::HTMLDocumentImpl(0x98e11c8) wasn't deleted
konqueror: /local/svn/kde/trunk/KDE/kdelibs/khtml/khtml_global.cpp:258: static void KHTMLGlobal::finalCheck(): Zusicherung »!s_refcnt« nicht erfüllt.
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = konqueror path = <unknown> pid = 21824
sock_file=/home/kde4/.kde/socket-stylistic/kdeinit4__0
kdeinit4: Got EXEC_NEW '/local/kde4/lib/kde4/libexec/drkonqi' from wrapper.
kdeinit4: preparing to launch /local/kde4/lib/libkdeinit4_/drkonqi.so
Could not open library /local/kde4/lib/kde4/libexec/drkonqi: Cannot load library /local/kde4/lib/libkdeinit4_/drkonqi.so: (/local/kde4/lib/libkdeinit4_/libdrkonqi.so: Kann die Shared-Object-Datei nicht öffnen: Datei oder Verzeichnis nicht gefunden)
drkonqi(22575)/kdeui (KIconLoader) KIconLoader::loadIcon: No such icon "system-restart"

[1]+  Stopped                 konqueror
kde4@stylistic:~> kio_http(22565)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22564)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22568)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22562)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22570)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kio_http(22572)/kio (TCPSlaveBase) KIO::TCPSlaveBase::disconnectFromHost:
kdeinit4: PID 22562 terminated.
kdeinit4: PID 22565 terminated.
kdeinit4: PID 22568 terminated.
kdeinit4: PID 22564 terminated.
kdeinit4: PID 22572 terminated.
kdeinit4: PID 22570 terminated.
drkonqi(22575) BacktraceLineGdb::parse: crap detected: "[Thread debugging using libthread_db enabled]
"
drkonqi(22575) BacktraceLineGdb::parse: crap detected: "0xffffe430 in __kernel_vsyscall ()
"
drkonqi(22575) BacktraceLineGdb::parse: thread indicator detected: "[Current thread is 1 (Thread 0xb5ba7710 (LWP 21824))]
"
drkonqi(22575) BacktraceLineGdb::parse: thread start detected: "Thread 1 (Thread 0xb5ba7710 (LWP 21824)):
"
drkonqi(22575) BacktraceLineGdb::parse: 0 "__kernel_vsyscall" "" false false ""
drkonqi(22575) BacktraceLineGdb::parse: 1 "nanosleep" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 2 "sleep" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 3 "KCrash::startDrKonqi" "argv=0xbfae48fc, argc=15" true true "/local/svn/kde/trunk/KDE/kdelibs/kdeui/util/kcrash.cpp:412"
drkonqi(22575) BacktraceLineGdb::parse: 4 "KCrash::defaultCrashHandler" "sig=6" true true "/local/svn/kde/trunk/KDE/kdelibs/kdeui/util/kcrash.cpp:337"
drkonqi(22575) BacktraceLineGdb::parse: 6 "__kernel_vsyscall" "" false false ""
drkonqi(22575) BacktraceLineGdb::parse: 7 "raise" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 8 "abort" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 9 "__assert_fail" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 10 "KHTMLGlobal::finalCheck" "" true true "/local/svn/kde/trunk/KDE/kdelibs/khtml/khtml_global.cpp:258"
drkonqi(22575) BacktraceLineGdb::parse: 11 "~KHTMLFactory" "this=0x87c3c00, __in_chrg=<value optimized out>" true true "/local/svn/kde/trunk/KDE/kdelibs/khtml/khtml_factory.cpp:35"
drkonqi(22575) BacktraceLineGdb::parse: 12 "qDeleteAll<QHash<QString, QPointer<KPluginFactory> >::const_iterator>" "begin=..., end=..." true true "/local/qt4/include/QtCore/qalgorithms.h:350"
drkonqi(22575) BacktraceLineGdb::parse: 13 "qDeleteAll<FactoryHash>" "c=..." true true "/local/qt4/include/QtCore/qalgorithms.h:358"
drkonqi(22575) BacktraceLineGdb::parse: 14 "~FactoryHash" "this=0x82a72f0, __in_chrg=<value optimized out>" true true "/local/svn/kde/trunk/KDE/kdelibs/kdecore/util/klibrary.cpp:93"
drkonqi(22575) BacktraceLineGdb::parse: 15 "destroy" "" true true "/local/svn/kde/trunk/KDE/kdelibs/kdecore/util/klibrary.cpp:97"
drkonqi(22575) BacktraceLineGdb::parse: 16 "~KCleanUpGlobalStatic" "this=0xb7573450, __in_chrg=<value optimized out>" true true "/local/svn/kde/trunk/KDE/kdelibs/kdecore/kernel/kglobal.h:62"
drkonqi(22575) BacktraceLineGdb::parse: 17 "exit" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 18 "__libc_start_main" "" true false "/lib/libc.so.6"
drkonqi(22575) BacktraceLineGdb::parse: 19 "_start" "" true true "../sysdeps/i386/elf/start.S:119"
Comment 3 Christoph Feck 2009-06-01 08:30:35 UTC

*** This bug has been marked as a duplicate of bug 151453 ***