Bug 194434 - ESPN.com causes Konqueror to Krash.
Summary: ESPN.com causes Konqueror to Krash.
Status: RESOLVED DUPLICATE of bug 189373
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-28 14:58 UTC by Jim
Modified: 2009-06-02 15:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Backtrace of Crash (9.65 KB, text/plain)
2009-06-01 16:52 UTC, Jim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim 2009-05-28 14:58:26 UTC
Application that crashed: konqueror
Version of the application: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
KDE Version: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
Qt Version: 4.5.1
Operating System: Linux 2.6.28-11-generic x86_64
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
Just simply visiting the site causes Konqueror to crash every time.  It appears to crash after about 80% of the page has loaded.

 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 0 (LWP 31106)]

Thread 3 (Thread 0x7f6ea2c34950 (LWP 31356)):
#0  0x00007f6eb221c56d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6eb5a70cc7 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f6eb5a66879 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6eb5a6fd02 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6eb22183ba in start_thread () from /lib/libpthread.so.0
#5  0x00007f6eb347bfcd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f6ea3e3a950 (LWP 31357)):
#0  0x00007f6eb221c56d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6eb5a70cc7 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f6eb5a66879 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6eb5a6fd02 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6eb22183ba in start_thread () from /lib/libpthread.so.0
#5  0x00007f6eb347bfcd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6eb8583750 (LWP 31106)):
[KCrash Handler]
#5  0x00007f6ea7e5d537 in ?? () from /usr/lib/libkjs.so.4
#6  0x00007f6ea7e60061 in ?? () from /usr/lib/libkjs.so.4
#7  0x00007f6ea7e92779 in KJS::JSObject::call () from /usr/lib/libkjs.so.4
#8  0x00007f6ea7ead7f1 in ?? () from /usr/lib/libkjs.so.4
#9  0x00007f6ea7e8ecdf in KJS::FunctionImp::callAsFunction () from /usr/lib/libkjs.so.4
#10 0x00007f6ea7e92779 in KJS::JSObject::call () from /usr/lib/libkjs.so.4
#11 0x00007f6ea7ead7f1 in ?? () from /usr/lib/libkjs.so.4
#12 0x00007f6ea7e8ecdf in KJS::FunctionImp::callAsFunction () from /usr/lib/libkjs.so.4
#13 0x00007f6ea7e92779 in KJS::JSObject::call () from /usr/lib/libkjs.so.4
#14 0x00007f6ea7ead7f1 in ?? () from /usr/lib/libkjs.so.4
#15 0x00007f6ea7e63379 in ?? () from /usr/lib/libkjs.so.4
#16 0x00007f6ea7e955e7 in KJS::Interpreter::evaluate () from /usr/lib/libkjs.so.4
#17 0x00007f6ea7e956a3 in KJS::Interpreter::evaluate () from /usr/lib/libkjs.so.4
#18 0x00007f6ea8547d41 in ?? () from /usr/lib/libkhtml.so.5
#19 0x00007f6ea8304d41 in KHTMLPart::executeScript () from /usr/lib/libkhtml.so.5
#20 0x00007f6ea83960e8 in ?? () from /usr/lib/libkhtml.so.5
#21 0x00007f6ea839a626 in ?? () from /usr/lib/libkhtml.so.5
#22 0x00007f6ea84bed4f in ?? () from /usr/lib/libkhtml.so.5
#23 0x00007f6ea84c254c in ?? () from /usr/lib/libkhtml.so.5
#24 0x00007f6ea84c21bf in ?? () from /usr/lib/libkhtml.so.5
#25 0x00007f6ea84c8547 in ?? () from /usr/lib/libkhtml.so.5
#26 0x00007f6eb5b6e8d2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#27 0x00007f6eb61ab792 in KJob::result () from /usr/lib/libkdecore.so.5
#28 0x00007f6eb61abb0f in KJob::emitResult () from /usr/lib/libkdecore.so.5
#29 0x00007f6eb73e4180 in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.5
#30 0x00007f6eb73e53a3 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.5
#31 0x00007f6eb73e6425 in KIO::TransferJob::qt_metacall () from /usr/lib/libkio.so.5
#32 0x00007f6eb5b6e8d2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#33 0x00007f6eb74a2771 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#34 0x00007f6eb749f2c2 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.5
#35 0x00007f6eb7491e43 in KIO::Slave::gotInput () from /usr/lib/libkio.so.5
#36 0x00007f6eb74940a8 in KIO::Slave::qt_metacall () from /usr/lib/libkio.so.5
#37 0x00007f6eb5b6e8d2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#38 0x00007f6eb73af541 in ?? () from /usr/lib/libkio.so.5
#39 0x00007f6eb73af99a in KIO::Connection::qt_metacall () from /usr/lib/libkio.so.5
#40 0x00007f6eb5b68f28 in QObject::event () from /usr/lib/libQtCore.so.4
#41 0x00007f6eb4facb9d in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#42 0x00007f6eb4fb4dea in QApplication::notify () from /usr/lib/libQtGui.so.4
#43 0x00007f6eb69921ab in KApplication::notify () from /usr/lib/libkdeui.so.5
#44 0x00007f6eb5b58dfc in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#45 0x00007f6eb5b59a6a in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#46 0x00007f6eb5b828a3 in ?? () from /usr/lib/libQtCore.so.4
#47 0x00007f6eb0f3620a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0x00007f6eb0f398e0 in ?? () from /usr/lib/libglib-2.0.so.0
#49 0x00007f6eb0f39a7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0x00007f6eb5b8252f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#51 0x00007f6eb504570f in ?? () from /usr/lib/libQtGui.so.4
#52 0x00007f6eb5b576a2 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#53 0x00007f6eb5b57a6d in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#54 0x00007f6eb5b59d34 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#55 0x00007f6eb8170852 in kdemain () from /usr/lib/libkdeinit4_konqueror.so
#56 0x00007f6eb33b45a6 in __libc_start_main () from /lib/libc.so.6
#57 0x00000000004007a9 in _start ()
Comment 1 A. Spehr 2009-05-29 04:45:21 UTC
http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

This is something that we thought was fixed, so if you can go and get a better backtrace, that would be really great!

Also, exactly what version of Qt are you running? And are you running trunk?

Thanks!
Comment 2 Jim 2009-06-01 16:52:12 UTC
Created attachment 34172 [details]
Backtrace of Crash

I re-ran the backtrace with debugging symbols installed for kdelibs5 libc6 and libqt4 (on Kubuntu Jaunty with KDE 4.3 Beta 1 installed).
Comment 3 Jim 2009-06-01 16:54:21 UTC
Also, I'm running Qt4.5.1.  I'm not using trunk, I'm using the kubuntu-experimental repository for jaunty.
Comment 4 Maksim Orlovich 2009-06-02 15:18:59 UTC
Thanks... Just as I thought --- this one is fixed...

*** This bug has been marked as a duplicate of bug 189373 ***