Bug 194190 - holding keys down no longer results in repeated entries
Summary: holding keys down no longer results in repeated entries
Status: RESOLVED LATER
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-26 20:04 UTC by Steven M. Parrish
Modified: 2011-09-23 03:32 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steven M. Parrish 2009-05-26 20:04:59 UTC
Version:            (using KDE 4.2.3)
OS:                Linux
Installed from:    Fedora RPMs

This was reported on the Fedora Bugzilla.  Below are the comments from that bugreport.

   Description From  Need Real Name (chapinjeff@gmail.com)  2009-02-18 19:25:36 EDT   (-) [reply]

Description of problem:

Pressing a key and holding does not result in repeated entries of that key.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Press "a" key, and count to 10
2.
3.

Actual results:
 a

Expected results:
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

Additional info:  

------- Comment #1 From Kevin Kofler (kevin@tigcc.ticalc.org) 2009-02-18 19:36:28 EDT (-) [reply] -------

This is probably an evdev issue, not a KDE issue.  

------- Comment #2 From Rex Dieter (rdieter@math.unl.edu) 2009-02-18 19:39:18 EDT (-) [reply] -------

could look in system settings -> keyboard & mouse, to check to see if the
"repeat
keys" option is enabled or not.  

------- Comment #3 From Need Real Name (chapinjeff@gmail.com) 2009-02-18 22:45:20 EDT (-) [reply] -------

Kevin -- It worked just fine on a tty.

Rex, that seems to have been the problem. Now to fix that so it is enabled (the
expected behavior) by default. Heck, it took three different people to even
guess that one.  

------- Comment #4 From Kevin Kofler (kevin@tigcc.ticalc.org) 2009-02-18 22:49:47 EDT (-) [reply] -------

Let's reassign it to kdebase-workspace for now.

Might this be a settings migration issue?  

------- Comment #5 From Need Real Name (chapinjeff@gmail.com) 2009-02-18 23:16:14 EDT (-) [reply] -------

This was an upgrade from fedora8/kde3.5, however that was not set prior to this
-- so if it is a migration issue, there is still a bug somewhere.  

------- Comment #6 From Need Real Name (chapinjeff@gmail.com) 2009-02-21 20:10:36 EDT (-) [reply] -------

It does not appear to be upgrade related, as KDE is not saving the fact that I
am enabing keyboard repeat. Everytime KDE restarts, I have to re-enable that.  

------- Comment #7 From Need Real Name (chapinjeff@gmail.com) 2009-02-22 18:37:17 EDT (-) [reply] -------

It appears that "enable keyboard repeat" is simply not saying. Every time I
open that system-settings dialog, the box is unchecked.

It also appears that 'up' 'down' and 'right' are still repeating... (sometimes)
but left never seems to.  

------- Comment #8 From Need Real Name (chapinjeff@gmail.com) 2009-03-02 02:31:44 EDT (-) [reply] -------

After re-enabling (again), now up and right repeat, down and left, do not. 

All attempted letters seem to repeat correctly.  

------- Comment #9 From Rex Dieter (rdieter@math.unl.edu) 2009-03-02 08:52:16 EDT (-) [reply] -------

curious, what video hw/driver is in use here?  We've had quite a few reports
lately of odd keyboard-related irregularities (similiar as here) for users of
recent nvidia drivers, for example.

Are these issues reproducible with a fresh user (ie, one with an initially
empty ~/.kde)?  

------- Comment #10 From Need Real Name (chapinjeff@gmail.com) 2009-03-02 09:11:45 EDT (-) [reply] -------

As per bug # 486234, I am unable to log in as a different user.

I am using the Intel 965GM chipset, with included video, and I am using the
'intel' driver that came by default.  

------- Comment #11 From Rex Dieter (rdieter@math.unl.edu) 2009-03-02 11:08:01 EDT (-) [reply] -------

There are much bigger issues going on here it would seem, so we may be losing
the forest for the trees here.  

------- Comment #12 From Need Real Name (chapinjeff@gmail.com) 2009-03-02 11:23:58 EDT (-) [reply] -------

Well, it would be nice to get working on the forest. If you have a better
suggestion for tackling the problems, feel free to suggest them.

As I see it, much of the problem stems from Fedora 8 losing support and
requiring an upgrade to maintain access to updated repos -- but Fedora 9 and 10
both have immature versions of KDE with multiple bugs.  Other than trying to
address the bugs one at a time, and petitioning to get a stable, mature version
of KDE back, I am out of ideas, and the latter seems to have a snowballs
chance.  

------- Comment #13 From Kevin Kofler (kevin@tigcc.ticalc.org) 2009-03-02 12:44:30 EDT (-) [reply] -------

I still think this issue is probably somehow related to the evdev migration.
Maybe it's KDE not handling evdev correctly though.

One thing you can try: go to the keyboard settings in System Settings and make
sure the keyboard type is set to "Evdev-managed keyboard".  

------- Comment #14 From Need Real Name (chapinjeff@gmail.com) 2009-03-04 20:41:22 EDT (-) [reply] -------

I started system-settings, clicked 'Keyboard and Mouse"... and do not see
anyplace to check keyboard type.  

------- Comment #15 From Kevin Kofler (kevin@tigcc.ticalc.org) 2009-03-04 20:45:36 EDT (-) [reply] -------

Sorry, it's under "keyboard layouts" in the regional settings, not under
"keyboard and mouse".

But the setting is there only if you have keyboard layouts enabled in KDE. If
you have them disabled, it's grayed out, in that case it can't be that.  

------- Comment #16 From Need Real Name (chapinjeff@gmail.com) 2009-03-04 20:50:36 EDT (-) [reply] -------

Grayed out.
Comment 1 Dario Andres 2009-05-27 19:14:05 UTC
Any conclusions about this?  Is this a problem in SystemSettings (settings not being saved), on kdelibs/kdeinit (settings not being loaded) or a whole wrong configuration with the keyboard and layouts ? (I would like to reassign this report to another place)

Thanks
Comment 2 Wolfgang Wallner 2009-06-04 16:18:59 UTC
I can reproduce the same problem with Kanotix Excalibur ( = modified Debian Lenny) using KDE 4.2.3

My System is set to "Autologin". When I log out and log in again, my keyboard suddenly works (without changing any settings!). The same is true if I disable autologin completly and just type in my password when the system starts up. In this case, my keyboard works just from the start.

When I start the system with autologin enabled ( = keyboard is NOT working in KDE), then open Konsole and start "evtest" for one of my keyboards (builtin laptop keyboard and external USB keyboard), both seem to work in evtest, but none of them is working as normal KDE keyboard.

I should also mention that I got the keyboard working just by playing with the keyboard settings in System-Settings -> Regional & Language -> Keyboard Layout. However, I could not reproduce this.

nice greets
Comment 3 Wolfgang Wallner 2009-06-04 20:59:32 UTC
I tried to boot with no X, then log in and run "startx".
This has the same effect as the "Autologin"-option, the keyboard does not work as expected.

I was also wondering if it could be some kind of conflict with "keytouch", the program I use for my multimedia-keys. I'm not sure, but I think I already had the keyboard-problem *before* I installed keytouch. This is why I think we can refuse this thougt, but it would be nice if someone could approve that he/she is not using keytouch but experiencing the same keyboard-problem.

nice greets.
Comment 4 Andriy Rysin 2009-06-07 23:28:18 UTC
I know it might not be helping much but I cannot reproduce the problem with Mandriva 2009.1 (KDE 4.2.2). My keyboard driver is evdev and I tried with session opened with kdm and one started by startx. I also tried with both clean config (removing ~./kde* directories) and with existing config files.
All the functionality: repeats, saving and restoring 'key repeat' config works properly.

As there were no changes to KDE keyboard module (which is responsible for setting repeats) for quite a while I doubt that it's a kde bug.

Also one of the previous comments from Kevin "It also appears that 'up' 'down' and 'right' are still repeating... (sometimes) but left never seems to" makes me think it's not kde bug even more.
Comment 5 Wolfgang Wallner 2009-11-10 18:35:53 UTC
After upgrading to KDE 4.3.2 found on http://www.debian-desktop.org/, I cannot reproduce this problem any more.

But as I have upgrade a lot of other packages since my last bug report in June without trying if the problem had gone, I still cannot say if it was a KDE related bug or not.

For now, I'm glad that it vanished on my machine :D
Comment 6 Jekyll Wu 2011-09-23 03:32:56 UTC
Can't reproduce this and this report has been inactive for 2 years. I guess the problem is solved in other place.