Bug 193730 - Random crashes sometimes when selecting images, sometimes closing tools (correlator)
Summary: Random crashes sometimes when selecting images, sometimes closing tools (corr...
Status: RESOLVED DUPLICATE of bug 182470
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Torsten Rahn
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-23 08:34 UTC by Rick Wagner
Modified: 2009-05-23 14:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick Wagner 2009-05-23 08:34:45 UTC
Version:           0.10.0 (using KDE 4.2.3)
OS:                Linux
Installed from:    Fedora RPMs

Digikam will crash a apparently random times.  Sometimes while just clicking on thumbnails to view meta-data.  A couple times in the geolocation correlator.

Application: digiKam (digikam), signal SIGSEGV
0x00000032b86a3e61 in nanosleep () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7f2e6d579820 (LWP 19886))]

Thread 11 (Thread 0x7f2e63e7c910 (LWP 19889)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00000032c465b2db in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x000000000063bb9b in Digikam::ScanController::run (this=0x128e600) at /usr/src/debug/digikam-0.10.0/digikam/scancontroller.cpp:412
#4  0x00000032c465a221 in QThreadPrivate::start (arg=0x128e600) at thread/qthread_unix.cpp:189
#5  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f2e6314c910 (LWP 19894)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00000032c465b2db in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x000000394312c372 in Digikam::LoadSaveThread::run (this=0x12ad380) at /usr/src/debug/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00000032c465a221 in QThreadPrivate::start (arg=0x12ad380) at thread/qthread_unix.cpp:189
#5  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
Current language:  auto; currently asm

Thread 9 (Thread 0x7f2e6274b910 (LWP 19895)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00000032c465b2db in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x000000394312c372 in Digikam::LoadSaveThread::run (this=0x14f2a10) at /usr/src/debug/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00000032c465a221 in QThreadPrivate::start (arg=0x14f2a10) at thread/qthread_unix.cpp:189
#5  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f2e4ebb1910 (LWP 19896)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:220
#1  0x00007f2e601055c1 in ?? () from /usr/lib64/libxine.so.1
#2  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#3  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f2e4c694910 (LWP 19897)):
#0  0x00000032b86d6fa2 in select () from /lib64/libc.so.6
#1  0x00007f2e6012da85 in xine_usec_sleep () from /usr/lib64/libxine.so.1
#2  0x00007f2e60113289 in ?? () from /usr/lib64/libxine.so.1
#3  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f2e4bc93910 (LWP 19898)):
#0  0xffffffffff60012f in ?? ()
#1  0x00007f2e4bc92c60 in ?? ()
#2  0x00007fff767ff782 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Current language:  auto; currently minimal

Thread 5 (Thread 0x7f2e4ae83910 (LWP 19907)):
#0  0x00000032b86d4f73 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2e4dd977f3 in ?? () from /usr/lib64/libpulse.so.0
#2  0x00007f2e4dd852c4 in pa_mainloop_poll () from /usr/lib64/libpulse.so.0
#3  0x00007f2e4dd85673 in pa_mainloop_iterate () from /usr/lib64/libpulse.so.0
#4  0x00007f2e4dd856e6 in pa_mainloop_run () from /usr/lib64/libpulse.so.0
#5  0x00007f2e4dd97870 in ?? () from /usr/lib64/libpulse.so.0
#6  0x00007f2e4db4cc2b in ?? () from /usr/lib64/libpulsecommon-0.9.15.so
#7  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#8  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2e4a482910 (LWP 19908)):
#0  0x00000032b86d4f73 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=333) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2e4b08f92e in snd_pcm_sw_params_set_start_threshold () from /usr/lib64/xine/plugins/1.26/xineplug_ao_out_alsa.so
#2  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#3  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f2e37fff910 (LWP 19909)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f2e60116493 in ?? () from /usr/lib64/libxine.so.1
#2  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#3  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2e3f3f8910 (LWP 19928)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00000032c465b2db in QWaitConditionPrivate::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (time=<value optimized out>, this=<value optimized out>) at thread/qwaitcondition_unix.cpp:159
#3  0x000000394312c372 in Digikam::LoadSaveThread::run (this=0x1ee45c0) at /usr/src/debug/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#4  0x00000032c465a221 in QThreadPrivate::start (arg=0x1ee45c0) at thread/qthread_unix.cpp:189
#5  0x00000032b920686a in start_thread (arg=<value optimized out>) at pthread_create.c:297
#6  0x00000032b86de25d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()
Current language:  auto; currently asm

Thread 1 (Thread 0x7f2e6d579820 (LWP 19886)):
[KCrash Handler]
#5  0x00000032be6c097a in __cxxabiv1::__dynamic_cast(const void *, const struct __cxxabiv1::__class_type_info *, const struct __cxxabiv1::__class_type_info *, ptrdiff_t) (src_ptr=0x7f2e2c3bc470, 
    src_type=0x353f17c960, dst_type=0x353f17d090, src2dst=0) at ../../../../libstdc++-v3/libsupc++/dyncast.cc:47
#6  0x000000353eed1c4d in Marble::MarbleGeometryModel::data (this=<value optimized out>, index=<value optimized out>, role=<value optimized out>)
    at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleGeometryModel.cpp:161
#7  0x00007f2e49272c59 in Marble::MarbleGeoDataView::renderIndex (this=0x1ccf680, index=<value optimized out>)
    at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:91
#8  0x00007f2e49272e37 in Marble::MarbleGeoDataView::paintEvent (this=0x1ccf680, event=<value optimized out>) at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:77
#9  0x00007f2e49271b6a in Marble::MarbleGeoDataPlugin::render (this=0x1ce4e70, painter=0x7fff76790c40, viewport=<value optimized out>, renderPos=<value optimized out>, layer=<value optimized out>)
    at /usr/src/debug/kdeedu-4.2.3/marble/src/plugins/render/geodata/MarbleGeoDataPlugin.cpp:102
#10 0x000000353eee537d in Marble::LayerManager::renderLayers (this=0x1ccfb40, painter=<value optimized out>, viewParams=<value optimized out>)
    at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/LayerManager.cpp:92
#11 0x000000353eeab08c in Marble::MarbleModel::paintGlobe (this=0x1ccf8b0, painter=0x7fff76790c40, width=<value optimized out>, height=<value optimized out>, viewParams=0x1ccea90, 
    redrawBackground=<value optimized out>, dirtyRect=@0x7fff76790c60) at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleModel.cpp:700
#12 0x000000353eeb30bf in Marble::MarbleMapPrivate::paintGround (this=0x1ccea70, painter=@0x7fff76790c40, dirtyRect=<value optimized out>)
    at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleMap.cpp:290
#13 0x000000353eea52d8 in Marble::MarbleWidget::paintEvent (this=0x1cce730, evt=<value optimized out>) at /usr/src/debug/kdeedu-4.2.3/marble/src/lib/MarbleWidget.cpp:844
#14 0x00000032c5fdd59f in QWidget::event (this=0x1cce730, event=0x7fff76791270) at kernel/qwidget.cpp:7654
#15 0x00000032c5f8deac in QApplicationPrivate::notify_helper (this=0x110a890, receiver=0x1cce730, e=0x7fff76791270) at kernel/qapplication.cpp:4084
#16 0x00000032c5f954de in QApplication::notify (this=0x7fff76792200, receiver=0x1cce730, e=0x7fff76791270) at kernel/qapplication.cpp:4049
#17 0x000000353b406076 in KApplication::notify (this=0x7fff76792200, receiver=0x1cce730, event=0x7fff76791270) at /usr/src/debug/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#18 0x00000032c4742b7c in QCoreApplication::notifyInternal (this=0x7fff76792200, receiver=0x1cce730, event=0x7fff76791270) at kernel/qcoreapplication.cpp:602
#19 0x00000032c5fe4c5a in QCoreApplication::sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:216
#20 QWidgetPrivate::drawWidget (event=<value optimized out>, receiver=<value optimized out>) at kernel/qwidget.cpp:5046
#21 0x00000032c618371e in QWidgetBackingStore::sync (this=0x12b97c0) at painting/qbackingstore.cpp:1258
#22 0x00000032c5fd66d0 in QWidgetPrivate::syncBackingStore (this=0x12cb220) at kernel/qwidget.cpp:1603
#23 0x00000032c5fdd3a5 in QWidget::event (this=0x12bf3b0, event=0x33df410) at kernel/qwidget.cpp:7794
#24 0x00000032c638470b in QMainWindow::event (this=0x12bf3b0, event=0x33df410) at widgets/qmainwindow.cpp:1396
#25 0x000000353b50b918 in KXmlGuiWindow::event (this=0x922540, ev=0x0) at /usr/src/debug/kdelibs-4.2.3/kdeui/xmlgui/kxmlguiwindow.cpp:131
#26 0x00000032c5f8deac in QApplicationPrivate::notify_helper (this=0x110a890, receiver=0x12bf3b0, e=0x33df410) at kernel/qapplication.cpp:4084
#27 0x00000032c5f954de in QApplication::notify (this=0x7fff76792200, receiver=0x12bf3b0, e=0x33df410) at kernel/qapplication.cpp:4049
#28 0x000000353b406076 in KApplication::notify (this=0x7fff76792200, receiver=0x12bf3b0, event=0x33df410) at /usr/src/debug/kdelibs-4.2.3/kdeui/kernel/kapplication.cpp:307
#29 0x00000032c4742b7c in QCoreApplication::notifyInternal (this=0x7fff76792200, receiver=0x12bf3b0, event=0x33df410) at kernel/qcoreapplication.cpp:602
#30 0x00000032c474366a in QCoreApplication::sendEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.h:213
#31 QCoreApplicationPrivate::sendPostedEvents (event=<value optimized out>, receiver=<value optimized out>) at kernel/qcoreapplication.cpp:1239
#32 0x00000032c476c333 in QCoreApplication::sendPostedEvents () at kernel/qcoreapplication.h:218
#33 postEventSourceDispatch () at kernel/qeventdispatcher_glib.cpp:209
#34 0x00000032bb23818e in g_main_dispatch (context=<value optimized out>) at gmain.c:1814
#35 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2367
#36 0x00000032bb23b8e8 in g_main_context_iterate (context=0x110ca20, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2448
#37 0x00000032bb23ba5c in IA__g_main_context_iteration (context=0x110ca20, may_block=1) at gmain.c:2511
#38 0x00000032c476bfa6 in QEventDispatcherGlib::processEvents (this=0x10f3b30, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:323
#39 0x00000032c60220de in QGuiEventDispatcherGlib::processEvents (this=0x922540, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#40 0x00000032c4741452 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#41 0x00000032c4741824 in QEventLoop::exec (this=0x7fff76792150, flags=) at kernel/qeventloop.cpp:200
#42 0x00000032c4743919 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#43 0x00000000006602fb in main (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/digikam-0.10.0/digikam/main.cpp:190
Current language:  auto; currently minimal
Comment 1 Andi Clemens 2009-05-23 08:57:48 UTC
Crash happens in marble widget, I will re-assign the report...

Andi
Comment 2 Dario Andres 2009-05-23 14:59:39 UTC
Marking as duplicate of bug 182470. Thanks

*** This bug has been marked as a duplicate of bug 182470 ***