Bug 193408 - kded4 high cpu load(50%)
Summary: kded4 high cpu load(50%)
Status: RESOLVED DUPLICATE of bug 178228
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: 4.2.2
Platform: openSUSE RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-20 21:27 UTC by Cosmin
Modified: 2009-10-02 18:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cosmin 2009-05-20 21:27:34 UTC
Version:            (using KDE 4.2.3)
OS:                Linux
Installed from:    SuSE RPMs

I think it happen after update of kde or qt (i did "update if newer version available" on two opensuse systems). Kded4 remains at 50% cpu load.
Comment 1 A. Spehr 2009-05-21 03:02:06 UTC
What does top say? This is most likely from the X server or graphics card drivers or something. Otherwise, we need some actual profiling information. 

There are general speed-ups between your version and 4.3beta.
Comment 2 Alexey Salmin 2009-05-22 14:35:49 UTC
Hello! I've just installed kde 4.2.3 from debian-desktop.org.

salmin@salmin:~$ sudo strace -p `pidof kded4` 2>&1 | head
Process 19456 attached - interrupt to quit
read(8, 0x6d5cb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=8, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
read(8, 0x6d5cb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
read(8, 0x6d5cb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=8, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
read(8, 0x6d5cb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
read(8, 0x6d5cb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=8, events=POLLIN}, {fd=5, events=POLLIN}, {fd=9, events=POLLIN}, {fd=11, events=POLLIN}], 5, 0) = 0 (Timeout)
read(8, 0x6d5cb4, 4096)                 = -1 EAGAIN (Resource temporarily unavailable)

The kded4 process is loading cpu to 100%.
Comment 3 Alexey Salmin 2009-05-22 17:07:46 UTC
If it's important I can add some information about fd
salmin:/proc/19456/fd# ls -l 8
lrwx------ 1 salmin salmin 64 Май 22 22:00 8 -> socket:[15602558]
salmin:/proc/19456/fd# netstat -p | grep 15602558
unix  3      [ ]         STREAM     CONNECTED     15602558 19456/kded4
Comment 4 David Faure 2009-10-02 18:31:42 UTC

*** This bug has been marked as a duplicate of bug 178228 ***