Bug 193231 - Lokalize crashes sometimes while translating
Summary: Lokalize crashes sometimes while translating
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: lokalize
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-19 12:56 UTC by Enrique Matías Sánchez
Modified: 2009-05-19 16:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Enrique Matías Sánchez 2009-05-19 12:56:21 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Debian testing/unstable Packages

Sometimes Lokalize crashes while I'm translating. The specific action might be going to the next entry, but I'm not sure.
 
This is the backtrace (I don't know if it is a duplicate of #191122 or other bug):

Aplicación: Lokalize (lokalize), señal SIGSEGV
0x00007f371bd788e1 in nanosleep () from /lib/libc.so.6
Current language:  auto; currently c
[Current thread is 0 (LWP 5280)]

Thread 2 (Thread 0x7f37144ef950 (LWP 5281)):
#0  __lll_lock_wait_private () at ../nptl/sysdeps/unix/sysv/linux/x86_64/lowlevellock.S:91
#1  0x00007f371bd5165e in _L_lock_3848 () from /lib/libc.so.6
#2  0x00007f371bd4dcfb in *__GI___libc_free (mem=0x7f371c028a00) at malloc.c:3623
#3  0x00007f371c721058 in QObjectPrivate::cleanConnectionLists (this=0x1078320) at ../../include/QtCore/../../src/corelib/tools/qlist.h:348
#4  0x00007f371c722604 in QMetaObject::connect (sender=0x1078240, signal_index=6, receiver=0x7f37000093f8, method_index=4, type=27956000, types=0x0) at kernel/qobject.cpp:2817
#5  0x00007f371c722adc in QObject::connect (sender=0x1078240, signal=0x7f371c79f743 "aboutToClose()", receiver=0x7f37000093f8, method=0x7f371c79f734 "flushStream()", type=4294966784)
    at kernel/qobject.cpp:2554
#6  0x00007f371c6b9f92 in QTextStream (this=0x7f3700000a00, device=0x1078240) at io/qtextstream.cpp:330
#7  0x00007f371d9a4b9e in KDebugPrivate::stream (this=0x1078220, type=QtWarningMsg, area=<value optimized out>, debugFile=0x4ba570 "../../../lokalize/src/tm/jobs.cpp", line=136, 
    funcinfo=0x4bb0a0 "qlonglong getFileId(const QString&, QSqlDatabase&)") at /usr/include/qt4/QtCore/qdebug.h:60
#8  0x00007f371d9a227f in kDebugStream (level=QtWarningMsg, area=0, file=0x4ba570 "../../../lokalize/src/tm/jobs.cpp", line=136, 
    funcinfo=0x4bb0a0 "qlonglong getFileId(const QString&, QSqlDatabase&)") at ../../kdecore/io/kdebug.cpp:622
#9  0x0000000000450489 in KDebug::operator() (this=<value optimized out>, area=27955984) at /usr/include/kdebug.h:240
#10 0x000000000047e62c in getFileId (path=@0x1e62928, db=<value optimized out>) at ../../../lokalize/src/tm/jobs.cpp:136
#11 0x0000000000485ea6 in TM::UpdateJob::run (this=0x1e62910) at ../../../lokalize/src/tm/jobs.cpp:1287
#12 0x00007f371e1c883c in ThreadWeaver::JobRunHelper::runTheJob (this=0x7f37144ef000, th=0x10c4450, job=0x1e62910) at ../../../threadweaver/Weaver/Job.cpp:106
#13 0x00007f371e1c8b61 in ThreadWeaver::Job::execute (this=0x1e62910, th=0x10c4450) at ../../../threadweaver/Weaver/Job.cpp:135
#14 0x00007f371e1c7aff in ThreadWeaver::ThreadRunHelper::run (this=0x7f37144ef090, parent=0x10c3790, th=0x10c4450) at ../../../threadweaver/Weaver/Thread.cpp:95
#15 0x00007f371e1c7f89 in ThreadWeaver::Thread::run (this=0x10c4450) at ../../../threadweaver/Weaver/Thread.cpp:142
#16 0x00007f371c628742 in QThreadPrivate::start (arg=0x10c4450) at thread/qthread_unix.cpp:189
#17 0x00007f371857afaa in start_thread (arg=<value optimized out>) at pthread_create.c:297
#18 0x00007f371bda82ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f371f8a6750 (LWP 5280)):
[KCrash Handler]
#5  malloc_consolidate (av=0x7f371c028a00) at malloc.c:4903
#6  0x00007f371bd4ec1e in _int_malloc (av=0x7f371c028a00, bytes=1152) at malloc.c:4229
#7  0x00007f371bd508e8 in *__GI___libc_malloc (bytes=1152) at malloc.c:3551
#8  0x00007f371c748a7b in QXmlStreamPrivateTagStack (this=0x1ee2820) at xml/qxmlstream_p.h:654
#9  0x00007f371c74c4cc in QXmlStreamReaderPrivate (this=0x7f371c028a00, q=0x480) at xml/qxmlstream.cpp:721
#10 0x00007f371c74da91 in QXmlStreamReader (this=0x7fff279e6e00, data=@0x7fff279e6e40) at xml/qxmlstream.cpp:399
#11 0x00007f371da840b7 in KuitSemanticsPrivate::semanticToVisualText (this=0x10513f0, text_=<value optimized out>, fmtExp_=Kuit::Fmt::Plain, fmtImp_=Kuit::Fmt::Plain)
    at ../../kdecore/localization/kuitsemantics.cpp:1229
#12 0x00007f371da852f6 in KuitSemanticsPrivate::format (this=0x10513f0, text=@0x7fff279e70c0, ctxt=<value optimized out>) at ../../kdecore/localization/kuitsemantics.cpp:995
#13 0x00007f371da853bc in KuitSemantics::format (this=<value optimized out>, text=@0x1e51ce0, ctxt=@0x7f371c028cd0) at ../../kdecore/localization/kuitsemantics.cpp:1689
#14 0x00007f371da5941d in KLocalizedStringPrivate::postFormat (this=<value optimized out>, text=<value optimized out>, lang=@0x7fff279e7210, lscr=@0x7fff279e71f0, ctxt=@0x7fff279e70d0)
    at ../../kdecore/localization/klocalizedstring.cpp:477
#15 0x00007f371da5bbd5 in KLocalizedStringPrivate::toString (this=0x1e33f70, locale=0x1052a40) at ../../kdecore/localization/klocalizedstring.cpp:296
#16 0x00007f371da5c507 in KLocalizedString::toString (this=0x7fff279e7330) at ../../kdecore/localization/klocalizedstring.cpp:205
#17 0x000000000043a127 in EditorWindow::gotoEntry (this=0x1ac9870, pos=<value optimized out>, selection=<value optimized out>) at /usr/include/klocalizedstring.h:748
#18 0x000000000043a9f8 in EditorWindow::gotoNext (this=0x1ac9870) at ../../../lokalize/src/kaider.cpp:989
#19 0x000000000042b6dd in EditorWindow::qt_metacall (this=0x1ac9870, _c=QMetaObject::InvokeMetaMethod, _id=12607, _a=0x7fff279e7560) at moc_kaider.cpp:243
#20 0x00007f371c726872 in QMetaObject::activate (sender=0x1d6a300, from_signal_index=<value optimized out>, to_signal_index=35, argv=0x7f371c028cd0) at kernel/qobject.cpp:3120
#21 0x0000000000442250 in KAiderView::eventFilter (this=0x1d6a300, obj=0x1d629d0, event=0x7fff279e7c50) at ../../../lokalize/src/kaiderview.cpp:358
#22 0x00007f371c710168 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1d629d0, event=0x7fff279e7c50) at kernel/qcoreapplication.cpp:726
#23 0x00007f371cbdf4cc in QApplicationPrivate::notify_helper (this=0xfc62d0, receiver=0x1d629d0, e=0x7fff279e7c50) at kernel/qapplication.cpp:4053
#24 0x00007f371cbe86bf in QApplication::notify (this=<value optimized out>, receiver=0x1d629d0, e=0x7fff279e7c50) at kernel/qapplication.cpp:3663
#25 0x00007f371e5f355b in KApplication::notify (this=0x7fff279e9e10, receiver=0x1d629d0, event=0x7fff279e7c50) at ../../kdeui/kernel/kapplication.cpp:307
#26 0x00007f371c710e5c in QCoreApplication::notifyInternal (this=0x7fff279e9e10, receiver=0x1d629d0, event=0x7fff279e7c50) at kernel/qcoreapplication.cpp:610
#27 0x00007f371cc74774 in QKeyMapper::sendKeyEvent (keyWidget=0x1d629d0, grab=<value optimized out>, type=QEvent::KeyPress, code=16777239, modifiers={i = 664699264}, text=@0x7fff279e8170, 
    autorepeat=false, count=1, nativeScanCode=117, nativeVirtualKey=65366, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1675
#28 0x00007f371cc76aa9 in QKeyMapperPrivate::translateKeyEvent (this=0x100e9a0, keyWidget=0x1d629d0, event=0x7fff279e9a50, grab=128) at kernel/qkeymapper_x11.cpp:1645
#29 0x00007f371cc4f626 in QApplication::x11ProcessEvent (this=0x7fff279e9e10, event=0x7fff279e9a50) at kernel/qapplication_x11.cpp:3459
#30 0x00007f371cc784d4 in x11EventSourceDispatch (s=0xfc9f20, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#31 0x00007f37187c8f7a in IA__g_main_context_dispatch (context=0xfc8d20) at /tmp/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#32 0x00007f37187cc640 in g_main_context_iterate (context=0xfc8d20, block=1, dispatch=1, self=<value optimized out>) at /tmp/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#33 0x00007f37187cc7dc in IA__g_main_context_iteration (context=0xfc8d20, may_block=1) at /tmp/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#34 0x00007f371c73a4cf in QEventDispatcherGlib::processEvents (this=0xfb2890, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
#35 0x00007f371cc77c7f in QGuiEventDispatcherGlib::processEvents (this=0x7f371c028a00, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#36 0x00007f371c70f702 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 664706368}) at kernel/qeventloop.cpp:149
#37 0x00007f371c70facd in QEventLoop::exec (this=0x7fff279e9d80, flags={i = 664706448}) at kernel/qeventloop.cpp:200
#38 0x00007f371c711d94 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#39 0x000000000042ca7d in main (argc=5, argv=0x7fff279ea2c8) at ../../../lokalize/src/main.cpp:111
Current language:  auto; currently asm
#0  0x00007f371bd788e1 in nanosleep () from /lib/libc.so.6
Current language:  auto; currently c
Comment 1 Nick Shaforostoff 2009-05-19 16:54:22 UTC
>I don't know if it is a duplicate of #191122
i think it is. if the crash will be present in KDE 4.3, please reopen this report.

*** This bug has been marked as a duplicate of bug 191122 ***