Bug 193229 - Marble widget while viewing the map
Summary: Marble widget while viewing the map
Status: RESOLVED DUPLICATE of bug 182470
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Torsten Rahn
URL:
Keywords:
: 191825 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-19 12:55 UTC by noeck
Modified: 2018-08-27 17:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description noeck 2009-05-19 12:55:33 UTC
Version:            (using KDE 4.1.2)
OS:                Linux
Installed from:    Ubuntu Packages

When the geo-localization of some pictures is set and then another album is selected within about 30 seconds digikam crashes very often. It is not indicated that saving the geo localization to metadata needs its time, but is seems like some time is needed in which the user must not do anything but wait.

It seems to be a problem with kipi-plugin in digikam 0.10.0.

The information of the backtracker an crash-manager follows:

[Thread debugging using libthread_db enabled]
[New Thread 0xb46c7920 (LWP 15667)]
[New Thread 0xa6ad5b90 (LWP 15742)]
[New Thread 0xacdffb90 (LWP 15741)]
[New Thread 0xa9f56b90 (LWP 15730)]
[New Thread 0xab7ffb90 (LWP 15722)]
[New Thread 0xb10ffb90 (LWP 15688)]
[New Thread 0xb1b29b90 (LWP 15687)]
[New Thread 0xb2693b90 (LWP 15670)]
0xb7fd1430 in __kernel_vsyscall ()
[Current thread is 0 (LWP 15667)]

Thread 8 (Thread 0xb2693b90 (LWP 15670)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb550dd46 in munmap () from /lib/tls/i686/cmov/libc.so.6
#2  0xb549a9e3 in _IO_setb () from /lib/tls/i686/cmov/libc.so.6
#3  0xb5498cff in _IO_file_close_it () from /lib/tls/i686/cmov/libc.so.6
#4  0xb548c025 in fclose () from /lib/tls/i686/cmov/libc.so.6
#5  0xb5065869 in Exiv2::FileIo::close () from /usr/lib/libexiv2.so.5
#6  0xb5099179 in Exiv2::Image::good () from /usr/lib/libexiv2.so.5
#7  0xb50a1c13 in Exiv2::newJpegInstance () from /usr/lib/libexiv2.so.5
#8  0xb509933a in Exiv2::ImageFactory::open () from /usr/lib/libexiv2.so.5
#9  0xb5099766 in Exiv2::ImageFactory::open () from /usr/lib/libexiv2.so.5
#10 0xb77fd4a3 in KExiv2Iface::KExiv2::load () from /usr/lib/libkexiv2.so.7
#11 0xb7192e5c in Digikam::DMetadata::load (this=0xb2692c2c, filePath=@0xb2692bb8) at /build/buildd/digikam-0.10.0/libs/dmetadata/dmetadata.cpp:75
#12 0xb7007121 in Digikam::ImageScanner::loadFromDisk (this=0xb2692c24) at /build/buildd/digikam-0.10.0/libs/database/imagescanner.cpp:601
#13 0xb700e312 in Digikam::ImageScanner::newFile (this=0xb2692c24, albumId=0) at /build/buildd/digikam-0.10.0/libs/database/imagescanner.cpp:89
#14 0xb70002ba in Digikam::CollectionScanner::scanNewFile (this=0xb2693314, info=@0xd4f645c, albumId=0) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:592
#15 0xb700184f in Digikam::CollectionScanner::scanAlbum (this=0xb2693314, location=@0xb2693234, album=@0xb2692ec4) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:545
#16 0xb7001758 in Digikam::CollectionScanner::scanAlbum (this=0xb2693314, location=@0xb2693234, album=@0xb2693014) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:556
#17 0xb7001758 in Digikam::CollectionScanner::scanAlbum (this=0xb2693314, location=@0xb2693234, album=@0xb2693164) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:556
#18 0xb7001758 in Digikam::CollectionScanner::scanAlbum (this=0xb2693314, location=@0xb2693234, album=@0xb26931e4) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:556
#19 0xb70022b7 in Digikam::CollectionScanner::scanAlbumRoot (this=0xb2693314, location=@0xb2693234) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:345
#20 0xb7002b33 in Digikam::CollectionScanner::partialScan (this=0xb2693314, albumRoot=@0xb26932c8, album=@0xb26932c4) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:261
#21 0xb7002ff7 in Digikam::CollectionScanner::partialScan (this=0xb2693314, filePath=@0xb269332c) at /build/buildd/digikam-0.10.0/libs/database/collectionscanner.cpp:221
#22 0x0828f374 in Digikam::ScanController::run (this=0x9677ec0) at /build/buildd/digikam-0.10.0/digikam/scancontroller.cpp:441
#23 0xb570b96e in QThreadPrivate::start (arg=0x9677ec0) at thread/qthread_unix.cpp:189
#24 0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#25 0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 7 (Thread 0xb1b29b90 (LWP 15687)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb541e0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55202ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb570c9b2 in QWaitCondition::wait (this=0x97c9e90, mutex=0x97c9e8c, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb71fdd4a in Digikam::LoadSaveThread::run (this=0x97c9e80) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb570b96e in QThreadPrivate::start (arg=0x97c9e80) at thread/qthread_unix.cpp:189
#6  0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 6 (Thread 0xb10ffb90 (LWP 15688)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb541e0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55202ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb570c9b2 in QWaitCondition::wait (this=0x997f700, mutex=0x997f6fc, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb71fdd4a in Digikam::LoadSaveThread::run (this=0x997f6f0) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb570b96e in QThreadPrivate::start (arg=0x997f6f0) at thread/qthread_unix.cpp:189
#6  0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 5 (Thread 0xab7ffb90 (LWP 15722)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb541e0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55202ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb570c9b2 in QWaitCondition::wait (this=0xaabacf8, mutex=0xaabacf4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb71fdd4a in Digikam::LoadSaveThread::run (this=0xaabace8) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb570b96e in QThreadPrivate::start (arg=0xaabace8) at thread/qthread_unix.cpp:189
#6  0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 4 (Thread 0xa9f56b90 (LWP 15730)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb55097b1 in select () from /lib/tls/i686/cmov/libc.so.6
#2  0xb57dd380 in QProcessManager::run (this=0x944eb08) at io/qprocess_unix.cpp:305
#3  0xb570b96e in QThreadPrivate::start (arg=0x944eb08) at thread/qthread_unix.cpp:189
#4  0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5  0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xacdffb90 (LWP 15741)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb541e0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55202ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb570c9b2 in QWaitCondition::wait (this=0x9ba1658, mutex=0x9ba1654, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb71fdd4a in Digikam::LoadSaveThread::run (this=0x9ba1648) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb570b96e in QThreadPrivate::start (arg=0x9ba1648) at thread/qthread_unix.cpp:189
#6  0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xa6ad5b90 (LWP 15742)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb541e0e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb55202ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
#3  0xb570c9b2 in QWaitCondition::wait (this=0xbe35ca8, mutex=0xbe35ca4, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#4  0xb71fdd4a in Digikam::LoadSaveThread::run (this=0xbe35c98) at /build/buildd/digikam-0.10.0/libs/threadimageio/loadsavethread.cpp:131
#5  0xb570b96e in QThreadPrivate::start (arg=0xbe35c98) at thread/qthread_unix.cpp:189
#6  0xb541a4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7  0xb551149e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb46c7920 (LWP 15667)):
#0  0xb7fd1430 in __kernel_vsyscall ()
#1  0xb54cc7a6 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#2  0xb54cc5be in sleep () from /lib/tls/i686/cmov/libc.so.6
#3  0xb69648b2 in KCrash::startDrKonqi (argv=0xbfeecad4, argc=17) at /build/buildd/kde4libs-4.2.2/kdeui/util/kcrash.cpp:412
#4  0xb6965274 in KCrash::defaultCrashHandler (sig=11) at /build/buildd/kde4libs-4.2.2/kdeui/util/kcrash.cpp:337
#5  <signal handler called>
#6  0xb567f30b in __dynamic_cast () from /usr/lib/libstdc++.so.6
#7  0xb6e94536 in ?? () from /usr/lib/libmarblewidget.so.4
#8  0xae00bf5e in ?? () from /usr/lib/kde4/plugins/marble/MarbleGeoDataPlugin.so
#9  0xae00c16b in ?? () from /usr/lib/kde4/plugins/marble/MarbleGeoDataPlugin.so
#10 0xae00b40c in ?? () from /usr/lib/kde4/plugins/marble/MarbleGeoDataPlugin.so
#11 0xae00ac04 in ?? () from /usr/lib/kde4/plugins/marble/MarbleGeoDataPlugin.so
#12 0xb6ea9352 in Marble::LayerManager::renderLayers () from /usr/lib/libmarblewidget.so.4
#13 0xb6e69174 in Marble::MarbleModel::paintGlobe () from /usr/lib/libmarblewidget.so.4
#14 0xb6e725e8 in ?? () from /usr/lib/libmarblewidget.so.4
#15 0xb6e61ac6 in Marble::MarbleWidget::paintEvent () from /usr/lib/libmarblewidget.so.4
#16 0xb5d2791e in QWidget::event (this=0x9d87eb0, event=0xbfeeda54) at kernel/qwidget.cpp:7654
#17 0xb5cd0e9c in QApplicationPrivate::notify_helper (this=0x944b7a0, receiver=0x9d87eb0, e=0xbfeeda54) at kernel/qapplication.cpp:4084
#18 0xb5cd9282 in QApplication::notify (this=0xbfeee6c4, receiver=0x9d87eb0, e=0xbfeeda54) at kernel/qapplication.cpp:4049
#19 0xb68f494d in KApplication::notify (this=0xbfeee6c4, receiver=0x9d87eb0, event=0xbfeeda54) at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:307
#20 0xb57ffa3b in QCoreApplication::notifyInternal (this=0xbfeee6c4, receiver=0x9d87eb0, event=0xbfeeda54) at kernel/qcoreapplication.cpp:602
#21 0xb5cdbfee in QCoreApplication::sendSpontaneousEvent (receiver=0x9d87eb0, event=0x0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#22 0xb5d2f719 in QWidgetPrivate::drawWidget (this=0x9dc4ed8, pdev=0x96b73e4, rgn=@0xbfeedc80, offset=@0xbfeedc50, flags=68, sharedPainter=0x0, backingStore=0x96fc480) at kernel/qwidget.cpp:5046
#23 0xb5eebfc5 in QWidgetBackingStore::sync (this=0x96fc480) at painting/qbackingstore.cpp:1258
#24 0xb5eec43d in QWidgetBackingStore::sync (this=0x96fc480, exposedWidget=0xb8140c0, exposedRegion=@0xbfeede80) at painting/qbackingstore.cpp:1073
#25 0xb5d1faf2 in QWidgetPrivate::syncBackingStore (this=0xb859a48, region=@0xbfeede80) at kernel/qwidget.cpp:1612
#26 0xb5d37c6e in QETWidget::translatePaintEvent (this=0xb8140c0, event=0xbfeee3bc) at kernel/qapplication_x11.cpp:5125
#27 0xb5d4744a in QApplication::x11ProcessEvent (this=0xbfeee6c4, event=0xbfeee3bc) at kernel/qapplication_x11.cpp:3443
#28 0xb5d72c6a in x11EventSourceDispatch (s=0x944e968, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#29 0xb4ad5b88 in IA__g_main_context_dispatch (context=0x944d310) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#30 0xb4ad90eb in g_main_context_iterate (context=0x944d310, block=1, dispatch=1, self=0x944b9c8) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#31 0xb4ad9268 in IA__g_main_context_iteration (context=0x944d310, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#32 0xb582b438 in QEventDispatcherGlib::processEvents (this=0x94375c0, flags={i = -1074862728}) at kernel/qeventdispatcher_glib.cpp:323
#33 0xb5d72365 in QGuiEventDispatcherGlib::processEvents (this=0x94375c0, flags={i = -1074862680}) at kernel/qguieventdispatcher_glib.cpp:202
#34 0xb57fe06a in QEventLoop::processEvents (this=0xbfeee620, flags={i = -1074862616}) at kernel/qeventloop.cpp:149
#35 0xb57fe4aa in QEventLoop::exec (this=0xbfeee620, flags={i = -1074862552}) at kernel/qeventloop.cpp:200
#36 0xb5800959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#37 0xb5cd0d17 in QApplication::exec () at kernel/qapplication.cpp:3553
#38 0x082b4e3b in main (argc=5, argv=0xbfeee924) at /build/buildd/digikam-0.10.0/digikam/main.cpp:190
#0  0xb7fd1430 in __kernel_vsyscall ()
Comment 1 caulier.gilles 2009-05-19 12:59:38 UTC
The backtrace said marble crash...

Gilles Caulier
Comment 2 noeck 2009-05-19 13:03:31 UTC
it only happens when the map on the right side in digikam is opened (geo-localization).
Comment 3 caulier.gilles 2009-05-19 13:06:17 UTC
yes, and it's marble widget...

compile and install marble with debug and re-run digiKam in GDB to see where is the problem

Gilles Caulier
Comment 4 noeck 2009-05-20 14:43:24 UTC
Here is a more detailed description of the problem:

The title of this bug should be corrected: 
digikam crashes when changing album while viewing the map

I compiled and installed marble with debug and used GDB.
The crash was reproduced very quickly because it always happens when I change the album while the map on the right side (geo location) is shown and some of the new pictures are selected.

Here is what GDB says, first the run-command and then bt. I hope that helps to find the reason of this problem:

$ gdb digikam
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(gdb) run
Starting program: /usr/bin/digikam 
[Thread debugging using libthread_db enabled]
[New Thread 0xb4794920 (LWP 16975)]
[New Thread 0xb275eb90 (LWP 17077)]
[New Thread 0xb1c09b90 (LWP 17081)]
[Thread 0xb1c09b90 (LWP 17081) exited]
[New Thread 0xb1c09b90 (LWP 17109)]
[New Thread 0xb137cb90 (LWP 17110)]
[New Thread 0xaea20b90 (LWP 17112)]
[Thread 0xaea20b90 (LWP 17112) exited]
digikam(16975) Phonon::KdePlatformPlugin::createBackend: using backend:  "GStreamer"
[New Thread 0xaea20b90 (LWP 17113)]
[Thread 0xaea20b90 (LWP 17113) exited]
[New Thread 0xaea20b90 (LWP 17114)]
[Thread 0xaea20b90 (LWP 17114) exited]
[New Thread 0xaea20b90 (LWP 17115)]
[Thread 0xaea20b90 (LWP 17115) exited]
[New Thread 0xaea20b90 (LWP 17116)]
[New Thread 0xaa15bb90 (LWP 17122)]
[Thread 0xaea20b90 (LWP 17116) exited]
[Thread 0xaa15bb90 (LWP 17122) exited]
Starting to load Plugins. 
=== MarbleDirs: === 
Local Path: "/home/joram/.marble/data" 
Plugin Local Path: "/home/joram/.marble/plugins" 
 
Marble Data Path (Run Time) : "" 
Marble Data Path (Compile Time): "/usr/local/share/apps/marble/data" 
 
Marble Plugin Path (Run Time) : "" 
Marble Plugin Path (Compile Time): "/usr/local/lib/kde4/plugins/marble" 
 
System Path: "/usr/local/share/apps/marble/data" 
Plugin System Path: "/usr/local/lib/kde4/plugins/marble" 
=================== 
"CompassFloatItem.so"  -  "/usr/local/lib/kde4/plugins/marble/CompassFloatItem.so" 
loading:  Marble::CompassFloatItem(0x9569758) Marble::CompassFloatItem(0x9569cb0) 
"MapScaleFloatItem.so"  -  "/usr/local/lib/kde4/plugins/marble/MapScaleFloatItem.so" 
loading:  Marble::MapScaleFloatItem(0x9569f08) Marble::MapScaleFloatItem(0x9579f00) 
"MarbleCrosshairsPlugin.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleCrosshairsPlugin.so" 
loading:  Marble::MarbleCrosshairsPlugin(0x95684b0) Marble::MarbleCrosshairsPlugin(0x957c3e8) 
"MarbleGeoDataPlugin.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleGeoDataPlugin.so" 
loading:  Marble::MarbleGeoDataPlugin(0x957bd98) Marble::MarbleGeoDataPlugin(0x957ae08) 
"MarbleOverviewMap.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleOverviewMap.so" 
loading:  Marble::MarbleOverviewMap(0x95735a8) Marble::MarbleOverviewMap(0x95742a8) 
"MarbleStarsPlugin.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleStarsPlugin.so" 
loading:  Marble::MarbleStarsPlugin(0x9579e38) Marble::MarbleStarsPlugin(0x9574288) 
"NavigationFloatItem.so"  -  "/usr/local/lib/kde4/plugins/marble/NavigationFloatItem.so" 
loading:  Marble::NavigationFloatItem(0x9574bb8) Marble::NavigationFloatItem(0x9574d00) 
Time elapsed: 1158 ms
[New Thread 0xaa15bb90 (LWP 17135)]
[New Thread 0xaea20b90 (LWP 17136)]
[New Thread 0xae142b90 (LWP 17137)]
[Thread 0xae142b90 (LWP 17137) exited]
[New Thread 0xae142b90 (LWP 17138)]
[New Thread 0xad7ffb90 (LWP 17139)]
[New Thread 0xacffeb90 (LWP 17140)]
[Thread 0xae142b90 (LWP 17138) exited]
[New Thread 0xac5ffb90 (LWP 17141)]
[New Thread 0xae142b90 (LWP 17142)]
[Thread 0xad7ffb90 (LWP 17139) exited]
[New Thread 0xad7ffb90 (LWP 17143)]
[Thread 0xae142b90 (LWP 17142) exited]
[Thread 0xad7ffb90 (LWP 17143) exited]
Use workaround:  0 
[Thread 0xacffeb90 (LWP 17140) exited]
loadMapTheme "earth/citylights/citylights.dgml" 
[Thread 0xac5ffb90 (LWP 17141) exited]
loadMapTheme "earth/bluemarble/bluemarble.dgml" 
[Thread 0xaea20b90 (LWP 17136) exited]
MapThemeId "earth/srtm/srtm.dgml" 
loadMapTheme "earth/srtm/srtm.dgml" 
[Thread 0xaa15bb90 (LWP 17135) exited]
DGML2 Name       :  "Atlas" 
adding container: "cityplacemarks.kml" false 
[New Thread 0xaa15bb90 (LWP 17144)]
starting parser for "cityplacemarks" 
adding container: "baseplacemarks.kml" false 
[New Thread 0xaea20b90 (LWP 17145)]
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/cityplacemarks.cache" 
starting parser for "baseplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/baseplacemarks.cache" 
Loading ended true 
[Thread 0xaea20b90 (LWP 17145) exited]
adding container: "elevplacemarks.kml" false 
[New Thread 0xaea20b90 (LWP 17146)]
starting parser for "elevplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/elevplacemarks.cache" 
Loading ended true 
[Thread 0xaea20b90 (LWP 17146) exited]
adding container: "otherplacemarks.kml" false 
[New Thread 0xaea20b90 (LWP 17147)]
starting parser for "otherplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/otherplacemarks.cache" 
Loading ended true 
[Thread 0xaea20b90 (LWP 17147) exited]
adding container: "boundaryplacemarks" true 
[New Thread 0xaea20b90 (LWP 17148)]
starting parser for "boundaryplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/boundaryplacemarks.cache" 
Loading ended true 
[Thread 0xaea20b90 (LWP 17148) exited]
TextureColorizer: Time elapsed: 207 ms
THEME CHANGED: *** "earth/srtm/srtm.dgml" 
SunLocator::setBody( QString ) 
Loading ended true 
[Thread 0xaa15bb90 (LWP 17144) exited]
[New Thread 0xaa15bb90 (LWP 17149)]
Starting to load Plugins. 
=== MarbleDirs: === 
Local Path: "/home/joram/.marble/data" 
Plugin Local Path: "/home/joram/.marble/plugins" 
 
Marble Data Path (Run Time) : "" 
Marble Data Path (Compile Time): "/usr/local/share/apps/marble/data" 
 
Marble Plugin Path (Run Time) : "" 
Marble Plugin Path (Compile Time): "/usr/local/lib/kde4/plugins/marble" 
 
System Path: "/usr/local/share/apps/marble/data" 
Plugin System Path: "/usr/local/lib/kde4/plugins/marble" 
=================== 
"CompassFloatItem.so"  -  "/usr/local/lib/kde4/plugins/marble/CompassFloatItem.so" 
loading:  Marble::CompassFloatItem(0x9569758) Marble::CompassFloatItem(0xad720f8) 
"MapScaleFloatItem.so"  -  "/usr/local/lib/kde4/plugins/marble/MapScaleFloatItem.so" 
loading:  Marble::MapScaleFloatItem(0x9569f08) Marble::MapScaleFloatItem(0xad72af8) 
"MarbleCrosshairsPlugin.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleCrosshairsPlugin.so" 
loading:  Marble::MarbleCrosshairsPlugin(0x95684b0) Marble::MarbleCrosshairsPlugin(0xad73888) 
"MarbleGeoDataPlugin.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleGeoDataPlugin.so" 
loading:  Marble::MarbleGeoDataPlugin(0x957bd98) Marble::MarbleGeoDataPlugin(0xad72128) 
"MarbleOverviewMap.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleOverviewMap.so" 
loading:  Marble::MarbleOverviewMap(0x95735a8) Marble::MarbleOverviewMap(0xad73720) 
"MarbleStarsPlugin.so"  -  "/usr/local/lib/kde4/plugins/marble/MarbleStarsPlugin.so" 
loading:  Marble::MarbleStarsPlugin(0x9579e38) Marble::MarbleStarsPlugin(0xad734a8) 
"NavigationFloatItem.so"  -  "/usr/local/lib/kde4/plugins/marble/NavigationFloatItem.so" 
loading:  Marble::NavigationFloatItem(0x9574bb8) Marble::NavigationFloatItem(0xad81030) 
Time elapsed: 111 ms
Use workaround:  0 
loadMapTheme "earth/citylights/citylights.dgml" 
loadMapTheme "earth/bluemarble/bluemarble.dgml" 
MapThemeId "earth/srtm/srtm.dgml" 
loadMapTheme "earth/srtm/srtm.dgml" 
DGML2 Name       :  "Atlas" 
adding container: "cityplacemarks.kml" false 
[New Thread 0xaea20b90 (LWP 17150)]
starting parser for "cityplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/cityplacemarks.cache" 
adding container: "baseplacemarks.kml" false 
[New Thread 0xac5ffb90 (LWP 17151)]
starting parser for "baseplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/baseplacemarks.cache" 
Loading ended true 
[Thread 0xac5ffb90 (LWP 17151) exited]
adding container: "elevplacemarks.kml" false 
[New Thread 0xac5ffb90 (LWP 17152)]
starting parser for "elevplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/elevplacemarks.cache" 
Loading ended true 
[Thread 0xac5ffb90 (LWP 17152) exited]
adding container: "otherplacemarks.kml" false 
[New Thread 0xac5ffb90 (LWP 17153)]
starting parser for "otherplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/otherplacemarks.cache" 
Loading ended true 
[Thread 0xac5ffb90 (LWP 17153) exited]
adding container: "boundaryplacemarks" true 
[New Thread 0xac5ffb90 (LWP 17154)]
starting parser for "boundaryplacemarks" 
"Loading Default Placemark Cache File:/usr/local/share/apps/marble/data/placemarks/boundaryplacemarks.cache" 
THEME CHANGED: *** "earth/srtm/srtm.dgml" 
SunLocator::setBody( QString ) 
Loading ended true 
[Thread 0xac5ffb90 (LWP 17154) exited]
Loading ended true 
[Thread 0xaea20b90 (LWP 17150) exited]
Style reset requested. 
Style reset requested. 
Style reset requested. 
Style reset requested. 
start generate indexes 
generated indexes 
MarblePlacemarkModel (generateIndex): Time elapsed: 39 ms 
Style reset requested. 
Style reset requested. 
Style reset requested. 
Style reset requested. 
Style reset requested. 
Style reset requested. 
start generate indexes 
generated indexes 
MarblePlacemarkModel (generateIndex): Time elapsed: 38 ms 
Style reset requested. 
Style reset requested. 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
[New Thread 0xaea20b90 (LWP 17155)]
digikam(16975): Attempt to use QAction "camera_solid" with KXMLGUIFactory! 
digikam(16975): Attempt to use QAction "usb_media" with KXMLGUIFactory! 
digikam(16975): Attempt to use QAction "card_reader" with KXMLGUIFactory! 
digikam(16975): Attempt to use QAction "camera_addedmanually" with KXMLGUIFactory! 
[New Thread 0xac5ffb90 (LWP 17171)]
[New Thread 0xacffeb90 (LWP 17172)]
[Thread 0xaea20b90 (LWP 17155) exited]
timeChanged 
void SunLocator::update() 
RESET started 
RESET stopped 
Detecting maxLabelHeight ... 
adding container: "data" 
[New Thread 0xaea20b90 (LWP 17216)]
[Thread 0xaea20b90 (LWP 17216) exited]
resetting the base of the Geometry model 0xba5d6f8 
start generate indexes 
generated indexes 
MarblePlacemarkModel (generateIndex): Time elapsed: 290 ms 
Style reset requested. 
Style reset requested. 
RESET started 
RESET stopped 
Detecting maxLabelHeight ... 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
[New Thread 0xaea20b90 (LWP 17813)]
timeChanged 
void SunLocator::update() 
[Thread 0xaea20b90 (LWP 17813) exited]
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
timeChanged 
void SunLocator::update() 
libpng error: Read Error
adding container: "data" 
[New Thread 0xaea20b90 (LWP 18592)]
[Thread 0xaea20b90 (LWP 18592) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb4794920 (LWP 16975)]
0xb574c30b in __dynamic_cast () from /usr/lib/libstdc++.so.6
(gdb) bt
#0  0xb574c30b in __dynamic_cast () from /usr/lib/libstdc++.so.6
#1  0xb6f59fce in Marble::MarbleGeometryModel::data (this=0x9b3a9b0, 
    index=@0xbfea3054, role=0)
    at /home/joram/Desktop/marble/marble/src/lib/MarbleGeometryModel.cpp:161
#2  0xae20b07d in Marble::MarbleGeoDataView::renderIndex (this=0x9574c68, 
    index=@0xbfea30b4)
    at /home/joram/Desktop/marble/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:91
#3  0xae20b369 in Marble::MarbleGeoDataView::paintEvent (this=0x9574c68, 
    event=0x0)
    at /home/joram/Desktop/marble/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:77
#4  0xae20a79d in Marble::MarbleGeoDataView::setGeoPainter (this=0x9574c68, 
    painter=0xbfea33a0)
    at /home/joram/Desktop/marble/marble/src/plugins/render/geodata/MarbleGeoDataView.cpp:42
#5  0xae209d12 in Marble::MarbleGeoDataPlugin::render (this=0x957ae08, 
    painter=0xbfea33a0, viewport=0x952a18c, renderPos=@0xbfea31a8, layer=0x0)
    at /home/joram/Desktop/marble/marble/src/plugins/render/geodata/MarbleGeoDataPlugin.cpp:102
#6  0xb6f6b069 in Marble::LayerManager::renderLayers (this=0x9567f48, 
    painter=0xbfea33a0, viewParams=0x9567774)
    at /home/joram/Desktop/marble/marble/src/lib/LayerManager.cpp:92
---Type <return> to continue, or q <return> to quit---
#7  0xb6f347f7 in Marble::MarbleModel::paintGlobe (this=0x9567d28, 
    painter=0xbfea33a0, width=324, height=767, viewParams=0x9567774, 
    redrawBackground=true, dirtyRect=@0xbfea3390)
    at /home/joram/Desktop/marble/marble/src/lib/MarbleModel.cpp:700
#8  0xb6f3c438 in Marble::MarbleMapPrivate::paintGround (this=0x9567760, 
    painter=@0xbfea33a0, dirtyRect=@0xbfea3390)
    at /home/joram/Desktop/marble/marble/src/lib/MarbleMap.cpp:290
#9  0xb6f2e851 in Marble::MarbleWidget::paintEvent (this=0x952a4e0, 
    evt=0xbfea3844)
    at /home/joram/Desktop/marble/marble/src/lib/MarbleWidget.cpp:844
#10 0xb5df491e in QWidget::event (this=0x952a4e0, event=0xbfea3844)
    at kernel/qwidget.cpp:7654
#11 0xb5d9de9c in QApplicationPrivate::notify_helper (this=0x8c1b540, 
    receiver=0x952a4e0, e=0xbfea3844) at kernel/qapplication.cpp:4084
#12 0xb5da6282 in QApplication::notify (this=0xbfea4a14, receiver=0x952a4e0, 
    e=0xbfea3844) at kernel/qapplication.cpp:4049
#13 0xb69c194d in KApplication::notify (this=0xbfea4a14, receiver=0x952a4e0, 
    event=0xbfea3844)
    at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:307
#14 0xb58cca3b in QCoreApplication::notifyInternal (this=0xbfea4a14, 
    receiver=0x952a4e0, event=0xbfea3844) at kernel/qcoreapplication.cpp:602
#15 0xb5da8fee in QCoreApplication::sendSpontaneousEvent (receiver=0x952a4e0, 
    event=0x0)
---Type <return> to continue, or q <return> to quit---
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#16 0xb5dfc719 in QWidgetPrivate::drawWidget (this=0x9567598, pdev=0x8e83c4c, 
    rgn=@0xbfea3a70, offset=@0xbfea3a40, flags=68, sharedPainter=0x0, 
    backingStore=0x8e67ca0) at kernel/qwidget.cpp:5046
#17 0xb5fb8fc5 in QWidgetBackingStore::sync (this=0x8e67ca0)
    at painting/qbackingstore.cpp:1258
#18 0xb5decbb6 in QWidgetPrivate::syncBackingStore (this=0x8f8b368)
    at kernel/qwidget.cpp:1603
#19 0xb5df4d85 in QWidget::event (this=0x8f9cfb8, event=0xbfea40a0)
    at kernel/qwidget.cpp:7794
#20 0xb61ec0d7 in QMainWindow::event (this=0x8f9cfb8, event=0xbfea40a0)
    at widgets/qmainwindow.cpp:1396
#21 0xb6aa5327 in KMainWindow::event (this=0x8f9cfb8, ev=0xbfea40a0)
    at /build/buildd/kde4libs-4.2.2/kdeui/widgets/kmainwindow.cpp:1094
#22 0xb6aea10c in KXmlGuiWindow::event (this=0x8f9cfb8, ev=0xbfea40a0)
    at /build/buildd/kde4libs-4.2.2/kdeui/xmlgui/kxmlguiwindow.cpp:131
#23 0xb5d9de9c in QApplicationPrivate::notify_helper (this=0x8c1b540, 
    receiver=0x8f9cfb8, e=0xbfea40a0) at kernel/qapplication.cpp:4084
#24 0xb5da6282 in QApplication::notify (this=0xbfea4a14, receiver=0x8f9cfb8, 
    e=0xbfea40a0) at kernel/qapplication.cpp:4049
#25 0xb69c194d in KApplication::notify (this=0xbfea4a14, receiver=0x8f9cfb8, 
    event=0xbfea40a0)
    at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:307
---Type <return> to continue, or q <return> to quit---
#26 0xb58cca3b in QCoreApplication::notifyInternal (this=0xbfea4a14, 
    receiver=0x8f9cfb8, event=0xbfea40a0) at kernel/qcoreapplication.cpp:602
#27 0xb5fb64a7 in sendUpdateRequest (widget=0x8f9cfb8, 
    updateImmediately=<value optimized out>)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#28 0xb5fb9837 in QWidgetBackingStore::markDirty (this=0x8e67ca0, 
    rect=@0xbfea41ac, widget=0xa720630, updateImmediately=true, 
    invalidateBuffer=false) at painting/qbackingstore.cpp:650
#29 0xb5defad5 in QWidget::repaint (this=0xa720630, rect=@0xbfea41ac)
    at kernel/qwidget.cpp:9413
#30 0xb7603e94 in Q3ListView::updateDirtyItems (this=0xa5ff770)
    at itemviews/q3listview.cpp:3623
#31 0xb777a528 in Q3ListView::qt_metacall (this=0xa5ff770, 
    _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0xbfea42c8)
    at .moc/release-shared/moc_q3listview.cpp:205
#32 0x08268aef in Digikam::FolderView::qt_metacall (this=0xa5ff770, 
    _c=QMetaObject::InvokeMetaMethod, _id=83, _a=0xbfea42c8)
    at /build/buildd/digikam-0.10.0/obj-i486-linux-gnu/digikam/folderview.moc:69
#33 0x08202b4f in Digikam::AlbumFolderView::qt_metacall (this=0xa5ff770, 
    _c=QMetaObject::InvokeMetaMethod, _id=83, _a=0xbfea42c8)
    at /build/buildd/digikam-0.10.0/obj-i486-linux-gnu/digikam/albumfolderview.moc:90
---Type <return> to continue, or q <return> to quit---
#34 0xb58e2ca8 in QMetaObject::activate (sender=0xa71d658, 
    from_signal_index=4, to_signal_index=4, argv=0x0)
    at kernel/qobject.cpp:3069
#35 0xb58e3932 in QMetaObject::activate (sender=0xa71d658, m=0xb59bf904, 
    local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3143
#36 0xb591e717 in QTimer::timeout (this=0xa71d658)
    at .moc/release-shared/moc_qtimer.cpp:128
#37 0xb58e86fe in QTimer::timerEvent (this=0xa71d658, e=0xbfea474c)
    at kernel/qtimer.cpp:261
#38 0xb58dd15f in QObject::event (this=0xa71d658, e=0xbfea474c)
    at kernel/qobject.cpp:1082
#39 0xb5d9de9c in QApplicationPrivate::notify_helper (this=0x8c1b540, 
    receiver=0xa71d658, e=0xbfea474c) at kernel/qapplication.cpp:4084
#40 0xb5da619e in QApplication::notify (this=0xbfea4a14, receiver=0xa71d658, 
    e=0xbfea474c) at kernel/qapplication.cpp:3631
#41 0xb69c194d in KApplication::notify (this=0xbfea4a14, receiver=0xa71d658, 
    event=0xbfea474c)
    at /build/buildd/kde4libs-4.2.2/kdeui/kernel/kapplication.cpp:307
#42 0xb58cca3b in QCoreApplication::notifyInternal (this=0xbfea4a14, 
    receiver=0xa71d658, event=0xbfea474c) at kernel/qcoreapplication.cpp:602
#43 0xb58fbd71 in QTimerInfoList::activateTimers (this=0x8c1e734)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#44 0xb58f84e0 in timerSourceDispatch (source=0x8c1e700)
---Type <return> to continue, or q <return> to quit---
    at kernel/qeventdispatcher_glib.cpp:164
#45 0xb4ba2b88 in IA__g_main_context_dispatch (context=0x8c1d890)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#46 0xb4ba60eb in g_main_context_iterate (context=0x8c1d890, block=1, 
    dispatch=1, self=0x8c1b778)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#47 0xb4ba6268 in IA__g_main_context_iteration (context=0x8c1d890, may_block=1)
    at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#48 0xb58f8438 in QEventDispatcherGlib::processEvents (this=0x8c075c8, flags=
      {i = -1075164984}) at kernel/qeventdispatcher_glib.cpp:323
#49 0xb5e3f365 in QGuiEventDispatcherGlib::processEvents (this=0x8c075c8, 
    flags={i = -1075164936}) at kernel/qguieventdispatcher_glib.cpp:202
#50 0xb58cb06a in QEventLoop::processEvents (this=0xbfea4970, flags=
      {i = -1075164872}) at kernel/qeventloop.cpp:149
#51 0xb58cb4aa in QEventLoop::exec (this=0xbfea4970, flags={i = -1075164808})
    at kernel/qeventloop.cpp:200
#52 0xb58cd959 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:880
#53 0xb5d9dd17 in QApplication::exec () at kernel/qapplication.cpp:3553
#54 0x082b4e3b in main (argc=1, argv=0xbfea4c74)
    at /build/buildd/digikam-0.10.0/digikam/main.cpp:190
Comment 5 caulier.gilles 2009-05-20 14:58:40 UTC
It's definitively a marble crash. I forward to marble team for investigations...

Gilles Caulier
Comment 6 noeck 2009-05-20 15:24:56 UTC
*** Bug 191825 has been marked as a duplicate of this bug. ***
Comment 7 Dario Andres 2009-05-23 15:00:14 UTC
Marking as duplicate of bug 182470. Thanks

*** This bug has been marked as a duplicate of bug 182470 ***