Bug 193223 - crash after closing the program
Summary: crash after closing the program
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: lokalize
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-19 12:21 UTC by Christoph Thielecke
Modified: 2009-05-19 13:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2009-05-19 12:21:51 UTC
Application that crashed: lokalize
Version of the application: 1.0
KDE Version: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514))
Qt Version: 4.5.0
Operating System: Linux 2.6.27-14-generic i686
Distribution: Ubuntu 8.10

What I was doing when the application crashed:
I open an po file. Next, I click on 'manage translation memories' and close the dialog later. Last step I close the program and this was resulting in a crash.

 -- Backtrace:
Application: Lokalize (lokalize), signal: Aborted
[Current thread is 0 (LWP 30538)]

Thread 2 (Thread 0xadbcdb90 (LWP 30540)):
#0  0xb7fc3430 in __kernel_vsyscall ()
#1  0xb693f075 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
#2  0xb69c6982 in QWaitCondition::wait (this=0x8e5c1f0, mutex=0x8e5bfa0, time=4294967295) at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/thread/qwaitcondition_unix.cpp:87
#3  0xb7896698 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x8e5c1d8, th=0xa0a30f8) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0xb789943c in ThreadWeaver::WorkingHardState::waitForAvailableJob (this=0x8e5bef8, th=0xa0a30f8) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:80
#5  0xb789527b in ThreadWeaver::WeaverImpl::waitForAvailableJob (this=0x8e5c1d8, th=0xa0a30f8) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:356
#6  0xb789953a in ThreadWeaver::WorkingHardState::applyForWork (this=0x8e5bef8, th=0xa0a30f8) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/WorkingHardState.cpp:71
#7  0xb7896c23 in ThreadWeaver::WeaverImpl::applyForWork (this=0x8e5c1d8, th=0xa0a30f8, previous=0xa256f78) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/WeaverImpl.cpp:351
#8  0xb789750e in ThreadWeaver::ThreadRunHelper::run (this=0xadbcd350, parent=0x8e5c1d8, th=0xa0a30f8) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/Thread.cpp:87
#9  0xb7897b4b in ThreadWeaver::Thread::run (this=0xa0a30f8) at /home/crissi/kdesvn/kdelibs/threadweaver/Weaver/Thread.cpp:142
#10 0xb69c5bc0 in QThreadPrivate::start (arg=0xa0a30f8) at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/thread/qthread_unix.cpp:189
#11 0xb693b50f in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#12 0xb6794a0e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb605e6c0 (LWP 30538)):
[KCrash Handler]
#6  0xb7fc3430 in __kernel_vsyscall ()
#7  0xb66de8a0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb66e0268 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb69be6fd in qt_message_output (msgType=QtFatalMsg, 
    buf=0x8e4d200 "Fatal Error: Accessed global static 'KCatalogStaticData *catalogStaticData()' after destruction. Defined at /home/crissi/kdesvn/kdelibs/kdecore/localization/kcatalog.cpp:69")
    at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2006
#10 0xb69be7b7 in qFatal (msg=0xb75ed0b8 "Fatal Error: Accessed global static '%s *%s()' after destruction. Defined at %s:%d") at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2201
#11 0xb75553bc in KCatalog::operator= (this=0x8dad790, rhs=@0xbfac54a4) at /home/crissi/kdesvn/kdelibs/kdecore/localization/kcatalog.cpp:69
#12 0xb75638d0 in KLocalePrivate::updateCatalogs (this=0x8dc53a0) at /usr/local/qt4/include/QtCore/qlist.h:340
#13 0xb756410c in KLocale::removeCatalog (this=0x8dbc130, catalog=@0xbfac5528) at /home/crissi/kdesvn/kdelibs/kdecore/localization/klocale.cpp:736
#14 0xb74e180b in ~KComponentDataPrivate (this=0x8df6f08) at /home/crissi/kdesvn/kdelibs/kdecore/kernel/kcomponentdata_p.h:50
#15 0xb74e14c0 in ~KComponentData (this=0x8dec3b8) at /home/crissi/kdesvn/kdelibs/kdecore/kernel/kcomponentdata_p.h:70
#16 0xb745c8a9 in ~KConfigPrivate (this=0x8dec388) at /home/crissi/kdesvn/kdelibs/kdecore/config/kconfig_p.h:73
#17 0xb7456c08 in ~KConfig (this=0x8dec100) at /home/crissi/kdesvn/kdelibs/kdecore/config/kconfig.cpp:195
#18 0xb7470dd9 in ~KSharedConfig (this=0x8dec100) at /home/crissi/kdesvn/kdelibs/kdecore/config/ksharedconfig.cpp:74
#19 0xb747536f in ~KCoreConfigSkeleton (this=0x8ded248) at /home/crissi/kdesvn/kdelibs/kdecore/util/ksharedptr.h:90
#20 0xb5fc4db1 in ~OxygenStyleConfigData (this=0x8ded248) at /usr/local/include/kconfigskeleton.h:41
#21 0xb5fc3190 in destroy () at /mnt/data/kde4/kdesvn/build/kdebase/runtime/kstyles/oxygen/oxygenstyleconfigdata.cpp:13
#22 0xb5fc20db in ~KCleanUpGlobalStatic (this=0xb5fc7460) at /usr/local/include/kglobal.h:62
#23 0xb66e1d89 in exit () from /lib/tls/i686/cmov/libc.so.6
#24 0xb66c968d in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#25 0x0806f6c1 in _start ()
Comment 1 Chusslove Illich 2009-05-19 13:17:46 UTC
This should be caused by the same problem as in #191122, which was fixed for all upcoming releases.

*** This bug has been marked as a duplicate of bug 191122 ***