Bug 193219 - crash after looking for devices
Summary: crash after looking for devices
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: Skanlite
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kåre Särs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-19 12:12 UTC by Christoph Thielecke
Modified: 2009-05-19 14:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2009-05-19 12:12:52 UTC
Application that crashed: skanlite
Version of the application: 0.3
KDE Version: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514))
Qt Version: 4.5.0
Operating System: Linux 2.6.27-14-generic i686
Distribution: Ubuntu 8.10

What I was doing when the application crashed:
THe program has been crashed after it looked for devices and none was found.

 -- Backtrace:
Application: Skanlite (skanlite), signal: Aborted
[KCrash Handler]
#6  0xb7f2f430 in __kernel_vsyscall ()
#7  0xb68498a0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb684b268 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb74786fd in qt_message_output (msgType=QtFatalMsg, 
    buf=0x936b1a0 "Fatal Error: Accessed global static 'KCatalogStaticData *catalogStaticData()' after destruction. Defined at /home/crissi/kdesvn/kdelibs/kdecore/localization/kcatalog.cpp:69")
    at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2006
#10 0xb74787b7 in qFatal (msg=0xb786d0b8 "Fatal Error: Accessed global static '%s *%s()' after destruction. Defined at %s:%d") at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2201
#11 0xb77d53bc in KCatalog::operator= (this=0x917d878, rhs=@0xbf82f2b4) at /home/crissi/kdesvn/kdelibs/kdecore/localization/kcatalog.cpp:69
#12 0xb77e38d0 in KLocalePrivate::updateCatalogs (this=0x9153290) at /usr/local/qt4/include/QtCore/qlist.h:340
#13 0xb77e410c in KLocale::removeCatalog (this=0x913ce78, catalog=@0xbf82f338) at /home/crissi/kdesvn/kdelibs/kdecore/localization/klocale.cpp:736
#14 0xb776180b in ~KComponentDataPrivate (this=0x9184b98) at /home/crissi/kdesvn/kdelibs/kdecore/kernel/kcomponentdata_p.h:50
#15 0xb77614c0 in ~KComponentData (this=0x917a018) at /home/crissi/kdesvn/kdelibs/kdecore/kernel/kcomponentdata_p.h:70
#16 0xb76dc8a9 in ~KConfigPrivate (this=0x9179fe8) at /home/crissi/kdesvn/kdelibs/kdecore/config/kconfig_p.h:73
#17 0xb76d6c08 in ~KConfig (this=0x9179d60) at /home/crissi/kdesvn/kdelibs/kdecore/config/kconfig.cpp:195
#18 0xb76f0dd9 in ~KSharedConfig (this=0x9179d60) at /home/crissi/kdesvn/kdelibs/kdecore/config/ksharedconfig.cpp:74
#19 0xb76f536f in ~KCoreConfigSkeleton (this=0x9172dc0) at /home/crissi/kdesvn/kdelibs/kdecore/util/ksharedptr.h:90
#20 0xb6128db1 in ~OxygenStyleConfigData (this=0x9172dc0) at /usr/local/include/kconfigskeleton.h:41
#21 0xb6127190 in destroy () at /mnt/data/kde4/kdesvn/build/kdebase/runtime/kstyles/oxygen/oxygenstyleconfigdata.cpp:13
#22 0xb61260db in ~KCleanUpGlobalStatic (this=0xb612b460) at /usr/local/include/kglobal.h:62
#23 0xb684cd89 in exit () from /lib/tls/i686/cmov/libc.so.6
#24 0x080509ab in Skanlite (this=0x9126590, device=@0xbf82f5e4, parent=0x0) at /home/crissi/kdesvn/extragear/graphics/skanlite/skanlite.cpp:99
#25 0x0804de3c in main (argc=5, argv=0xbf82f754) at /home/crissi/kdesvn/extragear/graphics/skanlite/main.cpp:78
Comment 1 Chusslove Illich 2009-05-19 13:17:29 UTC
This should be caused by the same problem as in #191122, which was fixed for all upcoming releases.

*** This bug has been marked as a duplicate of bug 191122 ***
Comment 2 Kåre Särs 2009-05-19 13:40:54 UTC
How on earth did you notice this bug and recognize that it probably is the same problem as #191122? I'm totally amazed :)
Comment 3 Chusslove Illich 2009-05-19 14:30:06 UTC
It wasn't me who noticed it, but it was brought to my attention since I'm the culprit :) (By now, after several reports, a positive telltale is the KCatalog:: something right before it goes into Qt code and below.)