Bug 193218 - crash on close after looking for device
Summary: crash on close after looking for device
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-19 12:11 UTC by Christoph Thielecke
Modified: 2009-05-19 13:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2009-05-19 12:11:16 UTC
Application that crashed: kopier
Version of the application: 0.1
KDE Version: 4.2.86 (KDE 4.2.86 (KDE 4.3 >= 20090514))
Qt Version: 4.5.0
Operating System: Linux 2.6.27-14-generic i686
Distribution: Ubuntu 8.10

What I was doing when the application crashed:
After I looked for devices and no devices found i close the app and it crashed.

 -- Backtrace:
Application: Kopier (kopier), signal: Aborted
[KCrash Handler]
#6  0xb80b7430 in __kernel_vsyscall ()
#7  0xb69d18a0 in raise () from /lib/tls/i686/cmov/libc.so.6
#8  0xb69d3268 in abort () from /lib/tls/i686/cmov/libc.so.6
#9  0xb76006fd in qt_message_output (msgType=QtFatalMsg, 
    buf=0x9070748 "Fatal Error: Accessed global static 'KCatalogStaticData *catalogStaticData()' after destruction. Defined at /home/crissi/kdesvn/kdelibs/kdecore/localization/kcatalog.cpp:69")
    at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2006
#10 0xb76007b7 in qFatal (msg=0xb79f50b8 "Fatal Error: Accessed global static '%s *%s()' after destruction. Defined at %s:%d") at /mnt/data/kde4/kdesvn/qt-copy/src/corelib/global/qglobal.cpp:2201
#11 0xb795d3bc in KCatalog::operator= (this=0x8e1d948, rhs=@0xbfcb7444) at /home/crissi/kdesvn/kdelibs/kdecore/localization/kcatalog.cpp:69
#12 0xb796b8d0 in KLocalePrivate::updateCatalogs (this=0x8def7b8) at /usr/local/qt4/include/QtCore/qlist.h:340
#13 0xb796c10c in KLocale::removeCatalog (this=0x8e1b090, catalog=@0xbfcb74c8) at /home/crissi/kdesvn/kdelibs/kdecore/localization/klocale.cpp:736
#14 0xb78e980b in ~KComponentDataPrivate (this=0x8df96c0) at /home/crissi/kdesvn/kdelibs/kdecore/kernel/kcomponentdata_p.h:50
#15 0xb78e94c0 in ~KComponentData (this=0x8e05ea8) at /home/crissi/kdesvn/kdelibs/kdecore/kernel/kcomponentdata_p.h:70
#16 0xb78648a9 in ~KConfigPrivate (this=0x8e05e78) at /home/crissi/kdesvn/kdelibs/kdecore/config/kconfig_p.h:73
#17 0xb785ec08 in ~KConfig (this=0x8df9550) at /home/crissi/kdesvn/kdelibs/kdecore/config/kconfig.cpp:195
#18 0xb7878dd9 in ~KSharedConfig (this=0x8df9550) at /home/crissi/kdesvn/kdelibs/kdecore/config/ksharedconfig.cpp:74
#19 0xb787d36f in ~KCoreConfigSkeleton (this=0x8df69f0) at /home/crissi/kdesvn/kdelibs/kdecore/util/ksharedptr.h:90
#20 0xb62b0db1 in ~OxygenStyleConfigData (this=0x8df69f0) at /usr/local/include/kconfigskeleton.h:41
#21 0xb62af190 in destroy () at /mnt/data/kde4/kdesvn/build/kdebase/runtime/kstyles/oxygen/oxygenstyleconfigdata.cpp:13
#22 0xb62ae0db in ~KCleanUpGlobalStatic (this=0xb62b3460) at /usr/local/include/kglobal.h:62
#23 0xb69d4d89 in exit () from /lib/tls/i686/cmov/libc.so.6
#24 0xb69bc68d in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#25 0x08050d71 in _start ()
Comment 1 Chusslove Illich 2009-05-19 13:17:10 UTC
This should be caused by the same problem as in #191122, which was fixed for all upcoming releases.

*** This bug has been marked as a duplicate of bug 191122 ***