Bug 192870 - Switching desktops moves windows in the wrong direction
Summary: Switching desktops moves windows in the wrong direction
Status: RESOLVED DUPLICATE of bug 185710
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-16 13:18 UTC by Andreas Pietzowski
Modified: 2009-05-16 14:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Pietzowski 2009-05-16 13:18:09 UTC
Version:            (using KDE 4.2.3)
OS:                Linux
Installed from:    Ubuntu Packages

I have 6 virtual desktops set up in my KDE. They are arranged in the panel pager as follows:

1 2 3
4 5 6

When I roll the wheel over the pager the active desktop gets changed and the desktop effect slides the windows over the screen. This is neat but there are some geometrically errors in the window moving. E.g. when I switch from desktop 1 to desktop 6 the windows should physically move away (and also in) from right bottom to left top. But instead they are moving from left bottom to right top. The same error occurs when switching from desktop 3 to 4. The windows should move from left bottom to right top. Instead they are moving from right bottom to left top.

Seems like an easy bug ;-) Thanks for fixing. ~Andreas
Comment 1 Marco Martin 2009-05-16 13:22:14 UTC
looks as a kwin issue to me
Comment 2 Martin Flöser 2009-05-16 13:55:34 UTC

*** This bug has been marked as a duplicate of bug 185710 ***