Bug 192671 - Notifier should support default action
Summary: Notifier should support default action
Status: RESOLVED DUPLICATE of bug 164053
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-devicenotifier (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Alexis MENARD
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-14 16:01 UTC by Patrick O'Callaghan
Modified: 2009-08-05 22:00 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick O'Callaghan 2009-05-14 16:01:42 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Fedora RPMs

In the current implementation it needs three mouse clicks to mount a drive.

On inserting a pendrive, the notifier pop-up shows all hot-plug devices (not just the one recently inserted). I then have to click on the device and get another pop-up, this time offering several possibilities. Since I always want Dolphin, I need to select it (second click) and then click a third time on OK.

There should be a way to mark one of choices as a preselected default. Failing that, at least re-order the list to put Dolphin at the top rather than Digikam.

It would also be useful for one of the actions to simply mount the drive without opening any application.
Comment 1 Anne Wilson 2009-05-14 16:52:16 UTC
The current requirement for these mouseclicks is an annoyance rather than a showstopper, but an annoyance none-the-less.  I wonder whether the OK is actually needed at all?  Unlike checkboxes, this is a single-selection situation.

I definitely add a +1 for the request for a Mount-only option.
Comment 2 Moritz Moeller-Herrmann 2009-08-05 22:00:57 UTC

*** This bug has been marked as a duplicate of bug 164053 ***