Bug 192466 - kmail certificates do not correspond to those shown in kleopatra
Summary: kmail certificates do not correspond to those shown in kleopatra
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.11.3
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-12 19:59 UTC by mattm3a
Modified: 2015-04-12 10:20 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mattm3a 2009-05-12 19:59:45 UTC
Version:           1.11.3 (using 4.2.3 (KDE 4.2.3) "release 118", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27.21-0.1-pae

The use of certificates is confusing in kmail. I have an email provider that uses a self-signed certificate for their imap server. Importing the certificate into kleopatra (Tools->Certificate Manager) does not make kmail trust the certificate. Specifically, the server certificate is alerted to be untrusted when checking mail. Adding the certificate through kmail when checking successfully adds trust for the certificate. Also removing the certificate from kleopatra has no effect on kmail's use of the certificate. 

In short, the certificate manager kleopatra seems completely independent from the kmail certificates. How does one manage the kmail certificates? I'm unsure what the intended behavior is, but this seems either incorrect or just very confusing.
Comment 1 Karl-Johan Karlsson 2010-03-13 20:35:58 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 Laurent Montel 2015-04-12 10:20:25 UTC
Thank you for taking the time to file a bug report.

KMail2 was released in 2011, and the entire code base went through significant changes. We are currently in the process of porting to Qt5 and KF5. It is unlikely that these bugs are still valid in KMail2.

We welcome you to try out KMail 2 with the KDE 4.14 release and give your feedback.